summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2021-01-02 10:17:19 +0100
committerUlrich Müller <ulm@gentoo.org>2021-01-02 10:17:49 +0100
commit1ae3e0e2c187a73cf53eb7e1d329ab8322abca00 (patch)
treeceb359dd2f6f7806b0f3c73e212b6775fec7caf6
parentdev-python/flufl-i18n: Bump to 3.1.4 (diff)
downloadgentoo-1ae3e0e2c187a73cf53eb7e1d329ab8322abca00.tar.gz
gentoo-1ae3e0e2c187a73cf53eb7e1d329ab8322abca00.tar.bz2
gentoo-1ae3e0e2c187a73cf53eb7e1d329ab8322abca00.zip
app-emacs/markdown-mode: Version bump to 2.4
Closes: https://bugs.gentoo.org/763042 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
-rw-r--r--app-emacs/markdown-mode/Manifest1
-rw-r--r--app-emacs/markdown-mode/files/markdown-mode-2.4-markdown-command.patch14
-rw-r--r--app-emacs/markdown-mode/markdown-mode-2.4.ebuild28
3 files changed, 43 insertions, 0 deletions
diff --git a/app-emacs/markdown-mode/Manifest b/app-emacs/markdown-mode/Manifest
index 4cfeb84fe301..bb12eeefa18a 100644
--- a/app-emacs/markdown-mode/Manifest
+++ b/app-emacs/markdown-mode/Manifest
@@ -1 +1,2 @@
DIST markdown-mode-2.3.el 387130 BLAKE2B acb583126a6f952835537f9e386df5f9a8fda5e49a14520e153c0cc99fc58cca596607b282f9f7070b001fe8165d50adb9abb81de1b03ae102cf2061de587810 SHA512 0820c5ae585e0f5ee8fef9eca40f2de2ad632a2559ea7f447cd19ded592de38bf2f3df8491796c15eb06723fe2af904335535af145356c7a7f9f855612263aaf
+DIST markdown-mode-2.4.tar.gz 211229 BLAKE2B 49a369d1b418634449cdac3103e1b107b5dd839edba6a3329539b80cf21bfb0f01aa436ec6deb256bfb5f03ef73b716943730adc4a87b52262dfccbd7923556e SHA512 8bf2acd7f402c036c57521340d26cea150935964f04f1343c2e17147d63226c815150be62c0b79a2ba48e55b3155d94f38caf1ec43c21d4f32dee6e73cc261a0
diff --git a/app-emacs/markdown-mode/files/markdown-mode-2.4-markdown-command.patch b/app-emacs/markdown-mode/files/markdown-mode-2.4-markdown-command.patch
new file mode 100644
index 000000000000..1ae481d6c094
--- /dev/null
+++ b/app-emacs/markdown-mode/files/markdown-mode-2.4-markdown-command.patch
@@ -0,0 +1,14 @@
+dev-python/markdown2 and dev-python/markdown install their commands
+as markdown2 and markdown_py, respectively.
+
+--- markdown-mode-2.4-orig/markdown-mode.el
++++ markdown-mode-2.4/markdown-mode.el
+@@ -90,7 +90,7 @@
+ :group 'text
+ :link '(url-link "https://jblevins.org/projects/markdown-mode/"))
+
+-(defcustom markdown-command (let ((command (cl-loop for cmd in '("markdown" "pandoc")
++(defcustom markdown-command (let ((command (cl-loop for cmd in '("markdown" "pandoc" "markdown2" "markdown_py")
+ when (executable-find cmd)
+ return (file-name-nondirectory it))))
+ (or command "markdown"))
diff --git a/app-emacs/markdown-mode/markdown-mode-2.4.ebuild b/app-emacs/markdown-mode/markdown-mode-2.4.ebuild
new file mode 100644
index 000000000000..79c7e94ef8f5
--- /dev/null
+++ b/app-emacs/markdown-mode/markdown-mode-2.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+NEED_EMACS=25.1
+
+inherit elisp
+
+DESCRIPTION="Major mode for editing Markdown-formatted text files"
+HOMEPAGE="https://jblevins.org/projects/markdown-mode/"
+SRC_URI="https://github.com/jrblevin/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="|| (
+ app-text/pandoc
+ dev-python/markdown2
+ dev-python/markdown
+ )"
+BDEPEND="test? ( app-text/pandoc )"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.4-markdown-command.patch )
+SITEFILE="50${PN}-gentoo.el"
+DOCS="CHANGES.md CONTRIBUTING.md README.md"