summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-01-28 18:42:17 +0100
committerMaciej Barć <xgqt@gentoo.org>2022-01-28 18:43:11 +0100
commit1aec768d3faa6ed552c7704115a5f9b1cd1deab2 (patch)
tree03a6cd7380b7390749fdf0b9706fd4051d48afd4
parentapp-accessibility/brltty: 6.4 bump (diff)
downloadgentoo-1aec768d.tar.gz
gentoo-1aec768d.tar.bz2
gentoo-1aec768d.zip
sci-mathematics/coq: bump to 8.15.0
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--sci-mathematics/coq/Manifest1
-rw-r--r--sci-mathematics/coq/coq-8.15.0.ebuild106
2 files changed, 107 insertions, 0 deletions
diff --git a/sci-mathematics/coq/Manifest b/sci-mathematics/coq/Manifest
index 6649176aa7f3..138dbaf7bc02 100644
--- a/sci-mathematics/coq/Manifest
+++ b/sci-mathematics/coq/Manifest
@@ -1,3 +1,4 @@
DIST coq-8.11.2.tar.gz 6564523 BLAKE2B 37ae7a1f899b8ce662d5c21542b2bec0e2e8f25e976fb46689e0eae182fa4ec571524ae9f4f1a5ebbd44966fbdc4ee10cffda59c287d51ab48df4ac0e5e6844c SHA512 f8ab307b8e39ffda5f6984e187c1f8de1cb6dec5c322726dbbe535ee611683cfeeb9cee3e11ad83f5e44e843fc51e7e2d50b4ea69ab42fde38aaf3d0cf2dea3c
DIST coq-8.12.0.tar.gz 6774001 BLAKE2B dc1d6adf9d4bd50d46007fbf5fd43d1ea97b6b226d89ad943419d4cb7df1439950c94b5e3cc614eb789103d1ab50535909d4ba2079eafc2caa4fd91db30e747d SHA512 8a64624c578ce0ab781fb3b1f162bd8b095735ad891fdad2fb7c40849afbdc7c1360187c6b62a5ef2982566f4c6c78029240c611ae769943a5250af300eb1240
DIST coq-8.13.0.tar.gz 7010242 BLAKE2B bf9ec96b6698a2371be3164f65424a8ffb273252afc05e046267cae4265c1be71f89d0345f9e40ab3a93f5063080fd0224502cc0de808c7a0ddbb0edacab5fca SHA512 c355f0a9183f3669debd5f8f4ab96786215d0cccc37d1c2ac95a2d3c6115c8b0ee7ff7e23464b18444e2648ef3f8c221f0f3a28acf91199751cea2b74ee3fe8e
+DIST coq-8.15.0.tar.gz 7215106 BLAKE2B 512fde593f6e7fb8b410b5debf5a78bc5d0d181ed7207c00669fc33fa39c2d7e57860f3afbcfc9defd2093115242ad176a5451d9bb309483ba2172e2b0521d02 SHA512 be6c799b6635875255f7288b9bae5f9108660308f299823155d41353e96fbed4e41e1fc8896fe9653c095da740a80dbf5a1add6b28d279eb7b65365eeaff54ab
diff --git a/sci-mathematics/coq/coq-8.15.0.ebuild b/sci-mathematics/coq/coq-8.15.0.ebuild
new file mode 100644
index 000000000000..b02fe03c702c
--- /dev/null
+++ b/sci-mathematics/coq/coq-8.15.0.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop dune
+
+MY_PV=${PV/_p/pl}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="Proof assistant written in O'Caml"
+HOMEPAGE="http://coq.inria.fr/"
+SRC_URI="https://github.com/coq/coq/archive/V${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk debug +ocamlopt" # doc add when antlr & antlr-python are ready
+RESTRICT="test" # fails
+
+RDEPEND="
+ dev-ml/zarith:=
+ || (
+ dev-ml/num
+ <dev-lang/ocaml-4.09.0[ocamlopt?]
+ )
+ gtk? (
+ dev-ml/lablgtk:3=[sourceview,ocamlopt?]
+ dev-ml/lablgtk-sourceview:3=[ocamlopt?]
+ )
+"
+DEPEND="${RDEPEND}"
+# to build docs we needantlr >=4.7, not yet in the tree
+# BDEPEND="doc? (
+# >=dev-java/antlr-4.7:4
+# dev-python/antlr-python:4
+# dev-python/beautifulsoup4
+# dev-python/pexpect
+# dev-python/sphinx_rtd_theme
+# dev-python/sphinxcontrib-bibtex
+# )"
+
+DOCS=( CODE_OF_CONDUCT.md CONTRIBUTING.md CREDITS INSTALL.md README.md )
+
+src_configure() {
+ local myconf=(
+ -prefix /usr
+ -libdir /usr/$(get_libdir)/coq
+ -mandir /usr/share/man
+ -docdir /usr/share/doc/${PF}
+ -datadir /usr/share/coq
+ -configdir /etc/xdg/${PN}
+ # -with-doc $(usex doc)
+ -with-doc no
+ )
+
+ use debug && myconf+=( -debug )
+ use ocamlopt || myconf+=( -byte-only )
+
+ if use gtk ; then
+ if use ocamlopt ; then
+ myconf+=( -coqide opt )
+ else
+ myconf+=( -coqide byte )
+ fi
+ else
+ myconf+=( -coqide no )
+ fi
+
+ export CAML_LD_LIBRARY_PATH="${S}/kernel/byterun/"
+
+ echo "Configure options: ${myconf[@]}"
+ sh ./configure ${myconf[@]} || die "configure failed"
+}
+
+src_compile() {
+ emake STRIP="true" VERBOSE=1 COQ_USE_DUNE="" world
+}
+
+src_test() {
+ emake STRIP="true" VERBOSE=1 COQ_USE_DUNE="" check
+}
+
+src_install() {
+ local sym
+ local syms=( coq-core coqide-server )
+
+ emake STRIP="true" VERBOSE=1 COQ_USE_DUNE="" DESTDIR="${D}" install-library
+ dune-install coq-core coqide-server
+
+ if use gtk ; then
+ dune-install coqide
+ make_desktop_entry "coqide" "Coq IDE" "${EPREFIX}/usr/share/coq/coq.png"
+ syms+=( coqide )
+ fi
+
+ # use doc && emake DESTDIR="${D}" install-doc-all
+ einstalldocs
+
+ # Dune installs into /usr/<libdir>/ocaml/<coq> but
+ # Coq wants /usr/<libdir>/<coq> ; symlink those directories
+ for sym in ${syms[@]} ; do
+ dosym $(ocamlc -where)/${sym} /usr/$(get_libdir)/${sym}
+ done
+}