summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2019-12-02 13:36:32 +0100
committerLouis Sautier <sbraz@gentoo.org>2019-12-02 14:34:22 +0100
commit1af5ea9baec9f3175dfe547676b1de7e05223d0d (patch)
treea720065720af8598822263fb745679db698896e5
parentdev-python/rst-linker: bump to 2.0.0, add Py3.8, drop unsupported compat (diff)
downloadgentoo-1af5ea9b.tar.gz
gentoo-1af5ea9b.tar.bz2
gentoo-1af5ea9b.zip
dev-python/rst-linker: remove old
Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
-rw-r--r--dev-python/rst-linker/Manifest1
-rw-r--r--dev-python/rst-linker/rst-linker-1.10.ebuild54
2 files changed, 0 insertions, 55 deletions
diff --git a/dev-python/rst-linker/Manifest b/dev-python/rst-linker/Manifest
index f153c9a281e1..65510ce73254 100644
--- a/dev-python/rst-linker/Manifest
+++ b/dev-python/rst-linker/Manifest
@@ -1,4 +1,3 @@
-DIST rst.linker-1.10.tar.gz 8820 BLAKE2B 3615353dcce16652aa3528985997467e1501161b012fad44203fd98cc5e91dc32acf6c8492f0797ae748a87c008e5f3437833b435c5cbd85845340b91665e664 SHA512 5541d0ba5299a6efee444ed3c4fb4f108bcdd7c84e4be0b0a44f71c9f13e18d5b5c4c38328a542fe5666d435e1e04c35c0db5535706a45932dc01590813a85cc
DIST rst.linker-1.11.tar.gz 12569 BLAKE2B 5418f651322c28d8aff2dc735f8ff72325e895d8f2c12dae4985112112f74023c6103e344f4422e944b32b692713834ae5239bc4193edc76bfa85d9e0a674f4a SHA512 8e748330f60e2e1f859fa3ec3fad706d7bbafc78a402b0df242bda7caff1fad3f1b17873fa9ee749d3d214e094f24a35695c627cf9a8d8f08ca99ee6ad0e4e6d
DIST rst.linker-1.9.tar.gz 7618 BLAKE2B b344495a217d7cd1c057256701130851975e46c45a740251ce20efa5131feb46a074fb1367a645e89b436b7e093baad1a484d06ca069ebc0f59eca8183ddd36d SHA512 b3e39b025f75bb6ff670f23ee7abd48dcc4e19343626c1ffadd2304a7e3285fe0b7369ace96e47094606e864672c8aeea967a02217b110762e53498dde64b8a7
DIST rst.linker-2.0.0.tar.gz 12861 BLAKE2B f52ddab3c8119f0bac64e294e4a5a3cc50916f19f49ca1ca4983d8b5d2bb5401c6accb5873df38609386e12fcd1cb02b867f3633edd4d10606a98936e96e62eb SHA512 ea9fa95de66c95dc384c888446512be66b180d0d76e99fe7a6b8f8348436d4be959d3d567fa521d9fc925b537467a4fdf05f9e9d17f7a6df4aafd6dfd323e4fc
diff --git a/dev-python/rst-linker/rst-linker-1.10.ebuild b/dev-python/rst-linker/rst-linker-1.10.ebuild
deleted file mode 100644
index 389752db19ac..000000000000
--- a/dev-python/rst-linker/rst-linker-1.10.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy{,3} python{2_7,3_{5,6,7}} )
-
-inherit distutils-r1
-
-MY_PN="${PN/-/.}"
-DESCRIPTION="Sphinx plugin to add links and timestamps to the changelog"
-HOMEPAGE="https://github.com/jaraco/rst.linker"
-SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="doc test"
-
-RDEPEND="
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
- doc? (
- >=dev-python/jaraco-packaging-3.2[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- )
- test? (
- ${RDEPEND}
- dev-python/path-py[${PYTHON_USEDEP}]
- >=dev-python/pytest-3.4[${PYTHON_USEDEP}]
- )
-"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-python_compile_all() {
- if use doc; then
- sphinx-build docs docs/_build/html || die
- HTML_DOCS=( docs/_build/html/. )
- fi
-}
-
-python_test() {
- # Ignore the module from ${S}, use the one from ${BUILD_DIR}
- # Otherwise, ImportMismatchError may occur
- # https://github.com/gentoo/gentoo/pull/1622#issuecomment-224482396
- # Override pytest options to skip flake8
- py.test -v --ignore=rst --override-ini="addopts=--doctest-modules" \
- || die "tests failed with ${EPYTHON}"
-}