summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-08-04 22:20:59 +0200
committerThomas Deutschmann <whissi@gentoo.org>2018-08-04 22:20:59 +0200
commit1af688711dbcb708c8bfb3efee2787a4ba82c9d6 (patch)
tree0a63c78ea93f468b038afd7a219dc76a474763a3
parentsys-apps/habitat: use virtual/cargo instead of dev-util/cargo (diff)
downloadgentoo-1af68871.tar.gz
gentoo-1af68871.tar.bz2
gentoo-1af68871.zip
dev-python/pytest-describe: new package
Needed for sys-auth/ssh-ldap-pubkey package (not yet in repository!). Michał Górny granted permission to set Python project as maintainer. Package-Manager: Portage-2.3.44, Repoman-2.3.10
-rw-r--r--dev-python/pytest-describe/Manifest1
-rw-r--r--dev-python/pytest-describe/metadata.xml12
-rw-r--r--dev-python/pytest-describe/pytest-describe-0.11.1.ebuild30
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/pytest-describe/Manifest b/dev-python/pytest-describe/Manifest
new file mode 100644
index 000000000000..eda2cbd4f151
--- /dev/null
+++ b/dev-python/pytest-describe/Manifest
@@ -0,0 +1 @@
+DIST pytest-describe-0.11.1.tar.gz 7226 BLAKE2B 5cbe722d1187fa67424e5c932eee7fc90335e6811d7493372515b44d4210d0de4b4d8f33f1583ac1ae400d91d9fb9795b2952a56fc6c2865ab450af279e45c09 SHA512 0634f17ca36f8fa346a6001338827d70dda410376660f370ba04b8857d37e009c5e33f06baee51d1c23a13094c88850668028f5d44a09c31b40baff0bfdaf1ef
diff --git a/dev-python/pytest-describe/metadata.xml b/dev-python/pytest-describe/metadata.xml
new file mode 100644
index 000000000000..91c491d48379
--- /dev/null
+++ b/dev-python/pytest-describe/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pytest-describe</remote-id>
+ <remote-id type="github">ropez/pytest-describe</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-describe/pytest-describe-0.11.1.ebuild b/dev-python/pytest-describe/pytest-describe-0.11.1.ebuild
new file mode 100644
index 000000000000..33283659c145
--- /dev/null
+++ b/dev-python/pytest-describe/pytest-describe-0.11.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Describe-style plugin for py.test"
+HOMEPAGE="https://github.com/ropez/pytest-describe https://pypi.org/project/pytest-describe"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=dev-python/pytest-2.6.0[${PYTHON_USEDEP}]"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( >=dev-python/pytest-2.6.0[${PYTHON_USEDEP}] )"
+
+python_test() {
+ # We need to disable flaky plugin because test_custom_prefix test validates
+ # pytest output and output from flaky plugin would appear unexpectedly
+ PYTEST_ADDOPTS="-p no:flaky" pytest -vv || die "Tests failed under ${EPYTHON}"
+}