summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2021-09-12 12:12:16 +0100
committerJames Le Cuirot <chewi@gentoo.org>2021-09-12 12:12:16 +0100
commit1b0d39f58fb9af857ca8277de7fe7ffd591192d5 (patch)
tree48da4464f23b88584d4de5be34e6324a358d7b5d
parentmedia-libs/libsdl2: Drop unused toolchain-funcs in 2.0.16 (diff)
downloadgentoo-1b0d39f5.tar.gz
gentoo-1b0d39f5.tar.bz2
gentoo-1b0d39f5.zip
media-libs/libsdl2: Install Doxygen documentation with USE=doc
Also install the sdl2-config man page. Closes: https://bugs.gentoo.org/812344 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
-rw-r--r--media-libs/libsdl2/libsdl2-2.0.16.ebuild18
1 files changed, 17 insertions, 1 deletions
diff --git a/media-libs/libsdl2/libsdl2-2.0.16.ebuild b/media-libs/libsdl2/libsdl2-2.0.16.ebuild
index a9a95560341f..1b9c8bdf53b8 100644
--- a/media-libs/libsdl2/libsdl2-2.0.16.ebuild
+++ b/media-libs/libsdl2/libsdl2-2.0.16.ebuild
@@ -14,7 +14,7 @@ LICENSE="ZLIB"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
-IUSE="alsa aqua cpu_flags_ppc_altivec cpu_flags_x86_3dnow cpu_flags_x86_mmx cpu_flags_x86_sse cpu_flags_x86_sse2 custom-cflags dbus fcitx4 gles1 gles2 haptic ibus jack +joystick kms libsamplerate nas opengl oss pipewire pulseaudio sndio +sound static-libs +threads udev +video video_cards_vc4 vulkan wayland X xinerama xscreensaver"
+IUSE="alsa aqua cpu_flags_ppc_altivec cpu_flags_x86_3dnow cpu_flags_x86_mmx cpu_flags_x86_sse cpu_flags_x86_sse2 custom-cflags dbus doc fcitx4 gles1 gles2 haptic ibus jack +joystick kms libsamplerate nas opengl oss pipewire pulseaudio sndio +sound static-libs +threads udev +video video_cards_vc4 vulkan wayland X xinerama xscreensaver"
REQUIRED_USE="
alsa? ( sound )
fcitx4? ( dbus )
@@ -80,6 +80,10 @@ DEPEND="${CDEPEND}
"
BDEPEND="
virtual/pkgconfig
+ doc? (
+ app-doc/doxygen
+ media-gfx/graphviz
+ )
"
MULTILIB_WRAPPED_HEADERS=(
@@ -201,6 +205,15 @@ multilib_src_compile() {
emake V=1
}
+src_compile() {
+ multilib-minimal_src_compile
+
+ if use doc; then
+ cd docs || die
+ doxygen || die
+ fi
+}
+
multilib_src_install() {
emake DESTDIR="${D}" install
}
@@ -209,5 +222,8 @@ multilib_src_install_all() {
# Do not delete the static .a libraries here as some are
# mandatory. They may be needed even when linking dynamically.
find "${ED}" -type f -name "*.la" -delete || die
+
dodoc {BUGS,CREDITS,README-SDL,TODO,WhatsNew}.txt README.md docs/README*.md
+ doman debian/sdl2-config.1
+ use doc && dodoc -r docs/output/html/
}