summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-20 21:19:41 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-20 21:42:05 +0200
commit1b190d662ed4cbbebd6c1f2b904a472e7c0bdda9 (patch)
treeb202cfd231305d5067a8c1743a36513fd8288ab6
parentdev-python/aws-xray-sdk: Bump to 2.13.1 (diff)
downloadgentoo-1b190d662ed4cbbebd6c1f2b904a472e7c0bdda9.tar.gz
gentoo-1b190d662ed4cbbebd6c1f2b904a472e7c0bdda9.tar.bz2
gentoo-1b190d662ed4cbbebd6c1f2b904a472e7c0bdda9.zip
dev-python/sphinx-autoapi: Bump to 3.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/sphinx-autoapi/Manifest1
-rw-r--r--dev-python/sphinx-autoapi/sphinx-autoapi-3.1.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/sphinx-autoapi/Manifest b/dev-python/sphinx-autoapi/Manifest
index 568f1fb352dd..77688800549f 100644
--- a/dev-python/sphinx-autoapi/Manifest
+++ b/dev-python/sphinx-autoapi/Manifest
@@ -1 +1,2 @@
DIST sphinx-autoapi-3.0.0.gh.tar.gz 62951 BLAKE2B 80c1168b7d6f2d8489139d1daaa00817bf88345b92d962d1b7114ffd078dab5babd00f3837b9a80bd7175f07a50a432be4096140ac3ee8db11d90e1b836cd308 SHA512 fece7ff76de1ad4a58d8128d7c1f4c57a91ffbc2fb788f7bf4ce230860e97279f8ddf32d24dee4b961d89807056abd2f621484ff91e13b98b57d7f7a00d1cd4c
+DIST sphinx-autoapi-3.1.0.gh.tar.gz 67664 BLAKE2B 5fefd1cf5ff401db9e309eeed3d8211bd72e43d6f40b088b6e1a2e406a910b2b99ff0e2431d0f8c55b0300c51f65c6892f2068131ecea2524fba3f0dd439bd2b SHA512 22ea54a11d9ecb2a91f3c7fee8561bd42f87fa82894b17cac51daeab94a298a7cc3bc5c0158c4fdead62879e89ea760beb3222e5bf31489b68a3483b47adb499
diff --git a/dev-python/sphinx-autoapi/sphinx-autoapi-3.1.0.ebuild b/dev-python/sphinx-autoapi/sphinx-autoapi-3.1.0.ebuild
new file mode 100644
index 000000000000..9182b8aa4e2c
--- /dev/null
+++ b/dev-python/sphinx-autoapi/sphinx-autoapi-3.1.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A new approach to API documentation in Sphinx"
+HOMEPAGE="
+ https://sphinx-autoapi.readthedocs.io/
+ https://github.com/readthedocs/sphinx-autoapi/
+ https://pypi.org/project/sphinx-autoapi/
+"
+# sdist is missing docs, as of 2.1.0
+SRC_URI="
+ https://github.com/readthedocs/sphinx-autoapi/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/astroid-3.0.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-6.1.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND+="
+ test? ( dev-python/beautifulsoup4[${PYTHON_USEDEP}] )
+"
+
+DOCS=( README.rst CHANGELOG.rst )
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Internet
+ tests/python/test_pyintegration.py::TestPEP695::test_integration
+ tests/python/test_pyintegration.py::TestPipeUnionModule::test_integration
+ "tests/test_integration.py::TestExtensionErrors::test_extension_setup_errors[dotnetexample"
+ )
+
+ distutils-r1_python_test
+}