summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2022-11-04 00:39:08 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2022-11-04 00:40:56 +0100
commit1b23b1ee07bd86ed8b861d35e29175b8fe866483 (patch)
treee318de83be58f86d560aa5bcbbdf67c1f9f1f464
parentdev-lua/luaexpat: Stabilize 1.5.1 ppc64, #879499 (diff)
downloadgentoo-1b23b1ee.tar.gz
gentoo-1b23b1ee.tar.bz2
gentoo-1b23b1ee.zip
x11-misc/zim: add 0.75.1
Add icons install step as PEP 517 mode skips them Closes: https://bugs.gentoo.org/878741 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
-rw-r--r--x11-misc/zim/Manifest1
-rw-r--r--x11-misc/zim/zim-0.75.1.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/x11-misc/zim/Manifest b/x11-misc/zim/Manifest
index 033ff52dae49..4f757a329ec8 100644
--- a/x11-misc/zim/Manifest
+++ b/x11-misc/zim/Manifest
@@ -1,2 +1,3 @@
DIST zim-0.74.3.tar.gz 3108228 BLAKE2B fbaaddbd5522ccffcba87da2f4080e93e46dfcdc22771a414daa813cdbc2982738c2bf6f068f4bddf788965b4cf45594f2720a697c04d71194f513d1d9b43875 SHA512 9f885571800e3aba327a46b3bc8677ca596fb2d0a58e2f65190d9e2bc90f013655947d86c1fc869e2d79a5c0ba8a7a4d907a00f8d7563116291df47d8c2c677d
DIST zim-0.75.0.tar.gz 3178872 BLAKE2B 71fcd9363fc238be6ca48f44e826d0ca1ac62fdb609f2397f2dbd6acf3601980b861bc1424e1834728179f1a9c29332bf4709010643b77c8daec6299688cbb0c SHA512 9b8c5be64b2d45de2b02770e91f1950928d8f2214fc0c6099cd57bf61e3749911f46c4ec7815c9e322559ce155db2475e3b1347a81d2b76a82cd848dd4af3864
+DIST zim-0.75.1.tar.gz 3212424 BLAKE2B 8db33315a8852b4efc5506cf94576f9b7cfa8574e77798d4e8bb61930a0d9ede5ea0bd2fc8c1ae479f49caee265981d70902b149e151e5f295cdcc5bbe98b131 SHA512 207d40af2342f16ba713a3809b06ddc6656bce22386fcaace65b0e04894218590d4c03b9c65d6eeb3c4edc46e85e103cfcf112e4298be07ba1f126d7732333c5
diff --git a/x11-misc/zim/zim-0.75.1.ebuild b/x11-misc/zim/zim-0.75.1.ebuild
new file mode 100644
index 000000000000..a7fb11f78c96
--- /dev/null
+++ b/x11-misc/zim/zim-0.75.1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_REQ_USE="sqlite"
+DISTUTILS_USE_PEP517=setuptools
+DISTUTILS_SINGLE_IMPL=1
+VIRTUALX_REQUIRED=test
+inherit distutils-r1 optfeature virtualx xdg
+
+DESCRIPTION="A desktop wiki"
+HOMEPAGE="
+ https://zim-wiki.org/
+ https://github.com/zim-desktop-wiki/zim-desktop-wiki
+"
+SRC_URI="https://github.com/${PN}-desktop-wiki/${PN}-desktop-wiki/archive/${PV/_/-}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ ')
+ x11-libs/gtk+:3[introspection]
+ x11-misc/xdg-utils
+"
+DEPEND="${RDEPEND}"
+
+DOCS=( CHANGELOG.md CONTRIBUTING.md PLUGIN_WRITING.md README.md )
+PATCHES=( "${FILESDIR}"/${PN}-0.60-remove-ubuntu-theme.patch )
+S=${WORKDIR}/${PN}-desktop-wiki-${PV/_/-}
+
+python_prepare_all() {
+ if [[ ${LINGUAS} ]]; then
+ local lingua
+ for lingua in translations/*.po; do
+ lingua=${lingua/.po}
+ lingua=${lingua/translations\/}
+ has ${lingua} ${LINGUAS} || \
+ { rm translations/${lingua}.po || die; }
+ done
+ fi
+
+ distutils-r1_python_prepare_all
+ export XDG_RUNTIME_DIR=fakethis
+}
+
+python_test() {
+ if has_version dev-vcs/git; then
+ git config --global user.email "git@example.com" || die
+ git config --global user.name "GitExample" || die
+ fi
+
+ virtx ./test.py
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ insinto /usr/share/icons
+ doins -r xdg/hicolor
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature "GNU R Plot Editor" dev-lang/R
+ optfeature "Spell checker" dev-python/gtkspell-python
+ optfeature "Version control Bazaar support" dev-vcs/bzr
+ optfeature "Diagram Editor" media-gfx/graphviz
+ optfeature "Insert Screenshot" "media-gfx/imagemagick media-gfx/scrot"
+ optfeature "Score Editor" media-sound/lilypond
+ optfeature "Gnuplot Editor" sci-visualization/gnuplot
+ optfeature "Equation Editor" virtual/latex-base app-text/dvipng
+}