summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-08-26 12:52:12 +0100
committerSam James <sam@gentoo.org>2022-08-26 13:04:37 +0100
commit1b2cdb17237fd8109a45b8ef28e0d22e500b6fa8 (patch)
treec706886d6e01b0fa373a803060a28040c4fc29c7
parentapp-admin/mcelog: add 189 (diff)
downloadgentoo-1b2cdb17237fd8109a45b8ef28e0d22e500b6fa8.tar.gz
gentoo-1b2cdb17237fd8109a45b8ef28e0d22e500b6fa8.tar.bz2
gentoo-1b2cdb17237fd8109a45b8ef28e0d22e500b6fa8.zip
app-misc/fdupes: add 2.2.0
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-misc/fdupes/Manifest1
-rw-r--r--app-misc/fdupes/fdupes-2.2.0.ebuild43
-rw-r--r--app-misc/fdupes/fdupes-9999.ebuild12
3 files changed, 51 insertions, 5 deletions
diff --git a/app-misc/fdupes/Manifest b/app-misc/fdupes/Manifest
index 0288ee4dd113..9deb6e1a8c25 100644
--- a/app-misc/fdupes/Manifest
+++ b/app-misc/fdupes/Manifest
@@ -1 +1,2 @@
DIST fdupes-2.1.2.tar.gz 142266 BLAKE2B caf949b87baf0fecc87fef58f512d0a99e1219b57bc167992b0e40841ce67e5ddcf5307de7fc9c70f173e75aab4a12eb86abef0084084b5119f95326509ea665 SHA512 9c3761e7ce34f2d9d1b5ee49ebc3bf665e3d45e4146231bc77d7416801fbfa70415e80c81c64962897766ee068d1a103609895d783f20a765c351d4cd433323d
+DIST fdupes-2.2.0.tar.gz 144763 BLAKE2B 26a6f003b6e1b536d02da1f4b5e9051c3da19ae67c6cbdfb3cf2060ae68288b9ebdf64ca911e60126a6646895f6a6d7158c23b28c20b415ee341a8dd29820aaf SHA512 83f7bb9c3dc44ef5356c02b1db7f7f0e5698f2b73dfbb8ea1176e9a7399167a7ffd8d416036792ede1ba106dfb221d72708f7e483ce96fb7faf6c23a4f43128b
diff --git a/app-misc/fdupes/fdupes-2.2.0.ebuild b/app-misc/fdupes/fdupes-2.2.0.ebuild
new file mode 100644
index 000000000000..5cf8c66e6420
--- /dev/null
+++ b/app-misc/fdupes/fdupes-2.2.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Identify/delete duplicate files residing within specified directories"
+HOMEPAGE="https://github.com/adrianlopezroche/fdupes"
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/adrianlopezroche/fdupes.git"
+ inherit autotools git-r3
+else
+ SRC_URI="https://github.com/adrianlopezroche/${PN}/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+ncurses"
+
+RDEPEND="
+ dev-libs/libpcre2[pcre32]
+ ncurses? ( sys-libs/ncurses:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( CHANGES CONTRIBUTORS README )
+
+src_prepare() {
+ default
+
+ [[ ${PV} == *9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf $(use_with ncurses)
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
diff --git a/app-misc/fdupes/fdupes-9999.ebuild b/app-misc/fdupes/fdupes-9999.ebuild
index 33ac17e5539a..5cf8c66e6420 100644
--- a/app-misc/fdupes/fdupes-9999.ebuild
+++ b/app-misc/fdupes/fdupes-9999.ebuild
@@ -1,26 +1,27 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit toolchain-funcs
DESCRIPTION="Identify/delete duplicate files residing within specified directories"
HOMEPAGE="https://github.com/adrianlopezroche/fdupes"
-if [[ "${PV}" == *9999 ]] ; then
- inherit autotools git-r3
+if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://github.com/adrianlopezroche/fdupes.git"
+ inherit autotools git-r3
else
SRC_URI="https://github.com/adrianlopezroche/${PN}/releases/download/v${PV}/${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
fi
+
LICENSE="MIT"
SLOT="0"
IUSE="+ncurses"
RDEPEND="
dev-libs/libpcre2[pcre32]
- ncurses? ( sys-libs/ncurses:0= )
+ ncurses? ( sys-libs/ncurses:= )
"
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
@@ -29,7 +30,8 @@ DOCS=( CHANGES CONTRIBUTORS README )
src_prepare() {
default
- [[ "${PV}" == *9999 ]] && eautoreconf
+
+ [[ ${PV} == *9999 ]] && eautoreconf
}
src_configure() {