summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-06-03 04:14:19 +0200
committerMichał Górny <mgorny@gentoo.org>2019-06-03 04:21:53 +0200
commit1b3b82dbfcb0e5a7b307ade4c0e996c81e4614ea (patch)
tree04e93287496919230a3d54b8cc4300a9c6ce5ae6
parentsys-kernel/git-sources: Linux patch 5.2-rc3. Clean-up of 5.1 series. (diff)
downloadgentoo-1b3b82dbfcb0e5a7b307ade4c0e996c81e4614ea.tar.gz
gentoo-1b3b82dbfcb0e5a7b307ade4c0e996c81e4614ea.tar.bz2
gentoo-1b3b82dbfcb0e5a7b307ade4c0e996c81e4614ea.zip
dev-python/cython: Bump to 0.29.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/cython/Manifest1
-rw-r--r--dev-python/cython/cython-0.29.10.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/dev-python/cython/Manifest b/dev-python/cython/Manifest
index 5f666eea1b57..bf50a62aa4c8 100644
--- a/dev-python/cython/Manifest
+++ b/dev-python/cython/Manifest
@@ -1,6 +1,7 @@
DIST Cython-0.25.2.tar.gz 1703315 BLAKE2B e458604d0843afa128c6019244220bd6b3dd6653013698aa67ee2f71555f09813a8136ef92d6dc51ca38fe085e7bedc5e01d1a32bbd0885e62bd91c2e482bebd SHA512 1974b9374aeedb030307dc95aa6560ce9d5e1652783cd4552e96ef11663c73dd263e3521b68e7712abbb31628011e2e66320c5ee2577968684e2679eb80726e1
DIST Cython-0.26.1.tar.gz 1725133 BLAKE2B b2c0433e8154ad76d921677608cae42a793326015ff320d8cd61818e5eb5fb4daf73ad4e72760d84f4cdaa2386b87d719cf9cd41584b781d4e2021e377a58422 SHA512 cdf31afaba78209c37a224345471c5c822b78c6d26c51583c46669b6b2b57b4952b33a839a51d06c3330fdff889345ac611fbaa2b2f17498cb02f3b5675f7948
DIST Cython-0.28.4.tar.gz 1880943 BLAKE2B a97314147294c95fa0bd6d3fa1a1315d81f8abb46a1f2196009c1ef6f0dd7f47f81a7b31ab81d1fd00e8de37878a18a22d225055181ee74ffe4cc8105d84cd75 SHA512 67d2da2d776fc02193cfe98c8942e93905ec5e30bf4e0f9d5c965d930a034936d4c29c8248fccefff5db6d4dee054ec854994bea63fa3f64ff65df7550997c29
+DIST Cython-0.29.10.tar.gz 2049468 BLAKE2B 1cfae1c5e2d7277d3ac25ab0ff5a7b4346242e6c01d0b7945491f4fb64e0c9b98c593efa41b790aa0437ae72275a0ba3b6fe8614c7efaadc6139823f0e453d71 SHA512 df8430bb89816df84abfc6d59bee8e50f4117e8e82b9c82a889afca390a42a1569a9b5dcde76f40e7c29d728489af34c6fe0cf359912f7b74ac0d014af2171c3
DIST Cython-0.29.4.tar.gz 2044382 BLAKE2B b36d27706a3270805f66190a4cf2735eaf20b1b932365b324a433c0e58e63e860ce1500333233c3539ae697886ac0adc361a2c158d5d064a3ea05843debc3f26 SHA512 8f115e36975aaf64eda4df8b0a85378d0c80b3292dbd162be826b939def03bdc9f3eb937676e2367003c2944b570d97f50d7880becfdb2fdc5144077b4a722dc
DIST Cython-0.29.7.tar.gz 2047944 BLAKE2B 79a2dbbbeef2c87e523d1222c1e3b62a63273644a0295a08fed3909ef01f2167baf15c0344a64ec168820e21c5c99b0accc083c8dfcaca7f1c0cb8c4b23677cc SHA512 1c2fd2185d65445318118d917ff6f8b4b958b0a036bc3ce1587dcb8fa94ccc750901cece27e4d0d39c53db68c3a620edf2dcf9424d7a6df58a0275097b90fa6e
DIST Cython-0.29.9.tar.gz 2049206 BLAKE2B d81cc4be6d99e8be025167700517880c3250feaf929f84a9de76e2c9f1ac5eb8018a7cb4609d95c01112e35ab54070eb373157004621d45db3c347ea2b585bb5 SHA512 17ac97eaa01e3c6cd9c7d597822ad25ef5cec2354055304a2999a0a0d969fa0513640470260cf0d88c8d9a7c331f02d1ebf144245a6c45de47e26e7fa73b0ae1
diff --git a/dev-python/cython/cython-0.29.10.ebuild b/dev-python/cython/cython-0.29.10.ebuild
new file mode 100644
index 000000000000..3bd1896df64d
--- /dev/null
+++ b/dev-python/cython/cython-0.29.10.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 toolchain-funcs elisp-common
+
+MY_PN="Cython"
+MY_P="${MY_PN}-${PV/_/}"
+
+DESCRIPTION="A Python to C compiler"
+HOMEPAGE="https://cython.org https://pypi.org/project/Cython/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="doc emacs test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ emacs? ( virtual/emacs )
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/numpy[${PYTHON_USEDEP}] )"
+
+SITEFILE=50cython-gentoo.el
+S="${WORKDIR}/${MY_PN}-${PV%_*}"
+
+python_prepare_all() {
+ # tests behavior that is illegal in Python 3.7+
+ # https://github.com/cython/cython/issues/2454
+ sed -i -e '/with_outer_raising/,/return/d' tests/run/generators_py.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ if ! python_is_python3; then
+ local CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ local CXXFLAGS="${CXXFLAGS} -fno-strict-aliasing"
+ fi
+
+ # Python gets confused when it is in sys.path before build.
+ local -x PYTHONPATH=
+
+ distutils-r1_python_compile
+}
+
+python_compile_all() {
+ use emacs && elisp-compile Tools/cython-mode.el
+
+ use doc && emake -C docs html
+}
+
+python_test() {
+ tc-export CC
+ # https://github.com/cython/cython/issues/1911
+ local -x CFLAGS="${CFLAGS} -fno-strict-overflow"
+ "${PYTHON}" runtests.py -vv --work-dir "${BUILD_DIR}"/tests \
+ || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ local DOCS=( CHANGES.rst README.rst ToDo.txt USAGE.txt )
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ distutils-r1_python_install_all
+
+ if use emacs; then
+ elisp-install ${PN} Tools/cython-mode.*
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}