summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-05-14 13:16:01 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-05-14 15:05:41 +0300
commit1b3fa0ba992cd1104a2c461f9954446a437950c1 (patch)
treeaf6e31367571ac438abdaeeeb3675f58a6757df6
parentdev-python/snowballstemmer: enable py3.11 (diff)
downloadgentoo-1b3fa0ba.tar.gz
gentoo-1b3fa0ba.tar.bz2
gentoo-1b3fa0ba.zip
dev-python/imagesize: Use PEP517
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/imagesize/imagesize-1.3.0-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/imagesize/imagesize-1.3.0-r1.ebuild b/dev-python/imagesize/imagesize-1.3.0-r1.ebuild
new file mode 100644
index 000000000000..42bf2c9e5281
--- /dev/null
+++ b/dev-python/imagesize/imagesize-1.3.0-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Pure Python module for getting image size from png/jpeg/jpeg2000/gif files"
+HOMEPAGE="https://github.com/shibukawa/imagesize_py"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-solaris"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # requires Internet
+ test/test_get_filelike.py::test_get_filelike
+)