summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-03-08 15:52:00 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-03-08 17:01:28 +0100
commit1b46f9d03a2007fdd829e26e6c68695498359bef (patch)
treeb36ae3aa26b84698017a5ce83d51f2b767c2f147
parentapp-crypt/xca: Bump to 2.2.1 (diff)
downloadgentoo-1b46f9d03a2007fdd829e26e6c68695498359bef.tar.gz
gentoo-1b46f9d03a2007fdd829e26e6c68695498359bef.tar.bz2
gentoo-1b46f9d03a2007fdd829e26e6c68695498359bef.zip
dev-python/symengine: Raise minimum sci-libs/symengine to 0.5.0
Closes: https://bugs.gentoo.org/704092 Package-Manager: Portage-2.3.93, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-python/symengine/symengine-0.5.1-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/symengine/symengine-0.5.1-r1.ebuild b/dev-python/symengine/symengine-0.5.1-r1.ebuild
new file mode 100644
index 000000000000..fe8498abaafe
--- /dev/null
+++ b/dev-python/symengine/symengine-0.5.1-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{3_6,3_7} )
+
+inherit distutils-r1
+
+MYP=${PN}.py-${PV}
+
+DESCRIPTION="Python wrappers to the symengine C++ library"
+HOMEPAGE="https://github.com/symengine/symengine.py"
+SRC_URI="https://github.com/symengine/symengine.py/archive/v${PV}.tar.gz -> ${MYP}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=sci-libs/symengine-0.5"
+DEPEND="${RDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MYP}"
+
+python_test() {
+ cd "${BUILD_DIR}"
+ nosetests -v || die "tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_prepare_all
+ rm "${ED}"/usr/share/doc/${PF}/README.md || die
+ newdoc README.md ${PN}.py.md
+}