summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <alexey+gentoo@asokolov.org>2023-10-16 18:35:48 +0100
committerYixun Lan <dlan@gentoo.org>2023-10-17 05:23:55 +0000
commit1b52ddd8a2557a6aa4de7aaa215ae5081c7c8851 (patch)
tree943a6cb30d22b08872814fecad0b0d609705279a
parentmedia-sound/clementine: update 9999 (diff)
downloadgentoo-1b52ddd8a2557a6aa4de7aaa215ae5081c7c8851.tar.gz
gentoo-1b52ddd8a2557a6aa4de7aaa215ae5081c7c8851.tar.bz2
gentoo-1b52ddd8a2557a6aa4de7aaa215ae5081c7c8851.zip
games-engines/fheroes2: add 1.0.9
Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Signed-off-by: Yixun Lan <dlan@gentoo.org>
-rw-r--r--games-engines/fheroes2/Manifest1
-rw-r--r--games-engines/fheroes2/fheroes2-1.0.9.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/games-engines/fheroes2/Manifest b/games-engines/fheroes2/Manifest
index 7af5d3cb2ddc..4ba114cb15d8 100644
--- a/games-engines/fheroes2/Manifest
+++ b/games-engines/fheroes2/Manifest
@@ -1 +1,2 @@
DIST fheroes2-1.0.8.tar.gz 11757081 BLAKE2B 5448ab4b8379046d632ee8ee1be3207e4b2bd7a7a8f8c2744b2c95b909128d71a1247c8c30a903cc283df7de04e1e5b3a07bac98346b4ec444dff891aa50c028 SHA512 90c198249ecd321c0c69c2e9296364c4d6d566df374198837aa2c7811c21ecf49561342006bd76f948ed14831b22d6b7d36df1c9b46d93c0aeb48052510c588e
+DIST fheroes2-1.0.9.tar.gz 11784935 BLAKE2B 0c85725f791615eb1f823f38cfc03a98a73d71d1c0dedeac2146f62099c25ed37bbd44c9d121099934f99850ad408c13c1ea1b51f531a2cc37a56d01a0beb826 SHA512 eeb575345a6250d60ed8c37ec66deec4f5383557d8259a6422ace84520321316016494d0cd6e8d5b57123f946f3841fc215183c297c9acefe17caa3e94123ea7
diff --git a/games-engines/fheroes2/fheroes2-1.0.9.ebuild b/games-engines/fheroes2/fheroes2-1.0.9.ebuild
new file mode 100644
index 000000000000..58080ed9163f
--- /dev/null
+++ b/games-engines/fheroes2/fheroes2-1.0.9.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+inherit cmake python-single-r1 xdg
+
+DESCRIPTION="Recreation of HoMM2 game engine"
+HOMEPAGE="https://ihhub.github.io/fheroes2/"
+SRC_URI="https://github.com/ihhub/fheroes2/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+IUSE="tools"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ media-libs/libpng:=
+ media-libs/libsdl2[video]
+ media-libs/sdl2-image
+ media-libs/sdl2-mixer
+ sys-libs/zlib
+"
+RDEPEND="
+ ${DEPEND}
+ ${PYTHON_DEPS}
+ app-arch/libarchive
+ dev-lang/python
+ virtual/libintl
+"
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}/fheroes2-1.0.4-scripts.patch"
+)
+
+src_configure() {
+ # Not using dev-games/libsmacker because the game crashes with it
+ local mycmakeargs=(
+ -DENABLE_IMAGE=ON
+ -DENABLE_TOOLS=$(usex tools)
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ emake -C files/lang
+}
+
+src_install() {
+ cmake_src_install
+
+ if use tools; then
+ for file in 82m2wav bin2txt extractor h2dmgr icn2img pal2img til2img xmi2midi; do
+ newbin "${BUILD_DIR}/${file}" "fheroes2-${file}"
+ done
+ fi
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ elog "You need original HoMM2 data files to play fheroes2."
+ elog "If you have an installer (.exe) from GOG, install:"
+ elog " games-strategy/homm2-gold-gog"
+ elog "If you have the original game installed somewhere already, run:"
+ elog " ${EPREFIX}/usr/share/fheroes2/extract_homm2_resources.sh"
+ elog "Also you can automatically get a demo version for free by installing:"
+ elog " games-strategy/homm2-demo"
+}