summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2019-02-10 14:21:58 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2019-02-10 14:21:58 +0100
commit1b7143b28ba6fce4f68b0bbbdcb47e4139538c88 (patch)
treef763a50e4245456b8a57ffddbb1e199ddc1676ab
parentwww-servers/tomcat-7.0.92: amd64 stable (diff)
downloadgentoo-1b7143b28ba6fce4f68b0bbbdcb47e4139538c88.tar.gz
gentoo-1b7143b28ba6fce4f68b0bbbdcb47e4139538c88.tar.bz2
gentoo-1b7143b28ba6fce4f68b0bbbdcb47e4139538c88.zip
www-servers/tomcat-7.0.90: removed obsolete
Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
-rw-r--r--www-servers/tomcat/Manifest1
-rw-r--r--www-servers/tomcat/tomcat-7.0.90.ebuild147
2 files changed, 0 insertions, 148 deletions
diff --git a/www-servers/tomcat/Manifest b/www-servers/tomcat/Manifest
index efaea0ce320a..eb08c4a869f4 100644
--- a/www-servers/tomcat/Manifest
+++ b/www-servers/tomcat/Manifest
@@ -1,4 +1,3 @@
-DIST apache-tomcat-7.0.90-src.tar.gz 4752747 BLAKE2B 5062ead2756aa8461de5e8387f14838661c082b6e397934fc92c91403f1950d84d79f05b9d4420a973d1b4921515b66c2c847550e1a06d75e722b62d9aa3f8bd SHA512 b32cb6902866ef72337c721d99d77f1a645311bb7694f51b82f7acec500c6197df15fb41be444fc6089652e8c825fb193f1a9de8c1b9b6fabd9d95f784565f6a
DIST apache-tomcat-7.0.92-src.tar.gz 4778943 BLAKE2B d11b01219a25c303ce791d965908c79cd48b5c97e1f0bed81ae60e0fcae3c4b23906f652eaf1d2922db7a57e68ee9f5a09ef017b7f1b89ed6c2ab81a477a810e SHA512 8cbcaf6d8dcda5ad8bd667582a39e91c1feaa4cc7216cafc23b9f5cf005cce9af24473c1c9d573f4da26c88ea68520a113dc0a7e2a50823f3ba3bb1510ec9e0a
DIST apache-tomcat-8.0.52-src.tar.gz 5039683 BLAKE2B 36318d0ae50fbca3f2a97e0210d0a8da8314f1ef79d0b047971bca30a5b0cc937faf013b5090f6e6b8aec4127b6185dc54ae589f5b57143b62c71c09f8bd5e9d SHA512 6d846213db0b15f9add8d80f30f304afdaf879ab6d7f85d212183a93f4f360ebfeeb079813bdea83cbd13f507504473028bbf8279e89b800b6f150b83086fa56
DIST apache-tomcat-8.0.53-src.tar.gz 5057041 BLAKE2B 3a50d2f61baecb5244909972384e36478c69e7592dd35119d8b7b974273c57a4855082f309146ed160144dbdcced3236fd586b047970bd8558bbe7b7e002e9fd SHA512 0b56bc723277b2888896ab34ec3e49cb56bac94ddf1a9b96bd023982e2ffabd5317f63b3c0971afdc8cd7a6364197409df461d22151dbaab3a2be7daf6858b9e
diff --git a/www-servers/tomcat/tomcat-7.0.90.ebuild b/www-servers/tomcat/tomcat-7.0.90.ebuild
deleted file mode 100644
index 9acd6b92a2e4..000000000000
--- a/www-servers/tomcat/tomcat-7.0.90.ebuild
+++ /dev/null
@@ -1,147 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-JAVA_PKG_IUSE="doc source test"
-
-inherit eutils java-pkg-2 java-ant-2 prefix user
-
-MY_P="apache-${P}-src"
-
-DESCRIPTION="Tomcat Servlet-3.0/JSP-2.2 Container"
-HOMEPAGE="https://tomcat.apache.org/"
-SRC_URI="mirror://apache/${PN}/tomcat-7/v${PV}/src/${MY_P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="7"
-KEYWORDS="amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
-IUSE="extra-webapps websockets"
-
-RESTRICT="test" # can we run them on a production system?
-
-ECJ_SLOT="4.5"
-SAPI_SLOT="3.0"
-
-COMMON_DEP="dev-java/eclipse-ecj:${ECJ_SLOT}
- dev-java/tomcat-servlet-api:${SAPI_SLOT}"
-RDEPEND="${COMMON_DEP}
- virtual/jre
- !<dev-java/tomcat-native-1.1.24"
-DEPEND="${COMMON_DEP}
- virtual/jdk:1.8
- test? ( dev-java/ant-junit:0 )"
-
-S=${WORKDIR}/${MY_P}
-
-pkg_setup() {
- java-pkg-2_pkg_setup
- enewgroup tomcat 265
- enewuser tomcat 265 -1 /dev/null tomcat
-}
-
-src_prepare() {
- default
-
- # Remove bundled servlet-api
- rm -rv java/javax/{el,servlet} || die
-
- java-pkg_clean
-
- eapply "${FILESDIR}/${PN}-7.0.84-build.xml.patch"
-
- # For use of catalina.sh in netbeans
- sed -i -e "/^# ----- Execute The Requested Command/ a\
- CLASSPATH=\`java-config --classpath ${PN}-${SLOT}\`" \
- bin/catalina.sh || die
-
- java-pkg-2_src_prepare
-}
-
-JAVA_ANT_REWRITE_CLASSPATH="true"
-
-EANT_BUILD_TARGET="deploy"
-EANT_GENTOO_CLASSPATH="eclipse-ecj-${ECJ_SLOT},tomcat-servlet-api-${SAPI_SLOT}"
-EANT_GENTOO_CLASSPATH_EXTRA="${S}/output/classes"
-EANT_NEEDS_TOOLS="true"
-EANT_EXTRA_ARGS="-Dversion=${PV}-gentoo -Dversion.number=${PV} -Dcompile.debug=false"
-
-# revisions of the scripts
-IM_REV="-r1"
-INIT_REV="-r1"
-
-src_compile() {
- use websockets && EANT_EXTRA_ARGS+=" -Djava.7.home=${JAVA_HOME}"
- EANT_GENTOO_CLASSPATH_EXTRA+=":$(java-pkg_getjar --build-only ant-core ant.jar)"
- java-pkg-2_src_compile
-}
-
-src_test() {
- java-pkg-2_src_test
-}
-
-src_install() {
- local dest="/usr/share/${PN}-${SLOT}"
-
- java-pkg_jarinto "${dest}"/bin
- java-pkg_dojar output/build/bin/*.jar
- exeinto "${dest}"/bin
- doexe output/build/bin/*.sh
-
- java-pkg_jarinto "${dest}"/lib
- java-pkg_dojar output/build/lib/*.jar
-
- dodoc RELEASE-NOTES RUNNING.txt
- use doc && java-pkg_dojavadoc output/dist/webapps/docs/api
- use source && java-pkg_dosrc java/*
-
- ### Webapps ###
-
- insinto "${dest}"/webapps
- doins -r output/build/webapps/{host-manager,manager,ROOT}
- use extra-webapps && doins -r output/build/webapps/{docs,examples}
-
- ### Config ###
-
- # create "logs" directory in $CATALINA_BASE
- # and set correct perms, see #458890
- dodir "${dest}"/logs
- fperms 0750 "${dest}"/logs
-
- # replace the default pw with a random one, see #92281
- local randpw=$(echo ${RANDOM}|md5sum|cut -c 1-15)
- sed -i -e "s|SHUTDOWN|${randpw}|" output/build/conf/server.xml || die
-
- # prepend gentoo.classpath to common.loader, see #453212
- sed -i -e 's/^common\.loader=/\0${gentoo.classpath},/' output/build/conf/catalina.properties || die
-
- insinto "${dest}"
- doins -r output/build/conf
-
- ### rc ###
-
- cp "${FILESDIR}"/tomcat{.conf,${INIT_REV}.init,-instance-manager${IM_REV}.bash} "${T}" || die
- eprefixify "${T}"/tomcat{.conf,${INIT_REV}.init,-instance-manager${IM_REV}.bash}
- sed -i -e "s|@SLOT@|${SLOT}|g" "${T}"/tomcat{.conf,${INIT_REV}.init,-instance-manager${IM_REV}.bash} || die
-
- insinto "${dest}"/gentoo
- doins "${T}"/tomcat.conf
- exeinto "${dest}"/gentoo
- newexe "${T}"/tomcat${INIT_REV}.init tomcat.init
- newexe "${T}"/tomcat-instance-manager${IM_REV}.bash tomcat-instance-manager.bash
-}
-
-pkg_postinst() {
- elog "New ebuilds of Tomcat support running multiple instances. If you used prior version"
- elog "of Tomcat (<7.0.32), you have to migrate your existing instance to work with new Tomcat."
- elog "You can find more information at https://wiki.gentoo.org/wiki/Apache_Tomcat"
-
- elog "To manage Tomcat instances, run:"
- elog " ${EPREFIX}/usr/share/${PN}-${SLOT}/gentoo/tomcat-instance-manager.bash --help"
-
- ewarn "tomcat-dbcp.jar is not built at this time. Please fetch jar"
- ewarn "from upstream binary if you need it. Gentoo Bug # 144276"
-
- einfo "Please read https://wiki.gentoo.org/wiki/Apache_Tomcat and"
- einfo "https://wiki.gentoo.org/wiki/Project:Java/Tomcat_6_Guide for more information."
-}