summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-12-23 23:16:02 -0500
committerMatt Turner <mattst88@gentoo.org>2020-12-23 23:16:57 -0500
commit1b9571ba4b96a813ea04b8c742d1c1273d2114ec (patch)
treea8cedb00cc0d5786afa496eca03df60787911e80
parentdev-util/spirv-tools: Add Python 3.9 compatibility (diff)
downloadgentoo-1b9571ba4b96a813ea04b8c742d1c1273d2114ec.tar.gz
gentoo-1b9571ba4b96a813ea04b8c742d1c1273d2114ec.tar.bz2
gentoo-1b9571ba4b96a813ea04b8c742d1c1273d2114ec.zip
dev-python/python-libevdev: Version bump to 0.9
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--dev-python/python-libevdev/Manifest1
-rw-r--r--dev-python/python-libevdev/python-libevdev-0.9.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/python-libevdev/Manifest b/dev-python/python-libevdev/Manifest
index 774520416af4..ea7597caa32c 100644
--- a/dev-python/python-libevdev/Manifest
+++ b/dev-python/python-libevdev/Manifest
@@ -1 +1,2 @@
DIST python-libevdev-0.8.tar.bz2 30375 BLAKE2B b59a705d49a54d5f98bca3bdf97038128df35294d4e62ffe058021c4da846e75a372660a4beef7e83dbf5b16a4d7d9195547f713bd290b14ca28ecd9291ac641 SHA512 c3c35e82b78f8968c930883a99def348a012a05ea122ac24e757441e81079f7c12bd50d96e8cec7b799a2d775d834859f924e8d1dc5841c718c050287fd1beb0
+DIST python-libevdev-0.9.tar.bz2 31496 BLAKE2B 4802f1528c104b0717f3f3a450e6e704232d5045ac285b96eb3eb690f120969ea0f23eae1da6013b260627f18b3e58e55a5017401928149e9cc581d9a84fad70 SHA512 77dcb18c393fd7962887d477292ec359c65404ae126624dc5ab201528e53b9fab565d5c6acfe2908f4a03a29e09fad862220246b91a92cc5f69768a31d1ca808
diff --git a/dev-python/python-libevdev/python-libevdev-0.9.ebuild b/dev-python/python-libevdev/python-libevdev-0.9.ebuild
new file mode 100644
index 000000000000..a8f0ef742a66
--- /dev/null
+++ b/dev-python/python-libevdev/python-libevdev-0.9.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrappers for the libevdev library"
+HOMEPAGE="https://gitlab.freedesktop.org/libevdev/python-libevdev"
+SRC_URI="https://gitlab.freedesktop.org/libevdev/${PN}/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ test? ( dev-libs/libevdev )
+"
+
+python_test() {
+ esetup.py test
+}