summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-04-18 11:57:19 -0400
committerMatt Turner <mattst88@gentoo.org>2023-04-18 12:02:29 -0400
commit1b9ba93f6a595027e915fccacdd6d826a11cff59 (patch)
treed4a5db039ad155fe800fd7cee057d5e8dd21978c
parentsci-libs/med: restrict to hdf5<14 (diff)
downloadgentoo-1b9ba93f6a595027e915fccacdd6d826a11cff59.tar.gz
gentoo-1b9ba93f6a595027e915fccacdd6d826a11cff59.tar.bz2
gentoo-1b9ba93f6a595027e915fccacdd6d826a11cff59.zip
gnome-base/gnome-settings-daemon: Version bump to 44.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--gnome-base/gnome-settings-daemon/Manifest1
-rw-r--r--gnome-base/gnome-settings-daemon/gnome-settings-daemon-44.1.ebuild139
2 files changed, 140 insertions, 0 deletions
diff --git a/gnome-base/gnome-settings-daemon/Manifest b/gnome-base/gnome-settings-daemon/Manifest
index 000aace8cabf..cabd9fac3fc8 100644
--- a/gnome-base/gnome-settings-daemon/Manifest
+++ b/gnome-base/gnome-settings-daemon/Manifest
@@ -1,2 +1,3 @@
DIST gnome-settings-daemon-43.0.tar.xz 1453808 BLAKE2B 365a1fe4d253e84b9fc355331688951e1428eaee421afbe052a16226c7006a420f28134b5fa02929bbb1d4250af243b02594444a4bdd208e5c41ed9e63e5f979 SHA512 8cc3ed73fa66d2cf72621db78be68e4fe01f292ab3987aff8cc67a1c67d910622e306c2d3e69a8dca5ac6517c8e57883faf02aec871c7aa1f1348d13ff1900a3
DIST gnome-settings-daemon-44.0.tar.xz 1464004 BLAKE2B 2c32dbea04f2d5107eab934379f955393590aa1ce2a4b27368d4df493fc96a07c0b21942a3a8987f85dfff4c6945e455c9113c1250c8fde3559ade43f81989d9 SHA512 276d1c2e559e0297855cfc9fc7bd2ce4ae55e2b711222f1f1aae4802dc6499f51ea09bff8f44c5d7b9f0f5a32ab187c2ac4d8ee8e5f1754a186ac189b4e885da
+DIST gnome-settings-daemon-44.1.tar.xz 1458612 BLAKE2B 86a66087c899c583a3ff77f1268d83af6ebc6e703cc31c76d21fcc3482ad2e54cf46c07af27f79126b26c0720eb1ecbaaf65c9a13b5a04edeb0145188881a4f7 SHA512 a955d74a594d49f67a5c27ac60d6f1e9b4aba7b12cbd0af8d3be02c4b2e8385f1abfbe08b62177b69851e9202960a17429373bf5533adbd73699232fefea6c79
diff --git a/gnome-base/gnome-settings-daemon/gnome-settings-daemon-44.1.ebuild b/gnome-base/gnome-settings-daemon/gnome-settings-daemon-44.1.ebuild
new file mode 100644
index 000000000000..006297788deb
--- /dev/null
+++ b/gnome-base/gnome-settings-daemon/gnome-settings-daemon-44.1.ebuild
@@ -0,0 +1,139 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit gnome.org gnome2-utils python-any-r1 meson udev virtualx xdg
+
+DESCRIPTION="Gnome Settings Daemon"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gnome-settings-daemon"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+IUSE="+colord +cups debug elogind input_devices_wacom modemmanager networkmanager smartcard systemd test wayland"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="^^ ( elogind systemd )"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+
+COMMON_DEPEND="
+ >=sci-geosciences/geocode-glib-3.10:2
+ >=dev-libs/glib-2.58:2
+ >=gnome-base/gnome-desktop-3.37.1:3=
+ >=gnome-base/gsettings-desktop-schemas-42
+ >=x11-libs/gtk+-3.15.3:3[X,wayland?]
+ >=dev-libs/libgweather-4.2.0:4=
+ colord? ( >=x11-misc/colord-1.4.5:= )
+ media-libs/libcanberra[gtk3]
+ >=app-misc/geoclue-2.3.1:2.0
+ >=x11-libs/libnotify-0.7.3
+ >=media-sound/pulseaudio-12.99.3[glib]
+ >=sys-auth/polkit-0.114
+ >=sys-power/upower-0.99.12:=
+ x11-libs/libX11
+ >=x11-libs/libXfixes-6.0.0
+ dev-libs/libgudev:=
+ wayland? ( dev-libs/wayland )
+ input_devices_wacom? (
+ >=dev-libs/libwacom-0.7:=
+ >=x11-libs/pango-1.20.0
+ x11-libs/gdk-pixbuf:2
+ )
+ smartcard? ( >=dev-libs/nss-3.11.2 )
+ cups? ( >=net-print/cups-1.4[dbus] )
+ modemmanager? (
+ >=app-crypt/gcr-3.90.0:4=
+ >=net-misc/modemmanager-1.0:=
+ )
+ networkmanager? ( >=net-misc/networkmanager-1.0 )
+ media-libs/alsa-lib
+ x11-libs/libXi
+ x11-libs/libXext
+ media-libs/fontconfig
+ systemd? (
+ >=sys-apps/systemd-243
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ x11-base/xorg-proto
+"
+# logind needed for power and session management, bug #464944
+RDEPEND="${COMMON_DEPEND}
+ gnome-base/dconf
+ elogind? ( sys-auth/elogind )
+"
+# rfkill requires linux/rfkill.h, thus linux-headers dep, not os-headers. If this package wants to work on other kernels, we need to make rfkill conditional instead
+BDEPEND="
+ sys-kernel/linux-headers
+ dev-util/glib-utils
+ dev-util/gdbus-codegen
+ ${PYTHON_DEPS}
+ test? (
+ $(python_gen_any_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/python-dbusmock[${PYTHON_USEDEP}]
+ ')
+ gnome-base/gnome-session
+ )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/42.1-build-Make-wacom-optional-and-controllable-via-meson.patch
+ "${FILESDIR}"/${PN}-3.38.1-build-Allow-NM-optional-on-Linux.patch
+)
+
+python_check_deps() {
+ if use test; then
+ python_has_version "dev-python/pygobject:3[${PYTHON_USEDEP}]" &&
+ python_has_version "dev-python/python-dbusmock[${PYTHON_USEDEP}]"
+ fi
+}
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ #-Dnssdb_dir # TODO: Is the default /etc/pki/nssdb path correct for our nss?
+ -Dudev_dir="$(get_udevdir)"
+ $(meson_use systemd)
+ -Dalsa=true
+ -Dgudev=true
+ -Dgcr3=false
+ $(meson_use colord)
+ $(meson_use cups)
+ $(meson_use networkmanager network_manager)
+ -Drfkill=true
+ $(meson_use smartcard)
+ $(meson_use input_devices_wacom wacom)
+ $(meson_use wayland)
+ $(meson_use modemmanager wwan)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ # Don't auto-suspend by default on AC power
+ insinto /usr/share/glib-2.0/schemas
+ doins "${FILESDIR}"/org.gnome.settings-daemon.plugins.power.gschema.override
+}
+
+src_test() {
+ virtx meson_src_test
+}
+
+pkg_postinst() {
+ udev_reload
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ udev_reload
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}