summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-01-02 00:42:42 +0100
committerJeroen Roovers <jer@gentoo.org>2020-01-02 00:54:52 +0100
commit1ba0756b534a0187d5ea75a6f70adc932b22fff5 (patch)
tree7f3deeac34f0c9ac56ddd698d767dbd42ec4bb12
parentapp-office/scribus: remove unused patch (diff)
downloadgentoo-1ba0756b.tar.gz
gentoo-1ba0756b.tar.bz2
gentoo-1ba0756b.zip
media-gfx/scrot: Add live ebuild
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
-rw-r--r--media-gfx/scrot/scrot-9999.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/media-gfx/scrot/scrot-9999.ebuild b/media-gfx/scrot/scrot-9999.ebuild
new file mode 100644
index 000000000000..da5268bea717
--- /dev/null
+++ b/media-gfx/scrot/scrot-9999.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools bash-completion-r1 git-r3
+
+DESCRIPTION="Screen capture utility using imlib2 library"
+HOMEPAGE="https://github.com/resurrecting-open-source-projects/scrot"
+EGIT_REPO_URI="https://github.com/resurrecting-open-source-projects/${PN}"
+
+LICENSE="feh LGPL-2+"
+SLOT="0"
+KEYWORDS=""
+
+RDEPEND="
+ >=media-libs/giblib-1.2.3
+ x11-libs/libX11
+ x11-libs/libXcursor
+ x11-libs/libXfixes
+ || (
+ media-libs/imlib2[gif]
+ media-libs/imlib2[jpeg]
+ media-libs/imlib2[png]
+ media-libs/imlib2[tiff]
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+DOCS=(
+ AUTHORS ChangeLog CONTRIBUTING.md README TODO
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ newbashcomp "${FILESDIR}"/${PN}-1.2.bash-completion ${PN}
+}