summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-08-18 07:07:01 +0200
committerMichał Górny <mgorny@gentoo.org>2022-08-18 08:18:32 +0200
commit1ba4ee1a10425ee98a110dae14daf107ec184aad (patch)
tree0ad89363636717fb644f30e238f75fa8de21d163
parentdev-python/blinker: Remove obsolete patch (diff)
downloadgentoo-1ba4ee1a.tar.gz
gentoo-1ba4ee1a.tar.bz2
gentoo-1ba4ee1a.zip
dev-python/sentry-sdk: Revert "drop 1.7.2"
Wrong version. Reverts: 6b302b75e8fb42006c3eda973dd9e3a5ad648241 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/sentry-sdk/Manifest1
-rw-r--r--dev-python/sentry-sdk/sentry-sdk-1.7.2.ebuild91
2 files changed, 92 insertions, 0 deletions
diff --git a/dev-python/sentry-sdk/Manifest b/dev-python/sentry-sdk/Manifest
index f14a04e1c031..94d927a49f41 100644
--- a/dev-python/sentry-sdk/Manifest
+++ b/dev-python/sentry-sdk/Manifest
@@ -1,4 +1,5 @@
DIST sentry-sdk-1.6.0.gh.tar.gz 249637 BLAKE2B c4d6788c80184ce9127ed85dfb5305363fd27bcbebd74763e4c14c4fed35dd05069ad4a244fa2d8a59f8cb618df22d4d864bf72510fe42600d23fcc6bf8228cf SHA512 d2999831af595ed7f1861ec78887e46887eea8c4c931f22bd4003aede508511287f67eb6100232362a110d16b7bdec892572225440be52a9bd37952c30478f15
+DIST sentry-sdk-1.7.2.gh.tar.gz 254370 BLAKE2B e65b2236bfec9279a4aa05b77c9492547f657e461a7c96c4158acb6bc0887571186bfa71893dce34251ef8d783fb5d583b25aa12539c5db7993cec65fdf05229 SHA512 9fe2c283a326b78c8be95500e4916bb633dc7369960a4e0ef69c0f29de74c38db81f43b3931c47d50431ee7f1a66a2b18e8c4fc02ce71c404a5e9700644cb76c
DIST sentry-sdk-1.8.0.gh.tar.gz 286488 BLAKE2B d47f33a1c83cfffa6e4a801a6fdfde132d4cfe1b734e464c4db60e97abf53ebe503c53c3edd89d1a84e655a348a4463a75c3475d4824d03cd9b95733b13b5532 SHA512 aa3be96dbc55265f17371d8f20f8b3116b4310cbc1d078b62beeb1fd90bdbb840db85c25309e16f793a188d373c6dbcfd11a104db21b60221a5fb06d8deacc2d
DIST sentry-sdk-1.9.0.gh.tar.gz 290271 BLAKE2B fcb4c45c129faf23a1177167e2bdd567a7ff228abbaa782676abb16c29e9c4cccef89f67ae5cd28c4f2b25e6687152fdc5eab0c7d981021a8df16374dc4e1fec SHA512 4f287bad8e9dd8eaad8f8a31d7335ccf6bfe72cc0ba8c0b26abcbd7e326bad886709d001976966a7b917f39e1ca249fa881abf29778cfd4bd65c63f05a6f6ef2
DIST sentry-sdk-1.9.1.gh.tar.gz 270398 BLAKE2B 66ee16816d312b38df737c5ecb0ecc4a2189c932c162bbedf165f2a153029e95c389372a4638d5f71f669ac780710769e4708c3e7673573d1b1e79a29cbf93c9 SHA512 5997252aeee900125e42d7275627359ca5382707162b93e45b238c11a181ac724fea327fa1b29deed63dbf800463d10c9d2a8e8943c32b907e4eac055e399297
diff --git a/dev-python/sentry-sdk/sentry-sdk-1.7.2.ebuild b/dev-python/sentry-sdk/sentry-sdk-1.7.2.ebuild
new file mode 100644
index 000000000000..ac1650bb3f7f
--- /dev/null
+++ b/dev-python/sentry-sdk/sentry-sdk-1.7.2.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python client for Sentry"
+HOMEPAGE="
+ https://sentry.io/
+ https://github.com/getsentry/sentry-python/
+ https://pypi.org/project/sentry-sdk/
+"
+SRC_URI="
+ https://github.com/getsentry/sentry-python/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/sentry-python-${PV}"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ~ppc ~ppc64 ~riscv ~sparc x86"
+
+RDEPEND="
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/asttokens[${PYTHON_USEDEP}]
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/executing[${PYTHON_USEDEP}]
+ dev-python/fakeredis[${PYTHON_USEDEP}]
+ dev-python/flask-login[${PYTHON_USEDEP}]
+ dev-python/gevent[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pyrsistent[${PYTHON_USEDEP}]
+ dev-python/pytest-aiohttp[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/zope-event[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/eventlet[${PYTHON_USEDEP}]
+ ' python3_{8..9})
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # tests require Internet access
+ tests/integrations/httpx/test_httpx.py
+ tests/integrations/requests/test_requests.py
+ tests/integrations/stdlib/test_httplib.py
+ tests/integrations/flask/test_flask.py
+ tests/integrations/django/test_basic.py
+ # wtf is it supposed to do?!
+ tests/integrations/gcp/test_gcp.py
+ # broken by rq-1.10.1 (optional dep)
+ tests/integrations/rq/test_rq.py
+ # fastapi is not packaged
+ tests/integrations/asgi/test_fastapi.py
+ # TODO
+ tests/integrations/bottle
+)
+
+EPYTEST_DESELECT=(
+ # hangs
+ 'tests/test_transport.py::test_transport_works'
+ # TODO
+ 'tests/test_basics.py::test_auto_enabling_integrations_catches_import_error'
+ tests/test_client.py::test_databag_depth_stripping
+ tests/test_client.py::test_databag_string_stripping
+ tests/test_client.py::test_databag_breadth_stripping
+ tests/integrations/asgi/test_asgi.py::test_auto_session_tracking_with_aggregates
+ tests/integrations/asgi/test_asgi.py::test_websocket
+ # incompatible version?
+ tests/integrations/falcon/test_falcon.py
+ tests/integrations/sqlalchemy/test_sqlalchemy.py::test_too_large_event_truncated
+ # test_circular_references: apparently fragile
+ 'tests/integrations/threading/test_threading.py::test_circular_references'
+ # test for new feature, fails with IndexError
+ tests/integrations/wsgi/test_wsgi.py::test_session_mode_defaults_to_request_mode_in_wsgi_handler
+ # TODO
+ tests/integrations/wsgi/test_wsgi.py::test_auto_session_tracking_with_aggregates
+)