summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-09-11 10:26:36 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2016-09-11 11:01:27 +0100
commit1ba6b8c4eb80f3debe1a556202b10bb28deeec59 (patch)
tree75be402dcf42d73204b8e170b3f9d8d5ac57594f
parentdev-haskell/xmlgen: XML generation library, a depend of dev-haskell/htf (diff)
downloadgentoo-1ba6b8c4eb80f3debe1a556202b10bb28deeec59.tar.gz
gentoo-1ba6b8c4eb80f3debe1a556202b10bb28deeec59.tar.bz2
gentoo-1ba6b8c4eb80f3debe1a556202b10bb28deeec59.zip
dev-haskell/htf: haskell test framework, a depend of dev-haskell/argparser
Package-Manager: portage-2.3.0
-rw-r--r--dev-haskell/htf/Manifest1
-rw-r--r--dev-haskell/htf/files/htf-0.13.1.0-aeson-pretty-0.8.patch9
-rw-r--r--dev-haskell/htf/htf-0.13.1.0.ebuild53
-rw-r--r--dev-haskell/htf/metadata.xml20
4 files changed, 83 insertions, 0 deletions
diff --git a/dev-haskell/htf/Manifest b/dev-haskell/htf/Manifest
new file mode 100644
index 000000000000..d9f48bca9311
--- /dev/null
+++ b/dev-haskell/htf/Manifest
@@ -0,0 +1 @@
+DIST HTF-0.13.1.0.tar.gz 78310 SHA256 1cb469ee21766fb7ad56fb42469709fac06214f7a33c39880134dfc2ea0de847 SHA512 1292f8f0b9189e1ce05de1cf6f686ce77a839c4191a5f8b8000c8d740abe4b8f457a7c5ed8aadc13221fe9fde9b4c15bde9f9f6f53ac03178cd1884572fb4069 WHIRLPOOL 76f85fc1710d598ac38bb7849467536af705d9ab82811745212c28ae0a2e5c8fac588320e30f3c44b173665dfb60089c37610ac669f075bf6ef74f255508baff
diff --git a/dev-haskell/htf/files/htf-0.13.1.0-aeson-pretty-0.8.patch b/dev-haskell/htf/files/htf-0.13.1.0-aeson-pretty-0.8.patch
new file mode 100644
index 000000000000..ac1472051eba
--- /dev/null
+++ b/dev-haskell/htf/files/htf-0.13.1.0-aeson-pretty-0.8.patch
@@ -0,0 +1,9 @@
+diff --git a/tests/TestHTF.hs b/tests/TestHTF.hs
+index 4a71874..c0442a5 100644
+--- a/tests/TestHTF.hs
++++ b/tests/TestHTF.hs
+@@ -383,3 +383,3 @@ checkOutput output =
+ BSL.toStrict $
+- J.encodePretty' (J.Config 2 J.compare) json
++ J.encodePretty' (J.defConfig { J.confIndent = J.Spaces 2, J.confCompare = J.compare }) json
+
diff --git a/dev-haskell/htf/htf-0.13.1.0.ebuild b/dev-haskell/htf/htf-0.13.1.0.ebuild
new file mode 100644
index 000000000000..758bbc02f343
--- /dev/null
+++ b/dev-haskell/htf/htf-0.13.1.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.6.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+MY_PN="HTF"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="The Haskell Test Framework"
+HOMEPAGE="https://github.com/skogsbaer/HTF/"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/aeson-0.6:=[profile?]
+ dev-haskell/base64-bytestring:=[profile?]
+ >=dev-haskell/cpphs-1.19:=[profile?]
+ >=dev-haskell/diff-0.3:=[profile?]
+ dev-haskell/haskell-src:=[profile?]
+ >=dev-haskell/hunit-1.2.5:=[profile?]
+ >=dev-haskell/lifted-base-0.1:=[profile?]
+ >=dev-haskell/monad-control-0.3:=[profile?]
+ >=dev-haskell/mtl-1.1:=[profile?]
+ >=dev-haskell/old-time-1.0:=[profile?]
+ >=dev-haskell/quickcheck-2.3:2=[profile?]
+ >=dev-haskell/random-1.0:=[profile?]
+ >=dev-haskell/regex-compat-0.92:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ dev-haskell/vector:=[profile?]
+ >=dev-haskell/xmlgen-0.6:=[profile?]
+ >=dev-lang/ghc-7.6.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.16.0
+ test? ( dev-haskell/aeson-pretty
+ >=dev-haskell/temporary-1.1
+ >=dev-haskell/unordered-containers-0.2 )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-aeson-pretty-0.8.patch
+}
diff --git a/dev-haskell/htf/metadata.xml b/dev-haskell/htf/metadata.xml
new file mode 100644
index 000000000000..c786b01278af
--- /dev/null
+++ b/dev-haskell/htf/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ The Haskell Test Framework (/HTF/ for short) lets you define unit
+ tests (&lt;http://hunit.sourceforge.net&gt;), QuickCheck properties
+ (&lt;http://www.cs.chalmers.se/~rjmh/QuickCheck/&gt;), and black box
+ tests in an easy and convenient way. The HTF uses a custom
+ preprocessor that collects test definitions automatically.
+ Furthermore, the preprocessor allows the HTF to report failing
+ test cases with exact file name and line number information.
+
+ The documentation of the "Test.Framework.Tutorial" module
+ provides a tutorial for the HTF.
+ </longdescription>
+</pkgmetadata>