summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-02-27 21:10:42 +0000
committerSam James <sam@gentoo.org>2021-02-27 21:39:13 +0000
commit1ba94803af2d44b47118096a29fc76453c4c3bc5 (patch)
tree5070cb6a397bc96947038a1e5b66d16d958a5979
parentdev-python/keyring: Bump to 22.3.0 (diff)
downloadgentoo-1ba94803af2d44b47118096a29fc76453c4c3bc5.tar.gz
gentoo-1ba94803af2d44b47118096a29fc76453c4c3bc5.tar.bz2
gentoo-1ba94803af2d44b47118096a29fc76453c4c3bc5.zip
dev-python/xxhash: add Python 3.9
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-python/xxhash/xxhash-2.0.0.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/dev-python/xxhash/xxhash-2.0.0.ebuild b/dev-python/xxhash/xxhash-2.0.0.ebuild
index 287ddf042f31..a27b42c102fa 100644
--- a/dev-python/xxhash/xxhash-2.0.0.ebuild
+++ b/dev-python/xxhash/xxhash-2.0.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=(python3_{7..8})
+PYTHON_COMPAT=( python3_{7..9} )
inherit distutils-r1
@@ -15,7 +15,6 @@ LICENSE="MIT"
KEYWORDS="~amd64"
SLOT="0"
-IUSE="test"
RDEPEND=">=dev-libs/xxhash-0.8.0"
BDEPEND="${RDEPEND}"
@@ -27,6 +26,6 @@ python_configure_all() {
}
python_test() {
- cd tests
+ cd tests || die
"${EPYTHON}" -m unittest discover -v || die "tests failed with ${EPYTHON}"
}