summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-09-20 16:04:35 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-09-20 16:07:28 -0500
commit1bb1631c28ea752a0fb7eed29c50e3a77a157a07 (patch)
tree18a1efac5d230217b26fcf83f3238c333d0e981d
parentapp-admin/puppetdb: 6.6.0 bump (diff)
downloadgentoo-1bb1631c28ea752a0fb7eed29c50e3a77a157a07.tar.gz
gentoo-1bb1631c28ea752a0fb7eed29c50e3a77a157a07.tar.bz2
gentoo-1bb1631c28ea752a0fb7eed29c50e3a77a157a07.zip
dev-ruby/puppetdb-termini: 6.6.0 bump
Package-Manager: Portage-2.3.69, Repoman-2.3.17 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--dev-ruby/puppetdb-termini/Manifest1
-rw-r--r--dev-ruby/puppetdb-termini/puppetdb-termini-6.6.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/puppetdb-termini/Manifest b/dev-ruby/puppetdb-termini/Manifest
index 398f7e24a809..989df4f690ed 100644
--- a/dev-ruby/puppetdb-termini/Manifest
+++ b/dev-ruby/puppetdb-termini/Manifest
@@ -1,3 +1,4 @@
DIST puppetdb-termini_6.3.4-1stretch_all.deb 20680 BLAKE2B 41d64eb7a13a0036323b916a70cebdc1d522175e1b6460a0df577b35d57bdfd2eba76784e7af314336d618e7445639e12ec369f243d10b5120ef5006fa21efd3 SHA512 06ce200b4d919d99c28f5361993ca9a641f38d27b1e775db7f1edd10515b75ea131770f3e03a1e3f9d3b32cb8e6f32f6995a6df1e6b3f24d4601585db48a9d8b
DIST puppetdb-termini_6.4.0-1stretch_all.deb 20680 BLAKE2B ccd129eb8510794c165b6fa88ed391006e583e58fb43fe1be72e1b976d75f30aee0775552f6460840b805e1e4ceb03a6c77dba70afeed75dc2ea3ebcfd4bee77 SHA512 948b5ccd1ddc1f0d52174a073cd13af9e1ba0f713c5326c4d3cbfae7daeeb16cb05efdfb7ac572f9d79e34842fca0a95e054ee49239d593bf4429223c18bb58c
DIST puppetdb-termini_6.5.0-1stretch_all.deb 20870 BLAKE2B 41cf79f2b7ce218fdfbce2588d8e206a3751ffb07a133bc5ddef3f5662c51eb9d12cda3017921edd4aafc064ff35713daaea9542dac687b3f399f2706657131f SHA512 956952bbc81cbcabd8ef3e37b9ebc7c489c90da7b75ff2c9a3e36cd312ee3f7eb3350cbf21a8b44f1d6722ddd3168f5795ba7258147f340a111b9dc29796cd84
+DIST puppetdb-termini_6.6.0-1stretch_all.deb 21210 BLAKE2B 366c5d0d97e3e1f63e61bc6a8d7d05b621c226cff872c4f780b4b08aac8db9ebcbbe5e5c81f9a79f11e1fc9cedb8c42d86e69055fb5af2195f07c59347699eda SHA512 b410322239933539b685c65c1f85ecca28269adaf94d4521b4ee6d0780701889c6aaec4c01fdcdce1338277544d249c597ac9c697bdacdeb943c53fd6538d348
diff --git a/dev-ruby/puppetdb-termini/puppetdb-termini-6.6.0.ebuild b/dev-ruby/puppetdb-termini/puppetdb-termini-6.6.0.ebuild
new file mode 100644
index 000000000000..6d51b944dfdb
--- /dev/null
+++ b/dev-ruby/puppetdb-termini/puppetdb-termini-6.6.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby23 ruby24 ruby25 ruby26"
+
+inherit unpacker
+
+DESCRIPTION="Library needed to connect puppet to puppetdb"
+HOMEPAGE="http://docs.puppetlabs.com/puppetdb/"
+SRC_URI="http://apt.puppetlabs.com/pool/stretch/puppet/${PN:0:1}/${PN}/${PN}_${PV}-1stretch_all.deb"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+# will need the same keywords as puppet
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND+=""
+DEPEND+=""
+
+S=${WORKDIR}
+
+src_install() {
+ insinto opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/
+ doins -r opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/*
+}