summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Vetter <jubalh@iodoru.org>2023-04-15 19:00:21 +0000
committerJimi Huotari <chiitoo@gentoo.org>2023-04-18 01:05:51 +0300
commit1bb56790364a40fbb6b55fba2756d6365ee5c3a3 (patch)
tree1c44e8fa7d1b3706d5f3693490b35fa1beb9f0ce
parentlxqt-base/lxqt-powermanagement: add 1.3.0 (diff)
downloadgentoo-1bb56790.tar.gz
gentoo-1bb56790.tar.bz2
gentoo-1bb56790.zip
lxqt-base/lxqt-qtplugin: add 1.3.0
Signed-off-by: Michael Vetter <jubalh@iodoru.org> Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
-rw-r--r--lxqt-base/lxqt-qtplugin/Manifest1
-rw-r--r--lxqt-base/lxqt-qtplugin/lxqt-qtplugin-1.3.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-qtplugin/Manifest b/lxqt-base/lxqt-qtplugin/Manifest
index 5d6db1255c41..274b135e6afa 100644
--- a/lxqt-base/lxqt-qtplugin/Manifest
+++ b/lxqt-base/lxqt-qtplugin/Manifest
@@ -1 +1,2 @@
DIST lxqt-qtplugin-1.2.0.tar.xz 23848 BLAKE2B 02a97d6291ea9dce1cb7458283be5704eddd6a9ba503618cf6dca052fcb0aa25cc31419bef3e71e5b9270ed04ab151d0d197fb8226e3b99217399d8b615c588e SHA512 9c46b36e64a4b9f0b26bfac75a5fc1ba3a1af7a435526bc55fc9cee14b6bf51aa681d8bbb6eae56eadf26b7da23b37f833f56eddcdc8855cacb7f9c616c18ce4
+DIST lxqt-qtplugin-1.3.0.tar.xz 23864 BLAKE2B 4aa79eb0513a3efac265707864137ec935042d3357395fa9e08e1b735015e665c95afe45c8c32c262a76e2d8bd92e80956965cd65e64eef0d409094e4e56b7c1 SHA512 a1fefe5af7aacfb3c594fa1c181c2146c702fe0fabaf269c7e22e5755026accc68745d4ba64cd725ba66691f704c5a5d69658b55188b9919586601efbadc27ff
diff --git a/lxqt-base/lxqt-qtplugin/lxqt-qtplugin-1.3.0.ebuild b/lxqt-base/lxqt-qtplugin/lxqt-qtplugin-1.3.0.ebuild
new file mode 100644
index 000000000000..3ee5742c21af
--- /dev/null
+++ b/lxqt-base/lxqt-qtplugin/lxqt-qtplugin-1.3.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PV="$(ver_cut 1-2)"
+
+inherit cmake
+
+DESCRIPTION="LXQt system integration plugin for Qt"
+HOMEPAGE="https://lxqt-project.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+BDEPEND="
+ >=dev-qt/linguist-tools-5.15:5
+ >=dev-util/lxqt-build-tools-0.13.0
+"
+DEPEND="
+ dev-libs/libdbusmenu-qt[qt5(+)]
+ >=dev-libs/libqtxdg-3.11.0
+ >=dev-qt/qtcore-5.15:5
+ >=dev-qt/qtdbus-5.15:5
+ >=dev-qt/qtgui-5.15:5=
+ >=dev-qt/qtwidgets-5.15:5
+ =x11-libs/libfm-qt-${MY_PV}*
+"
+RDEPEND="${DEPEND}"