summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2023-08-15 17:25:40 +0200
committerFlorian Schmaus <flow@gentoo.org>2023-08-15 17:53:11 +0200
commit1bf27838bc88d60c218e5ba701202499d42cb287 (patch)
treeef4188cf0df69e6fa571d8754f788d03e9824a39
parentdev-python/portalocker: new package, add 2.7.0 (diff)
downloadgentoo-1bf27838bc88d60c218e5ba701202499d42cb287.tar.gz
gentoo-1bf27838bc88d60c218e5ba701202499d42cb287.tar.bz2
gentoo-1bf27838bc88d60c218e5ba701202499d42cb287.zip
dev-python/jsonpath-ng: new package, add 1.5.3
Signed-off-by: Florian Schmaus <flow@gentoo.org>
-rw-r--r--dev-python/jsonpath-ng/Manifest1
-rw-r--r--dev-python/jsonpath-ng/jsonpath-ng-1.5.3.ebuild38
-rw-r--r--dev-python/jsonpath-ng/metadata.xml12
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/jsonpath-ng/Manifest b/dev-python/jsonpath-ng/Manifest
new file mode 100644
index 000000000000..74e5acdda5c9
--- /dev/null
+++ b/dev-python/jsonpath-ng/Manifest
@@ -0,0 +1 @@
+DIST jsonpath-ng-1.5.3.tar.gz 32819 BLAKE2B 2f217638a5f4b76d0fe2bd8d0655794281d437983abe9fda96a40440bc97ba0ad13875b7cf83d06386258c43e66732b8a9d799ccaecf5034a9d01d120f403cb6 SHA512 adf501d0db74f76216476700dce342d7a92641ecb451bdce43d0c6abce59a278dc1696b959205030de256b456ae67a554ea35a5dec272f0a4fc84c4d2b76a5c1
diff --git a/dev-python/jsonpath-ng/jsonpath-ng-1.5.3.ebuild b/dev-python/jsonpath-ng/jsonpath-ng-1.5.3.ebuild
new file mode 100644
index 000000000000..4b2123f8e663
--- /dev/null
+++ b/dev-python/jsonpath-ng/jsonpath-ng-1.5.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_11 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python JSONPath Next-Generation"
+HOMEPAGE="
+ https://github.com/h2non/jsonpath-ng
+ https://pypi.org/project/jsonpath-ng/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/ply[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/oslotest[${PYTHON_USEDEP}]
+ dev-python/testscenarios[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ tests/test_jsonpath_rw_ext.py::Testjsonpath_ng_ext::test_fields_value
+)
diff --git a/dev-python/jsonpath-ng/metadata.xml b/dev-python/jsonpath-ng/metadata.xml
new file mode 100644
index 000000000000..220b98b8a585
--- /dev/null
+++ b/dev-python/jsonpath-ng/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <name>Florian Schmaus</name>
+ <email>flow@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">h2non/jsonpath-ng</remote-id>
+ <remote-id type="pypi">jsonpath-ng</remote-id>
+ </upstream>
+</pkgmetadata>