summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-24 14:59:10 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-24 14:59:10 +0200
commit1bf48a0e40e5b897c802207afc9881f27ddffd25 (patch)
tree2369827fb9122c531fce749070e6b441dee735c8
parentdev-python/sphinx_ansible_theme: Remove old (diff)
downloadgentoo-1bf48a0e40e5b897c802207afc9881f27ddffd25.tar.gz
gentoo-1bf48a0e40e5b897c802207afc9881f27ddffd25.tar.bz2
gentoo-1bf48a0e40e5b897c802207afc9881f27ddffd25.zip
dev-python/uvicorn: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/uvicorn/Manifest2
-rw-r--r--dev-python/uvicorn/files/uvicorn-0.21.1-optional-rust.patch80
-rw-r--r--dev-python/uvicorn/uvicorn-0.20.0.ebuild72
-rw-r--r--dev-python/uvicorn/uvicorn-0.21.1-r1.ebuild96
4 files changed, 0 insertions, 250 deletions
diff --git a/dev-python/uvicorn/Manifest b/dev-python/uvicorn/Manifest
index 69419035acb3..3171d6eec91b 100644
--- a/dev-python/uvicorn/Manifest
+++ b/dev-python/uvicorn/Manifest
@@ -1,4 +1,2 @@
-DIST uvicorn-0.20.0.gh.tar.gz 716073 BLAKE2B 7f1cf4808e985199d39e54e3563119cef1fe3af31361ad05a91278d32bc6f0dd741ad87f6073fbb720e9d9d4119fc8389b4e2feaaede665d8f68c56d56b37a17 SHA512 fa089da78dd7ce3cc02d83405e7db401e6055e947b80bf4abb0e3a4dce6575d97761f3bd6fcc253f3338caad5f797fc4f01bd40d833514d9cc0bcd0f072ad793
-DIST uvicorn-0.21.1.gh.tar.gz 717974 BLAKE2B ac4e1ec6a2533e364fe2ad7cd52558ad70b82e3c739756f33123d08737cc406ba879f50f7fa1cba875d0f0a284da5467e4ca15139558462401fb6a7938a17f61 SHA512 9f8dfe42df5d7f3923609e177def66d68fac24e3016fc1c6fead489320c2e5eaf7816a43e242f4426e670ce16f200db41679ac6ebd29a000ba76ca72b9ccec76
DIST uvicorn-0.22.0.gh.tar.gz 719615 BLAKE2B 8e0d6099e66822e77fb447c279de8f29c820e1f9e24e37629d36349ebd4b52ea8dc69f7fc02a21e9711925e3ad1ec4a95464ea315c7bc40a905810dc9a1ef077 SHA512 61af2df426a5bc060a32730ddf024ca8dd39ccea6800235bf48d7e0c694b9d363cbedd826f498063c6779061af84b6b56e8ab0a466e74291dbbaf5ae995e5587
DIST uvicorn-0.23.0.gh.tar.gz 722671 BLAKE2B f1fdc09e211c97d9e326b41b197d12ad019e660a1a2fcc0c70ee62c2016a20bbcafb9be759fc9b682185e70e10881c9a3511168eb0e75844973f7c3321d455bd SHA512 2449150abdf7914b47ff8c02732549cd71e63cc7c6440eedfd200340df4e70543232ed1ef47e2ebc6b29fc9a0d4615f542d7d1c603ce2673f121afab63d89b47
diff --git a/dev-python/uvicorn/files/uvicorn-0.21.1-optional-rust.patch b/dev-python/uvicorn/files/uvicorn-0.21.1-optional-rust.patch
deleted file mode 100644
index dddeda158252..000000000000
--- a/dev-python/uvicorn/files/uvicorn-0.21.1-optional-rust.patch
+++ /dev/null
@@ -1,80 +0,0 @@
---- a/tests/conftest.py
-+++ b/tests/conftest.py
-@@ -11,9 +11,13 @@ from time import sleep
- from uuid import uuid4
-
- import pytest
--import trustme
--from cryptography.hazmat.backends import default_backend
--from cryptography.hazmat.primitives import serialization
-+
-+try:
-+ import trustme
-+ from cryptography.hazmat.backends import default_backend
-+ from cryptography.hazmat.primitives import serialization
-+except ImportError:
-+ pass
-
- from uvicorn.config import LOGGING_CONFIG
-
-@@ -30,12 +34,12 @@ LOGGING_CONFIG["loggers"]["uvicorn"]["propagate"] = True
-
-
- @pytest.fixture
--def tls_certificate_authority() -> trustme.CA:
-+def tls_certificate_authority() -> "trustme.CA":
- return trustme.CA()
-
-
- @pytest.fixture
--def tls_certificate(tls_certificate_authority: trustme.CA) -> trustme.LeafCert:
-+def tls_certificate(tls_certificate_authority: "trustme.CA") -> "trustme.LeafCert":
- return tls_certificate_authority.issue_cert(
- "localhost",
- "127.0.0.1",
-@@ -44,13 +48,13 @@ def tls_certificate(tls_certificate_authority: trustme.CA) -> trustme.LeafCert:
-
-
- @pytest.fixture
--def tls_ca_certificate_pem_path(tls_certificate_authority: trustme.CA):
-+def tls_ca_certificate_pem_path(tls_certificate_authority: "trustme.CA"):
- with tls_certificate_authority.cert_pem.tempfile() as ca_cert_pem:
- yield ca_cert_pem
-
-
- @pytest.fixture
--def tls_ca_certificate_private_key_path(tls_certificate_authority: trustme.CA):
-+def tls_ca_certificate_private_key_path(tls_certificate_authority: "trustme.CA"):
- with tls_certificate_authority.private_key_pem.tempfile() as private_key:
- yield private_key
-
-@@ -72,25 +76,25 @@ def tls_certificate_private_key_encrypted_path(tls_certificate):
-
-
- @pytest.fixture
--def tls_certificate_private_key_path(tls_certificate: trustme.CA):
-+def tls_certificate_private_key_path(tls_certificate: "trustme.CA"):
- with tls_certificate.private_key_pem.tempfile() as private_key:
- yield private_key
-
-
- @pytest.fixture
--def tls_certificate_key_and_chain_path(tls_certificate: trustme.LeafCert):
-+def tls_certificate_key_and_chain_path(tls_certificate: "trustme.LeafCert"):
- with tls_certificate.private_key_and_cert_chain_pem.tempfile() as cert_pem:
- yield cert_pem
-
-
- @pytest.fixture
--def tls_certificate_server_cert_path(tls_certificate: trustme.LeafCert):
-+def tls_certificate_server_cert_path(tls_certificate: "trustme.LeafCert"):
- with tls_certificate.cert_chain_pems[0].tempfile() as cert_pem:
- yield cert_pem
-
-
- @pytest.fixture
--def tls_ca_ssl_context(tls_certificate_authority: trustme.CA) -> ssl.SSLContext:
-+def tls_ca_ssl_context(tls_certificate_authority: "trustme.CA") -> ssl.SSLContext:
- ssl_ctx = ssl.create_default_context(ssl.Purpose.SERVER_AUTH)
- tls_certificate_authority.configure_trust(ssl_ctx)
- return ssl_ctx
diff --git a/dev-python/uvicorn/uvicorn-0.20.0.ebuild b/dev-python/uvicorn/uvicorn-0.20.0.ebuild
deleted file mode 100644
index bc899d6b9df0..000000000000
--- a/dev-python/uvicorn/uvicorn-0.20.0.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 2021-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( pypy3 python3_{9..11} )
-
-inherit distutils-r1 optfeature
-
-DESCRIPTION="Lightning-fast ASGI server implementation"
-HOMEPAGE="
- https://www.uvicorn.org/
- https://github.com/encode/uvicorn/
- https://pypi.org/project/uvicorn/
-"
-SRC_URI="https://github.com/encode/${PN}/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- >=dev-python/asgiref-3.4.0[${PYTHON_USEDEP}]
- >=dev-python/click-7.0[${PYTHON_USEDEP}]
- >=dev-python/h11-0.8[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/httpx[${PYTHON_USEDEP}]
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/python-dotenv[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/trustme[${PYTHON_USEDEP}]
- >=dev-python/websockets-10.4[${PYTHON_USEDEP}]
- dev-python/wsproto[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # too long path for unix socket
- tests/test_config.py::test_bind_unix_socket_works_with_reload_or_workers
- # need unpackaged httptools
- "tests/middleware/test_logging.py::test_trace_logging_on_http_protocol[httptools]"
- tests/protocols/test_http.py::test_fragmentation
- )
- if [[ ${EPYTHON} == pypy3 ]]; then
- # TODO
- EPYTEST_DESELECT+=(
- tests/middleware/test_logging.py::test_running_log_using_fd
- )
- fi
-
- local EPYTEST_IGNORE=()
- # love from Rust world
- if ! has_version "dev-python/watchfiles[${PYTHON_USEDEP}]"; then
- EPYTEST_IGNORE+=(
- tests/supervisors/test_reload.py
- )
- fi
-
- epytest
-}
-
-pkg_postinst() {
- optfeature "auto reload on file changes" dev-python/watchfiles
-}
diff --git a/dev-python/uvicorn/uvicorn-0.21.1-r1.ebuild b/dev-python/uvicorn/uvicorn-0.21.1-r1.ebuild
deleted file mode 100644
index 792a7809216c..000000000000
--- a/dev-python/uvicorn/uvicorn-0.21.1-r1.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 2021-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( pypy3 python3_{9..11} )
-
-inherit distutils-r1 optfeature
-
-DESCRIPTION="Lightning-fast ASGI server implementation"
-HOMEPAGE="
- https://www.uvicorn.org/
- https://github.com/encode/uvicorn/
- https://pypi.org/project/uvicorn/
-"
-# as of 0.21.0, no tests in sdist
-SRC_URI="
- https://github.com/encode/uvicorn/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-IUSE="test-rust"
-
-RDEPEND="
- >=dev-python/asgiref-3.4.0[${PYTHON_USEDEP}]
- >=dev-python/click-7.0[${PYTHON_USEDEP}]
- >=dev-python/h11-0.8[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/a2wsgi[${PYTHON_USEDEP}]
- dev-python/httpx[${PYTHON_USEDEP}]
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/python-dotenv[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- >=dev-python/websockets-10.4[${PYTHON_USEDEP}]
- dev-python/wsproto[${PYTHON_USEDEP}]
- test-rust? (
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/trustme[${PYTHON_USEDEP}]
- dev-python/watchfiles[${PYTHON_USEDEP}]
- )
- )
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.21.1-optional-rust.patch
-)
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # too long path for unix socket
- tests/test_config.py::test_bind_unix_socket_works_with_reload_or_workers
- # need unpackaged httptools
- "tests/middleware/test_logging.py::test_trace_logging_on_http_protocol[httptools]"
- tests/protocols/test_http.py::test_fragmentation
- # TODO
- tests/protocols/test_websocket.py::test_connection_lost_before_handshake_complete
- )
- if [[ ${EPYTHON} == pypy3 ]]; then
- # TODO
- EPYTEST_DESELECT+=(
- tests/middleware/test_logging.py::test_running_log_using_fd
- )
- fi
-
- local EPYTEST_IGNORE=()
-
- if ! use test-rust ; then
- EPYTEST_DESELECT+=(
- # dev-python/cryptography
- tests/test_config.py::test_ssl_config
- tests/test_config.py::test_ssl_config_combined
- )
-
- EPYTEST_IGNORE+=(
- # dev-python/watchfiles
- tests/supervisors/test_reload.py
- # dev-python/cryptography
- tests/test_ssl.py
- )
- fi
-
- epytest
-}
-
-pkg_postinst() {
- optfeature "auto reload on file changes" dev-python/watchfiles
-}