summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-09-30 05:24:43 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-09-30 06:48:13 -0400
commit1c0bcea858a457034445af16010899e97f0d55fb (patch)
tree8ebde03353f4b526f1dcb7522ce3a3b2ce9fb694
parentx11-misc/xsnap: force gcc -E for imake's generation (diff)
downloadgentoo-1c0bcea858a457034445af16010899e97f0d55fb.tar.gz
gentoo-1c0bcea858a457034445af16010899e97f0d55fb.tar.bz2
gentoo-1c0bcea858a457034445af16010899e97f0d55fb.zip
x11-misc/xsnap: fix build with clang
Includes fix specific to >=clang16 too. Closes: https://bugs.gentoo.org/870811 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--x11-misc/xsnap/files/xsnap-1.5.15-clang.patch17
-rw-r--r--x11-misc/xsnap/xsnap-1.5.15-r2.ebuild7
2 files changed, 23 insertions, 1 deletions
diff --git a/x11-misc/xsnap/files/xsnap-1.5.15-clang.patch b/x11-misc/xsnap/files/xsnap-1.5.15-clang.patch
new file mode 100644
index 000000000000..9b51bcb33e5b
--- /dev/null
+++ b/x11-misc/xsnap/files/xsnap-1.5.15-clang.patch
@@ -0,0 +1,17 @@
+https://bugs.gentoo.org/870811
+--- a/xsnap.c
++++ b/xsnap.c
+@@ -150,2 +150,3 @@
+ Window win;
++int init_cursor;
+ {
+@@ -1706,3 +1707,3 @@
+ static Window win0 = None;
+- static w0 = 0, h0 = 0;
++ static int w0 = 0, h0 = 0;
+ int i, j, d, w, h;
+@@ -2254,3 +2255,3 @@
+ if (op_mode == 0)
+- exitXsnap (NULL, NULL, snap_pixmap, copy_gc);
++ exitXsnap ((Window)0, (Window)0, snap_pixmap, copy_gc);
+
diff --git a/x11-misc/xsnap/xsnap-1.5.15-r2.ebuild b/x11-misc/xsnap/xsnap-1.5.15-r2.ebuild
index bc17eb259842..e93eb8f85a7d 100644
--- a/x11-misc/xsnap/xsnap-1.5.15-r2.ebuild
+++ b/x11-misc/xsnap/xsnap-1.5.15-r2.ebuild
@@ -34,8 +34,13 @@ BDEPEND="
sys-devel/gcc
>=x11-misc/imake-1.0.8-r1
"
+
DOCS=( AUTHORS Changelog README )
-PATCHES=( "${FILESDIR}"/${P}-root_name.patch )
+
+PATCHES=(
+ "${FILESDIR}"/${P}-root_name.patch
+ "${FILESDIR}"/${P}-clang.patch
+)
src_prepare() {
default