summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2017-07-09 22:30:03 +0900
committerAkinori Hattori <hattya@gentoo.org>2017-07-09 22:30:03 +0900
commit1c106290b02505c2af7c95058c0a1be602dc5c90 (patch)
tree7dd668a2bf505685bb8eee5e7594d46fb16c122e
parentapp-editors/aee: fix build with -Werror=format-security (diff)
downloadgentoo-1c106290b02505c2af7c95058c0a1be602dc5c90.tar.gz
gentoo-1c106290b02505c2af7c95058c0a1be602dc5c90.tar.bz2
gentoo-1c106290b02505c2af7c95058c0a1be602dc5c90.zip
app-editors/aee: new upstream release
Package-Manager: Portage-2.3.6, Repoman-2.3.1
-rw-r--r--app-editors/aee/Manifest1
-rw-r--r--app-editors/aee/aee-2.2.21.ebuild63
-rw-r--r--app-editors/aee/files/aee-ae-location.patch89
3 files changed, 153 insertions, 0 deletions
diff --git a/app-editors/aee/Manifest b/app-editors/aee/Manifest
index ab70d57f9d43..66df500056b8 100644
--- a/app-editors/aee/Manifest
+++ b/app-editors/aee/Manifest
@@ -1 +1,2 @@
DIST aee-2.2.15b.tar.gz 184218 SHA256 7abbaffe35018f9de87c8685f9bee2ea3f261e88ce60674f1a5a9a3a0f54d752 SHA512 2810cd8f5148edb352fdaefbc823d417b9a83c8083644c8729be8595013ca8ba660bd72120db1e15915e454f5185d2d030c2f0c853b37eb83c213c1d581a640f WHIRLPOOL 3ae452544f8926fda55f3661c9890c39d6ab1dd295acba1a18edf91d010e731d7f356a679e8174f66ce7c8604c148ad1ce61d31c43a67162bdcda400b9de5961
+DIST aee-2.2.21.tar.gz 186304 SHA256 b8a9a20679736ec44e74faae1550b33411cc675f7c587d2316e578f97b0d3727 SHA512 c052ef97b18fa9900e9bf0c5894e05cbbf775d7de4ad4c14cb9e3e7758983c84e4768995a98398c05e30173464e6f7994e7f476522a314bc25dac5a84831155a WHIRLPOOL 7508981b4035fb80dc4fb4cb49af4a7ca552cdf6abe6427ec5bccd5d957f0e64db14083174e7671b521f772e36fc887ac0f7a2b078874888efb042a43ed0363b
diff --git a/app-editors/aee/aee-2.2.21.ebuild b/app-editors/aee/aee-2.2.21.ebuild
new file mode 100644
index 000000000000..763b9cf91901
--- /dev/null
+++ b/app-editors/aee/aee-2.2.21.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit toolchain-funcs
+
+DESCRIPTION="An easy to use text editor"
+#HOMEPAGE="http://mahon.cwx.net/ http://www.users.uswest.net/~hmahon/"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE="X"
+
+RDEPEND="X? ( x11-libs/libX11 )"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-ae-location.patch
+ "${FILESDIR}"/${PN}-Wformat-security.patch
+)
+DOCS=( Changes README.${PN} ${PN}.i18n.guide ${PN}.msg )
+
+src_prepare() {
+ sed -i \
+ -e "s/make -/\$(MAKE) -/g" \
+ -e "/^buildaee/s/$/ localaee/" \
+ -e "/^buildxae/s/$/ localxae/" \
+ Makefile
+
+ sed -i \
+ -e "s/\([\t ]\)cc /\1\\\\\$(CC) /" \
+ -e "/CFLAGS =/s/\" >/ \\\\\$(LDFLAGS)\" >/" \
+ -e "/other_cflag/s/ \${strip_option}//" \
+ create.mk.{aee,xae}
+
+ default
+}
+
+src_compile() {
+ local target="aee"
+ use X && target="both"
+
+ emake CC="$(tc-getCC)" ${target}
+}
+
+src_install() {
+ dobin ${PN}
+ dosym ${PN} /usr/bin/rae
+ doman ${PN}.1
+ einstalldocs
+
+ insinto /usr/share/${PN}
+ doins help.ae
+
+ if use X; then
+ dobin xae
+ dosym xae /usr/bin/rxae
+ fi
+}
diff --git a/app-editors/aee/files/aee-ae-location.patch b/app-editors/aee/files/aee-ae-location.patch
new file mode 100644
index 000000000000..eb598cc7be38
--- /dev/null
+++ b/app-editors/aee/files/aee-ae-location.patch
@@ -0,0 +1,89 @@
+--- a/aee.1
++++ b/aee.1
+@@ -680,7 +680,7 @@
+ .\"
+ .SS Initializing aee From A File
+ .PP
+-\fIaee\fR checks for a file named \fIinit.ae\fR in \fI/usr/local/lib\fR,
++\fIaee\fR checks for a file named \fIinit.ae\fR in \fI/usr/share/aee\fR,
+ .I .init.ae
+ in the user's home directory, then for \fI.init.ae\fR in the
+ current directory. (This file may be created manually or by using the
+@@ -962,7 +962,7 @@
+ .PP
+ On-line help is provided through the 'help' command or menu item. This
+ command uses a file with help information. By default the help file is
+-located in \fB/usr/local/lib/help.ae\fR, but this file may be located
++located in \fB/usr/share/aee/help.ae\fR, but this file may be located
+ in the user's home directory with the name \fB.help.ae\fR, or in the
+ current directory with the name \fBhelp.ae\fR.
+ .\"
+@@ -1019,7 +1019,7 @@
+ .\"
+ .SH FILES
+ .PP
+-.I /usr/local/lib/init.ae
++.I /usr/share/aee/init.ae
+ .br
+ .I $HOME/.aeeinfo
+ .br
+--- a/aee.c
++++ b/aee.c
+@@ -2628,7 +2628,7 @@
+
+ char *init_name[6] = {
+ "/usr/local/aee/init.ae",
+- "/usr/local/lib/init.ae",
++ "/usr/share/aee/init.ae",
+ NULL, /* to be ~/.init.ae */
+ ".init.ae",
+ NULL, /* to be ~/.aeerc */
+--- a/aee.msg
++++ b/aee.msg
+@@ -2,7 +2,7 @@
+ $
+ $set 1
+ $quote "
+-1 "/usr/local/lib/help.ae"
++1 "/usr/share/aee/help.ae"
+ 2 "main"
+ 3 "modes menu"
+ 4 "tabs to spaces "
+--- a/help.ae
++++ b/help.ae
+@@ -1058,11 +1058,11 @@
+
+ The file 'init.ae' may be used to set parameters and define keys to
+ perform certain functions within ae. This file may reside in three
+-locations: /usr/local/lib/init.ae, .init.ae in your home directory, and
++locations: /usr/share/aee/init.ae, .init.ae in your home directory, and
+ .init.ae in the current working directory.
+
+ First, aee checks for a system level initialization file, located in
+-/usr/local/lib. Next the user's home directory is checked for a file named
++/usr/share/aee. Next the user's home directory is checked for a file named
+ .init.ae, then the current directory. The settings from each file are read,
+ so that the directives from the most recently read file will take precedence
+ over previously read files. This allows, for example, the .init.ae file in
+--- a/help.c
++++ b/help.c
+@@ -12,7 +12,7 @@
+
+ char *help_file_list[4] = {
+ "/usr/local/aee/help.ae",
+- "/usr/local/lib/help.ae",
++ "/usr/share/aee/help.ae",
+ "~/.help.ae",
+ "help.ae"
+ };
+--- a/localize.c
++++ b/localize.c
+@@ -64,7 +64,7 @@
+ catalog = catopen("aee", 0);
+ #endif /* NO_CATGETS */
+
+- ae_help_file = catgetlocal( 1, "/usr/local/lib/help.ae");
++ ae_help_file = catgetlocal( 1, "/usr/share/aee/help.ae");
+ main_buffer_name = catgetlocal( 2, "main");
+
+