summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-03-05 10:48:53 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-03-05 11:19:37 +0100
commit1c15a18309c64c5713ef22cd1113192e69f6b23d (patch)
treeaeeaf14247629c6d8fe3df65a67587afcad5c0d9
parentdev-qt/qtwayland: Bump to QT5_KDEPATCHSET_REV=2 (diff)
downloadgentoo-1c15a18309c64c5713ef22cd1113192e69f6b23d.tar.gz
gentoo-1c15a18309c64c5713ef22cd1113192e69f6b23d.tar.bz2
gentoo-1c15a18309c64c5713ef22cd1113192e69f6b23d.zip
dev-qt/qtlocation: Fix build with GCC-13
Closes: https://bugs.gentoo.org/885431 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-qt/qtlocation/files/qtlocation-5.15.8-mapboxgl-gcc13.patch51
-rw-r--r--dev-qt/qtlocation/qtlocation-5.15.8.ebuild2
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-qt/qtlocation/files/qtlocation-5.15.8-mapboxgl-gcc13.patch b/dev-qt/qtlocation/files/qtlocation-5.15.8-mapboxgl-gcc13.patch
new file mode 100644
index 000000000000..ba4e94e859fb
--- /dev/null
+++ b/dev-qt/qtlocation/files/qtlocation-5.15.8-mapboxgl-gcc13.patch
@@ -0,0 +1,51 @@
+From d8054f1efa0b97b291a6f8c7fff9090b0fd4328e Mon Sep 17 00:00:00 2001
+From: Fabian Vogt <fvogt@suse.de>
+Date: Fri, 3 Mar 2023 11:39:58 +0100
+Subject: [PATCH] Add some missing cstdint inclusions (#872)
+
+GCC 13 removed some indirect inclusions of cstdint which this relied on.
+Include it explicitly to fix build errors.
+---
+ include/mbgl/util/geometry.hpp | 2 ++
+ include/mbgl/util/string.hpp | 1 +
+ src/mbgl/gl/stencil_mode.hpp | 2 ++
+ 3 files changed, 5 insertions(+)
+
+diff --git a/include/mbgl/util/geometry.hpp b/include/mbgl/util/geometry.hpp
+index a28c59a47d..283ec7dbbe 100644
+--- a/src/3rdparty/mapbox-gl-native/include/mbgl/util/geometry.hpp
++++ b/src/3rdparty/mapbox-gl-native/include/mbgl/util/geometry.hpp
+@@ -1,5 +1,7 @@
+ #pragma once
+
++#include <cstdint>
++
+ #include <mapbox/geometry/geometry.hpp>
+ #include <mapbox/geometry/point_arithmetic.hpp>
+ #include <mapbox/geometry/for_each_point.hpp>
+diff --git a/include/mbgl/util/string.hpp b/include/mbgl/util/string.hpp
+index 13498ccb92..2f6acb6410 100644
+--- a/src/3rdparty/mapbox-gl-native/include/mbgl/util/string.hpp
++++ b/src/3rdparty/mapbox-gl-native/include/mbgl/util/string.hpp
+@@ -3,6 +3,7 @@
+ #include <sstream>
+ #include <string>
+ #include <cassert>
++#include <cstdint>
+ #include <cstdlib>
+ #include <exception>
+
+diff --git a/src/mbgl/gl/stencil_mode.hpp b/src/mbgl/gl/stencil_mode.hpp
+index bc959c9a73..fd00370f88 100644
+--- a/src/3rdparty/mapbox-gl-native/src/mbgl/gl/stencil_mode.hpp
++++ b/src/3rdparty/mapbox-gl-native/src/mbgl/gl/stencil_mode.hpp
+@@ -1,5 +1,7 @@
+ #pragma once
+
++#include <cstdint>
++
+ #include <mbgl/util/variant.hpp>
+
+ namespace mbgl {
+--
+GitLab
diff --git a/dev-qt/qtlocation/qtlocation-5.15.8.ebuild b/dev-qt/qtlocation/qtlocation-5.15.8.ebuild
index 219efff528b3..a1ab77f7306e 100644
--- a/dev-qt/qtlocation/qtlocation-5.15.8.ebuild
+++ b/dev-qt/qtlocation/qtlocation-5.15.8.ebuild
@@ -39,6 +39,8 @@ QT5_TARGET_SUBDIRS=(
src/plugins/geoservices
)
+PATCHES=( "${FILESDIR}/${P}-mapboxgl-gcc13.patch" ) # bug 885431
+
src_configure() {
# src/plugins/geoservices requires files that are only generated when
# qmake is run in the root directory. Bug 633776.