summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Feldman <NP-Hardass@gentoo.org>2021-07-01 11:29:05 -0400
committerAdam Feldman <NP-Hardass@gentoo.org>2021-07-01 12:02:03 -0400
commit1c6479db3764a14009a04ae1cfd29d3e50e667b6 (patch)
tree70af4870fc54220af5235f583a300c6ecd88b819
parentgames-strategy/freeorion: Python 3.9 (diff)
downloadgentoo-1c6479db.tar.gz
gentoo-1c6479db.tar.bz2
gentoo-1c6479db.zip
games-strategy/freeorion: Add snapshot that fixes build errors
Backporting was too complicated, so I added a snapshot Bug: https://bugs.gentoo.org/739378 Bug: https://bugs.gentoo.org/795771 Bug: https://bugs.gentoo.org/796683 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Adam Feldman <NP-Hardass@gentoo.org>
-rw-r--r--games-strategy/freeorion/Manifest1
-rw-r--r--games-strategy/freeorion/freeorion-0.4.10.1_p20200629.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/games-strategy/freeorion/Manifest b/games-strategy/freeorion/Manifest
index 4f0f36b38b3e..649be95583bd 100644
--- a/games-strategy/freeorion/Manifest
+++ b/games-strategy/freeorion/Manifest
@@ -1 +1,2 @@
DIST freeorion-0.4.10.1.tar.gz 124693099 BLAKE2B d24c481e7be6f718897bb095209673f24cb7d43842f148cf1e8665254970d22449bf7a4ee4ba7a8cb3b5b515d6bed38a24e2862810959a63b29ba9d3c054e6c4 SHA512 b28a8bdc2428778480ff8404ad7d84153939f4f8b4a75f51775354e3e563f7f309d479e499ea1be8b57822d725cc57ece8dd14f2e40360ab6c07d70c917bc256
+DIST freeorion-0.4.10.1_p20200629.tar.gz 142041599 BLAKE2B a9c14409f31f5ad4d8db95fa33e8f1adb35f7b2a74ea7f173365c7d09979b9a3aa7981ee9deec0427c64844da14ecc323ee54e3331217e2978b49eb86a7a18fb SHA512 b2d4f52e968852569d549c03eca2545b7adac560e5716a21da612dc363b23d790c4481fbd5762f1f1f8da9a8e04894e247ce19363cd96cc2001728912e027d9a
diff --git a/games-strategy/freeorion/freeorion-0.4.10.1_p20200629.ebuild b/games-strategy/freeorion/freeorion-0.4.10.1_p20200629.ebuild
new file mode 100644
index 000000000000..62d5f6b9836a
--- /dev/null
+++ b/games-strategy/freeorion/freeorion-0.4.10.1_p20200629.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_7,3_8,3_9} )
+inherit cmake python-single-r1 xdg
+
+DESCRIPTION="A free turn-based space empire and galactic conquest game"
+HOMEPAGE="https://www.freeorion.org"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/freeorion/freeorion.git"
+else
+ KEYWORDS="~amd64"
+ if [[ ${PV} = *_p* ]]; then
+ COMMIT="24a08d6c597ce8afc90ccec485a937982b6c3683"
+ SRC_URI="https://github.com/${PN}/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${COMMIT}"
+ else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV/_/-}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${PV/_/-}"
+ fi
+fi
+
+LICENSE="GPL-2 LGPL-2.1 CC-BY-SA-3.0"
+SLOT="0"
+IUSE="dedicated"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-libs/boost-1.58:=[nls,python,threads(+),${PYTHON_MULTI_USEDEP}]
+ ')
+ !dedicated? (
+ media-libs/freealut
+ >=media-libs/freetype-2.5.5
+ media-libs/glew:=
+ >=media-libs/libogg-1.1.3
+ media-libs/libpng:0=
+ media-libs/libsdl2[X,opengl,video]
+ >=media-libs/libvorbis-1.1.2
+ media-libs/openal
+ sci-physics/bullet:=
+ virtual/opengl
+ )
+ sys-libs/zlib
+ ${PYTHON_DEPS}
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -e "s/-O3//" -i CMakeLists.txt || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_BUILD_TYPE=Release
+ -DCMAKE_SKIP_RPATH=ON
+ -DBUILD_HEADLESS="$(usex dedicated)"
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ newenvd "${FILESDIR}/${PN}.envd" 99${PN}
+}