summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-01-06 11:04:21 +0100
committerMichał Górny <mgorny@gentoo.org>2018-01-06 14:39:22 +0100
commit1c7db172aad891a7ebbde359dde522fca606380b (patch)
tree763bb882d44c106e697827a9144d1f62cbb8b3c1
parentdev-python/yappi: Clean old up (diff)
downloadgentoo-1c7db172aad891a7ebbde359dde522fca606380b.tar.gz
gentoo-1c7db172aad891a7ebbde359dde522fca606380b.tar.bz2
gentoo-1c7db172aad891a7ebbde359dde522fca606380b.zip
dev-python/zc-buildout: Clean old up
-rw-r--r--dev-python/zc-buildout/zc-buildout-2.5.3.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/dev-python/zc-buildout/zc-buildout-2.5.3.ebuild b/dev-python/zc-buildout/zc-buildout-2.5.3.ebuild
deleted file mode 100644
index a5324fbf46e1..000000000000
--- a/dev-python/zc-buildout/zc-buildout-2.5.3.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4} pypy pypy3 )
-
-inherit distutils-r1
-
-MY_PN="${PN/-/.}"
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="System for managing development buildouts"
-HOMEPAGE="https://pypi.python.org/pypi/zc.buildout"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="ZPL"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-RDEPEND=">=dev-python/setuptools-3.3[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? ( dev-python/zope-testing[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}"/${MY_P}
-
-DOCS=( README.rst doc/tutorial.txt )
-
-# Prevent incorrect installation of data file
-python_prepare_all() {
- sed -e '/^ include_package_data/d' -i setup.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- if python_is_python3; then
- ewarn "Tests are broken for ${EPYTHON}, skipping"
- continue
- fi
-
- distutils_install_for_testing
- "${PYTHON}" src/zc/buildout/tests.py || die "Tests fail with ${EPYTHON}"
-}