summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChema Alonso Josa <nimiux@gentoo.org>2018-04-01 22:13:09 +0200
committerChema Alonso Josa <nimiux@gentoo.org>2018-04-01 22:13:33 +0200
commit1c912aa885ac3094a1bd6e9c432e8a841e892f62 (patch)
treec19353b25e771ce86c0b99cf6491b6634f150b8e
parentapp-shells/ksh: bump (diff)
downloadgentoo-1c912aa8.tar.gz
gentoo-1c912aa8.tar.bz2
gentoo-1c912aa8.zip
app-admin/tripwire: Bumps version to 2.4.3.7
Package-Manager: Portage-2.3.24, Repoman-2.3.6
-rw-r--r--app-admin/tripwire/Manifest1
-rw-r--r--app-admin/tripwire/tripwire-2.4.3.7.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/app-admin/tripwire/Manifest b/app-admin/tripwire/Manifest
index 577b6a94bca2..2d57d8313fa5 100644
--- a/app-admin/tripwire/Manifest
+++ b/app-admin/tripwire/Manifest
@@ -1,2 +1,3 @@
DIST tripwire-2.4.3.5.tar.gz 965014 BLAKE2B 4eeec002c7c99fdb83bfb9f9ff19b552f8bfab007b6d2e13a8fabcd0f3c21e32a5a04310c4ab55e0aa8281350f0118939dec156cbb2b903407c4fb5fc3da762e SHA512 7aef0e7d38f4b6966a806a4e556636c7b2477f4ea5451e89f1749c1535a489c2f490ea13898edff5d7786acf572f77d04430115b8ddd4c6a03c38382feb45269
DIST tripwire-2.4.3.6.tar.gz 1001145 BLAKE2B aa1392d29d782266e26f605c621def8cffb67112db9151b3f098211f4243a671e5f7fc15ab5868c35794a8dbac2284f564815874aafb2b9323fd1191edb249db SHA512 4757827b908fd56a014de81609be9cfdf3631d34cbc02214ac800bf6d9c413d85d812bc3211f9dc32ceee97e1f13decd955037a0cbbaf2f8e3020699492bd9bf
+DIST tripwire-2.4.3.7.tar.gz 1002257 BLAKE2B fb0c847087e8b27d2a111b4a4122b3c4d5b187efe6f80995c6d06c7592a22fec2c537bbebba9c21a7761a8047535de4a96a6b94246da586faad4e9fc92137196 SHA512 541138f4a4c3a4227f31de6607503d305f0d893bdd5d24928d619d3a25bb8fe7061a45c041992ace957b976b834b5f4212b5c727eee1cbc76ddb2e2c52aeafbd
diff --git a/app-admin/tripwire/tripwire-2.4.3.7.ebuild b/app-admin/tripwire/tripwire-2.4.3.7.ebuild
new file mode 100644
index 000000000000..a24979351464
--- /dev/null
+++ b/app-admin/tripwire/tripwire-2.4.3.7.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools eutils flag-o-matic
+
+DESCRIPTION="Open Source File Integrity Checker and IDS"
+HOMEPAGE="http://www.tripwire.org/"
+SRC_URI="https://github.com/Tripwire/tripwire-open-source/archive/${PV}.tar.gz -> ${PF}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="libressl selinux ssl static +tools"
+
+DEPEND="sys-devel/automake
+ sys-devel/autoconf
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )"
+RDEPEND="virtual/cron
+ virtual/mta
+ selinux? ( sec-policy/selinux-tripwire )
+ ssl? ( dev-libs/openssl )"
+PDEPEND="tools? ( app-admin/mktwpol )"
+
+S="${WORKDIR}/tripwire-open-source-${PV}"
+
+src_prepare() {
+ eautoreconf
+ eapply_user
+}
+
+src_configure() {
+ # tripwire can be sensitive to compiler optimisation.
+ # see #32613, #45823, and others.
+ # -taviso@gentoo.org
+ strip-flags
+ append-cppflags -DCONFIG_DIR='"\"/etc/tripwire\""' -fno-strict-aliasing
+ econf $(use_enable ssl openssl) $(use_enable static)
+}
+
+src_install() {
+ dosbin "${S}"/bin/{siggen,tripwire,twadmin,twprint}
+ doman "${S}"/man/man{4/*.4,5/*.5,8/*.8}
+ dodir /etc/tripwire /var/lib/tripwire{,/report}
+ keepdir /var/lib/tripwire{,/report}
+
+ exeinto /etc/cron.daily
+ doexe "${FILESDIR}"/tripwire
+
+ dodoc ChangeLog policy/policyguide.txt TRADEMARK \
+ "${FILESDIR}"/tripwire.txt
+
+ insinto /etc/tripwire
+ doins "${FILESDIR}"/twcfg.txt policy/twpol-GENERIC.txt
+
+ fperms 750 /etc/cron.daily/tripwire
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog "Tripwire needs to be configured before its first run. You can"
+ elog "do this by manually editing the twpol-GENERIC.txt file shipped with"
+ elog "the package to suit your needs. A quickstart guide is provided"
+ elog "in tripwire.txt file to help you with this."
+ elog "To configure tripwire automatically, you can use the twsetup.sh"
+ elog "script provided by the app-admin/mktwpol package. This package is"
+ elog "installed for you by the \"tools\" USE flag (which is enabled by"
+ elog "default."
+else
+ elog "Maintenance of tripwire policy files as packages are added"
+ elog "and deleted from your system can be automated by the mktwpol.sh"
+ elog "script provided by the app-admin/mktwpol package. This package"
+ elog "is installed for you if you append \"tools\" to your USE flags"
+ fi
+}