summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-07 16:06:53 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-09 17:26:54 +0100
commit1c98fe8bc128858fa999409a779a1a72812bd524 (patch)
tree0b0797c508be7353eea018542e1c63201c329a63
parentmedia-gfx/openvdb: Switch to PYTHON_MULTI_USEDEP API (diff)
downloadgentoo-1c98fe8b.tar.gz
gentoo-1c98fe8b.tar.bz2
gentoo-1c98fe8b.zip
media-gfx/zbar: Switch to PYTHON_MULTI_USEDEP API
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--media-gfx/zbar/zbar-0.20.1-r2.ebuild (renamed from media-gfx/zbar/zbar-0.20.1-r1.ebuild)8
-rw-r--r--media-gfx/zbar/zbar-0.23-r1.ebuild (renamed from media-gfx/zbar/zbar-0.23.ebuild)4
2 files changed, 9 insertions, 3 deletions
diff --git a/media-gfx/zbar/zbar-0.20.1-r1.ebuild b/media-gfx/zbar/zbar-0.20.1-r2.ebuild
index 9a6382e3b61f..5aba21e790d8 100644
--- a/media-gfx/zbar/zbar-0.20.1-r1.ebuild
+++ b/media-gfx/zbar/zbar-0.20.1-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -33,7 +33,11 @@ COMMON_DEPEND="
jpeg? ( virtual/jpeg:0[${MULTILIB_USEDEP}] )
python? (
${PYTHON_DEPS}
- gtk? ( >=dev-python/pygtk-2[${PYTHON_USEDEP}] )
+ gtk? (
+ $(python_gen_cond_dep '
+ >=dev-python/pygtk-2[${PYTHON_MULTI_USEDEP}]
+ ')
+ )
)
qt5? (
dev-qt/qtcore:5
diff --git a/media-gfx/zbar/zbar-0.23.ebuild b/media-gfx/zbar/zbar-0.23-r1.ebuild
index 495dc423d47e..87656810dce6 100644
--- a/media-gfx/zbar/zbar-0.23.ebuild
+++ b/media-gfx/zbar/zbar-0.23-r1.ebuild
@@ -66,7 +66,9 @@ DEPEND="${COMMON_DEPEND}
)
test? (
${PYTHON_DEPS}
- dev-python/pillow[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/pillow[${PYTHON_MULTI_USEDEP}]
+ ')
)"
BDEPEND="