summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-02 16:36:50 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-03 06:37:12 +0100
commit1ca179e1c1b7984a7ea02958e06f75364febb11c (patch)
tree65af84642feee28cb621fe3860dbd5f2701feb31
parentdev-python/libvirt-python: version bump to 6.0.0 (diff)
downloadgentoo-1ca179e1.tar.gz
gentoo-1ca179e1.tar.bz2
gentoo-1ca179e1.zip
sys-kernel/vanilla-kernel: Bump to 4.19.101
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--sys-kernel/vanilla-kernel/Manifest1
-rw-r--r--sys-kernel/vanilla-kernel/vanilla-kernel-4.19.101.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/sys-kernel/vanilla-kernel/Manifest b/sys-kernel/vanilla-kernel/Manifest
index 7a422330b225..995eafd989ba 100644
--- a/sys-kernel/vanilla-kernel/Manifest
+++ b/sys-kernel/vanilla-kernel/Manifest
@@ -1,4 +1,5 @@
DIST linux-4.19.100.tar.xz 103408008 BLAKE2B 047d803af6a54e57aee2536222fb4aec729c2525a113cf87a0ad043f66b3a29cecaaa2ff71c3020796162199ab3926374a2cd52bc905cbe531c5aaf07b23d9ee SHA512 d59d6b85afc04f4c37d42cc0b76e505ba49b607489f69fc25eae6ca6f21a3ea66b33337382d899ed3326896fa283b604d687f8d13f50efd53947c368d5c082a8
+DIST linux-4.19.101.tar.xz 103403812 BLAKE2B 47ebacfd10bc34b6d7936205a60b4af0d3d0a4f685666dcd065ffaf022eaef13caf49919f1dbc72a97a20dbbc5059508ab99139a651fc968ddb67c0cc8d4a074 SHA512 571087e1d3a34239d5c93643cc5727924950842295ec351cd87776d166c5109bfbc0ffd61d054247b089d687a0c40fabadc9069ed3230edf6741b36faaaa4e0c
DIST linux-4.19.85-arch1.i686.config 222183 BLAKE2B 03eac77940db0ee6b4f2a006edc600ef34141bbca849f5be4de9b961301a8fc987da6d0e21344aa5d80c29bb7793d56cf5441abb6c8e4057d94e2601c174c1be SHA512 6bd45c9dfd96b1afb8c1ca1ca72722baee6c91894e454d7af937de02242d3bb9d3b6870f5976aa96245c753c6bc1ac637a6356125b0d4c596aadef643b8c3d8d
DIST linux-4.19.92-arch1.amd64.config 222487 BLAKE2B a658d80d85525287a1df9053ca2ddfe423ab423bcc3b9ea8bd9cda65cc7ffa4b1be782c48c867c13e46070af4016f446860f5cf71351f239da1eff6c45a5aa6a SHA512 a5658c8e8464516dffd6f624344e739784cb315d334b2c5105bd5d16022b6366ad4ec00d3692a7b78e2458514175522bc85e834bf19593feff6363b616860258
DIST linux-4.19.96.tar.xz 103395480 BLAKE2B 1bc24dd40d427e088e1569be4d5964ae92028ce6ce7e549734837040c5043b5ef4aae572b1430ea5c03f67b7f071e18c4f58a24a63dcb342f18aecf2401ab9a8 SHA512 1fb1ee24429f2183b7e6b85d34e4c88f9c2a82ed95de1b7ca2db3d8ee4815ebcd05cdb171f93e1b0e85f9ffbc3a6fa8c66adceb240d3bf9c38afcc32f21c8dcf
diff --git a/sys-kernel/vanilla-kernel/vanilla-kernel-4.19.101.ebuild b/sys-kernel/vanilla-kernel/vanilla-kernel-4.19.101.ebuild
new file mode 100644
index 000000000000..17bfa6ee759e
--- /dev/null
+++ b/sys-kernel/vanilla-kernel/vanilla-kernel-4.19.101.ebuild
@@ -0,0 +1,65 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kernel-build
+
+MY_P=linux-${PV}
+# https://git.archlinux.org/svntogit/packages.git/log/trunk/config?h=packages/linux-lts
+AMD64_CONFIG_VER=4.19.92-arch1
+AMD64_CONFIG_HASH=bf97de6a2e405659aaad4c251b7f0bb48d5ed3c9
+# https://git.archlinux32.org/packages/log/core/linux-lts/config
+I686_CONFIG_VER=4.19.85-arch1
+I686_CONFIG_HASH=1f0345e2983d2edd55b401cb5a87fdf365a4192c
+
+DESCRIPTION="Linux kernel built from vanilla upstream sources"
+HOMEPAGE="https://www.kernel.org/"
+SRC_URI+=" https://cdn.kernel.org/pub/linux/kernel/v$(ver_cut 1).x/${MY_P}.tar.xz
+ amd64? (
+ https://git.archlinux.org/svntogit/packages.git/plain/trunk/config?h=packages/linux-lts&id=${AMD64_CONFIG_HASH}
+ -> linux-${AMD64_CONFIG_VER}.amd64.config
+ )
+ x86? (
+ https://git.archlinux32.org/packages/plain/core/linux-lts/config?id=${I686_CONFIG_HASH}
+ -> linux-${I686_CONFIG_VER}.i686.config
+ )"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ !sys-kernel/vanilla-kernel-bin:${SLOT}"
+
+src_prepare() {
+ default
+
+ # prepare the default config
+ case ${ARCH} in
+ amd64)
+ cp "${DISTDIR}"/linux-${AMD64_CONFIG_VER}.amd64.config .config || die
+ ;;
+ x86)
+ cp "${DISTDIR}"/linux-${I686_CONFIG_VER}.i686.config .config || die
+ ;;
+ *)
+ die "Unsupported arch ${ARCH}"
+ ;;
+ esac
+
+ local config_tweaks=(
+ # shove arch under the carpet!
+ -e 's:^CONFIG_DEFAULT_HOSTNAME=:&"gentoo":'
+ # we do support x32
+ -e '/CONFIG_X86_X32/s:.*:CONFIG_X86_X32=y:'
+ # disable signatures
+ -e '/CONFIG_MODULE_SIG/d'
+ -e '/CONFIG_SECURITY_LOCKDOWN/d'
+ # disable compression to allow stripping
+ -e '/CONFIG_MODULE_COMPRESS/d'
+ # disable gcc plugins to unbreak distcc
+ -e '/CONFIG_GCC_PLUGIN_STRUCTLEAK/d'
+ )
+ sed -i "${config_tweaks[@]}" .config || die
+}