summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOz Tiram <oz.tiram@gmail.com>2023-08-12 08:51:42 +0200
committerSam James <sam@gentoo.org>2023-08-17 07:22:39 +0100
commit1cabeb40d1e1b1a75f36b2406c365970d51b688d (patch)
treed4be1e10208bafc2c402cec47bf1e3eb5ebf8efb
parentapp-arch/engrampa: add 1.26.1 (diff)
downloadgentoo-1cabeb40d1e1b1a75f36b2406c365970d51b688d.tar.gz
gentoo-1cabeb40d1e1b1a75f36b2406c365970d51b688d.tar.bz2
gentoo-1cabeb40d1e1b1a75f36b2406c365970d51b688d.zip
mate-base/mate-control-center: add 1.26.1
Signed-off-by: Oz Tiram <oz.tiram@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--mate-base/mate-control-center/Manifest1
-rw-r--r--mate-base/mate-control-center/mate-control-center-1.26.1.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/mate-base/mate-control-center/Manifest b/mate-base/mate-control-center/Manifest
index 2a1b10dc0aef..28ec0ff09a3a 100644
--- a/mate-base/mate-control-center/Manifest
+++ b/mate-base/mate-control-center/Manifest
@@ -1 +1,2 @@
DIST mate-control-center-1.26.0.tar.xz 3449952 BLAKE2B 46a3b25952417dc0c7b893caca956e5a6097a2e88f17ebc9f98822efc52ff36fdb4517a8bac54c96550787f1fb15b24b55898ad272d309db17c1ba1530cb488a SHA512 958c41200b6fecc5cfbebbe7112038468bb5e8a6a877e2b16a40af3b41c100e32052e176fc87029eba3d0ccc05767f9400b609ab413924a54222cb18748d746f
+DIST mate-control-center-1.26.1.tar.xz 3495636 BLAKE2B 3e56ef75ea8af47613de09d565850b8ce58cfb3cd835194b4c4dc89f8d71042f074303c45b4830974bbd5272332d95b66eb7cad426c7996153b5afaa5c0098b3 SHA512 f359173596035a5ac3a73b17ab590bd9da5e202af9f203f0d6d4621877c6946e496d9a850823f8fa49bae6eac3035df7c7888c71d881c97acaa21b5e262da1a6
diff --git a/mate-base/mate-control-center/mate-control-center-1.26.1.ebuild b/mate-base/mate-control-center/mate-control-center-1.26.1.ebuild
new file mode 100644
index 000000000000..ba5657f0b4aa
--- /dev/null
+++ b/mate-base/mate-control-center/mate-control-center-1.26.1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+
+DESCRIPTION="The MATE Desktop configuration tool"
+LICENSE="FDL-1.1+ GPL-2+ LGPL-2+ LGPL-2.1+ HPND"
+SLOT="0"
+
+IUSE="accountsservice appindicator debug nls"
+
+COMMON_DEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ >=dev-libs/glib-2.50:2
+ dev-libs/libxml2:2
+ >=gnome-base/dconf-0.13.4
+ >=gnome-base/librsvg-2.0:2
+ >=mate-base/libmatekbd-1.17.0
+ >=mate-base/mate-desktop-1.25.0
+ >=mate-base/caja-1.20.0
+ >=mate-base/mate-menus-1.21.0
+ >=media-libs/fontconfig-1:1.0
+ media-libs/freetype:2
+ media-libs/libcanberra:0[gtk3]
+ sys-auth/polkit[introspection]
+ x11-apps/xmodmap
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.22:3
+ x11-libs/libX11
+ x11-libs/libXScrnSaver
+ x11-libs/libXcursor
+ x11-libs/libXext
+ >=x11-libs/libXi-1.5
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ >=x11-libs/libxklavier-4
+ x11-libs/pango
+ >=x11-wm/marco-1.17.0:=
+ accountsservice? ( sys-apps/accountsservice )
+ appindicator? ( dev-libs/libayatana-appindicator )
+"
+
+RDEPEND="${COMMON_DEPEND}"
+
+BDEPEND="${COMMON_DEPEND}
+ app-text/yelp-tools
+ dev-libs/libxml2
+ dev-util/desktop-file-utils
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ x11-base/xorg-proto
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ # https://github.com/mate-desktop/mate-control-center/issues/701
+ "${FILESDIR}"/${PN}-1.26.0-ayatana-detection.patch
+)
+
+src_configure() {
+ mate_src_configure \
+ --disable-update-mimedb \
+ $(use_enable appindicator) \
+ $(use_enable nls) \
+ $(use_enable debug)
+}