summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-11-03 18:44:11 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-11-03 18:45:06 +0100
commit1cc5d7c674a6fece0e3d20f5824039a506ccb9e8 (patch)
tree5110cf2af913c0358a7063a20e4c17e216564b82
parentnet-im/mcabber: amd64 stable wrt bug #669830 (diff)
downloadgentoo-1cc5d7c6.tar.gz
gentoo-1cc5d7c6.tar.bz2
gentoo-1cc5d7c6.zip
sys-apps/less: Bump to version 541
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
-rw-r--r--sys-apps/less/Manifest1
-rw-r--r--sys-apps/less/less-541.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/sys-apps/less/Manifest b/sys-apps/less/Manifest
index e632a941f7e2..764a9059cf16 100644
--- a/sys-apps/less/Manifest
+++ b/sys-apps/less/Manifest
@@ -2,3 +2,4 @@ DIST less-530.tar.gz 339723 BLAKE2B 9321548b06330c0b1b5b5a36147f5b9348619ff15d90
DIST less-531.tar.gz 340466 BLAKE2B 6ac75b623fce478114d18cff429659499fedf4ef1a7bb067465ace91c28a7968efb224a4994a1e376a8cf40b110492f10ecda634628029107b38187044a0cd1e SHA512 180b665f194d7cc40d4bbb37bd64b10be463c0705e81795bef84b20dbba1c61825bb3e3da8bcd79f9176bb3af7b1f4e4c3dfe0829a5a2195a11f5b42294daca1
DIST less-538.tar.gz 341589 BLAKE2B ce2c451da4f25e1fd93c738817f92fb12453b3091b34f8162ff11645a0bc223ca158ed3facb5eac611799117c8d20c14597abd5a0924a4f39d1ac18cd4afb638 SHA512 55012727f855de1c5e451dead0533e0d8505c0c829ff4f624bfadee998278ca372f201e1f58c23f09e0c4a2d424a17fcce6d3ebb18dd1c3bb757f5ccd8aaa330
DIST less-540.tar.gz 342724 BLAKE2B d5184ae3e44ea111d9a3fc87166779cf19ac63b26b25ff149610fd5728e20457c9469fff885759a1230b831b0c306569179c2a1e25c6c15c85604855726e3153 SHA512 1cee065b9a16db74ef0ccdffa149071bf66dd40d82c3d5581b0a7706f75ed4afaf4beca9e5d928d20605e390d5b0a6c1b346a67d8abb90d93bf140cbe03d435d
+DIST less-541.tar.gz 342956 BLAKE2B aaefc6b1486c220405a2c9288d3aa78099356468ee695991f4ea05a1431444dc1fd46ca92a65625dc33662f6ce669319e3d12d297e068efb24d252229d775ff9 SHA512 384f79b4acbdbf1b7d4de128a9ede405302633d78e5c057a8a4e568022072f0a73172f7bb7f2f9e45508cc8a0f4f0fa353945445a5bc59ee978dede1299e7b48
diff --git a/sys-apps/less/less-541.ebuild b/sys-apps/less/less-541.ebuild
new file mode 100644
index 000000000000..3bc3bf389320
--- /dev/null
+++ b/sys-apps/less/less-541.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Excellent text file viewer"
+HOMEPAGE="http://www.greenwoodsoftware.com/less/"
+SRC_URI="http://www.greenwoodsoftware.com/less/${P}.tar.gz"
+
+LICENSE="|| ( GPL-3 BSD-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="pcre unicode"
+
+DEPEND=">=app-misc/editor-wrapper-3
+ >=sys-libs/ncurses-5.2:0=
+ pcre? ( dev-libs/libpcre2 )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ export ac_cv_lib_ncursesw_initscr=$(usex unicode)
+ export ac_cv_lib_ncurses_initscr=$(usex !unicode)
+ local myeconfargs=(
+ --with-regex=$(usex pcre pcre2 posix)
+ --with-editor="${EPREFIX}"/usr/libexec/editor
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ newbin "${FILESDIR}"/lesspipe.sh lesspipe
+ newenvd "${FILESDIR}"/less.envd 70less
+}
+
+pkg_preinst() {
+ if has_version "<${CATEGORY}/${PN}-483-r1" ; then
+ elog "The lesspipe.sh symlink has been dropped. If you are still setting"
+ elog "LESSOPEN to that, you will need to update it to '|lesspipe %s'."
+ elog "Colorization support has been dropped. If you want that, check out"
+ elog "the new app-text/lesspipe package."
+ fi
+}