summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2015-11-18 18:13:42 +0100
committerDaniel Pielmeier <billie@gentoo.org>2015-11-18 18:13:42 +0100
commit1cd39e035be1286af924eea3da17a5d36dd9aad8 (patch)
treed41581550874d99cc0d78aa896bb7bf6436742c6
parentdev-go/godep: version bump (diff)
downloadgentoo-1cd39e035be1286af924eea3da17a5d36dd9aad8.tar.gz
gentoo-1cd39e035be1286af924eea3da17a5d36dd9aad8.tar.bz2
gentoo-1cd39e035be1286af924eea3da17a5d36dd9aad8.zip
app-admin/conky: Add patch to build with >=cmake-3.4.0.
Also fixes epatch_user which failed in any case, because still trying to run eautoreconf. Thanks to Casey Webster for the report and the patches. Package-Manager: portage-2.2.20.1
-rw-r--r--app-admin/conky/conky-1.10.0.ebuild6
-rw-r--r--app-admin/conky/files/conky-1.10.0-includefiles.patch29
2 files changed, 32 insertions, 3 deletions
diff --git a/app-admin/conky/conky-1.10.0.ebuild b/app-admin/conky/conky-1.10.0.ebuild
index cc1ba4a21ee1..b20f331e479c 100644
--- a/app-admin/conky/conky-1.10.0.ebuild
+++ b/app-admin/conky/conky-1.10.0.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-inherit autotools eutils libtool cmake-utils linux-info
+inherit eutils cmake-utils linux-info
DESCRIPTION="An advanced, highly configurable system monitor for X"
HOMEPAGE="https://github.com/brndnmtthws/conky"
@@ -77,10 +77,10 @@ pkg_setup() {
src_prepare() {
epatch "${FILESDIR}/${P}-cmake.patch"
+ epatch "${FILESDIR}/${P}-includefiles.patch"
# Allow user patches #478482
- # Only run autotools if user patched something
- epatch_user && eautoreconf || elibtoolize
+ epatch_user
}
src_configure() {
diff --git a/app-admin/conky/files/conky-1.10.0-includefiles.patch b/app-admin/conky/files/conky-1.10.0-includefiles.patch
new file mode 100644
index 000000000000..948072039280
--- /dev/null
+++ b/app-admin/conky/files/conky-1.10.0-includefiles.patch
@@ -0,0 +1,29 @@
+--- a/cmake/ConkyPlatformChecks.cmake
++++ b/cmake/ConkyPlatformChecks.cmake
+@@ -22,7 +22,7 @@
+
+ include(FindPkgConfig)
+ include(CheckFunctionExists)
+-include(CheckIncludeFile)
++include(CheckIncludeFiles)
+ include(CheckSymbolExists)
+
+ # Check for some headers
+@@ -119,7 +119,7 @@ if(BUILD_HTTP)
+ endif(BUILD_HTTP)
+
+ if(BUILD_NCURSES)
+- check_include_file(ncurses.h NCURSES_H)
++ check_include_files(ncurses.h NCURSES_H)
+ find_library(NCURSES_LIB NAMES ncurses)
+ if(NOT NCURSES_H OR NOT NCURSES_LIB)
+ message(FATAL_ERROR "Unable to find ncurses library")
+@@ -167,7 +167,7 @@ endif(BUILD_PORT_MONITORS)
+
+ # Check for iconv
+ if(BUILD_ICONV)
+- check_include_file(iconv.h HAVE_ICONV_H)
++ check_include_files(iconv.h HAVE_ICONV_H)
+ find_library(ICONV_LIBRARY NAMES iconv)
+ if(NOT ICONV_LIBRARY)
+ # maybe iconv() is provided by libc