summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2022-03-27 10:10:08 +0100
committerMatthew Smith <matthew@gentoo.org>2022-03-27 10:24:35 +0100
commit1cd4beaa9954809bf08a135836e2a7b8f4953f9e (patch)
treea3badcd9b52bba5099b6aa2baf975632cafe8262
parentdev-lang/erlang: drop 23.3.4.11, 24.2, 24.2.1 (diff)
downloadgentoo-1cd4beaa.tar.gz
gentoo-1cd4beaa.tar.bz2
gentoo-1cd4beaa.zip
app-emacs/helm: add 3.8.5
Signed-off-by: Matthew Smith <matthew@gentoo.org>
-rw-r--r--app-emacs/helm/Manifest1
-rw-r--r--app-emacs/helm/helm-3.8.5.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/app-emacs/helm/Manifest b/app-emacs/helm/Manifest
index 4110275ba2d2..66ded6f601a6 100644
--- a/app-emacs/helm/Manifest
+++ b/app-emacs/helm/Manifest
@@ -1,2 +1,3 @@
DIST helm-3.8.0.tar.gz 3943168 BLAKE2B cee9ed8eafdf01cb2109dcf5289522f4a0d9db9a8626097a1ffc3bdeaee792b072b7b27e635ef360815a354c9796b55fc4b3921784e2fd0d655387507df208b6 SHA512 0aec3d4270205c61cabc991dd39d5bac3b10e827f362819e9fb85880985ce2c7e7c7b8f73d2f0cde5b5c168d4b9857e0379f1e4ca9395dbd8f083c1a707ad3f2
DIST helm-3.8.4.tar.gz 2346120 BLAKE2B 2f554a6a3fc3a42ba2761c267d085ad1e6679f4913bc19cdbbff11130922d93d2fbe75bcae8230748c39148b6e42d45d4c2c711f731ebd4a1984c5927d93d290 SHA512 011cc4eb79a0a6916404428b9f645e4401b8a0b8b473bec88ac4211d4157b78cc673922c1b74dc93d60cf036135a67bd9c174198b63edd63a6d26a40ba9c1b9d
+DIST helm-3.8.5.tar.gz 2349290 BLAKE2B 84f0c15c2a9f492246defdf9496e8dcc5265b0c60b50ccaaa3b9f6731285a667da919da7fec80d77a4fd11bc83d9f4ae4c0910e31423b58afbdf00d51b070295 SHA512 af727553c29c9fa0ba6eb6a73b25d62855ea4413eebc57baf3ed94be6a0240e4c558193c898430dc21132ba5e32ead584514910bf98b3b8d82adf7828f953652
diff --git a/app-emacs/helm/helm-3.8.5.ebuild b/app-emacs/helm/helm-3.8.5.ebuild
new file mode 100644
index 000000000000..76b566bbf23a
--- /dev/null
+++ b/app-emacs/helm/helm-3.8.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Emacs incremental completion and selection narrowing framework"
+HOMEPAGE="https://emacs-helm.github.io/helm/"
+SRC_URI="https://github.com/emacs-helm/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="app-emacs/async
+ app-emacs/popup"
+BDEPEND="${RDEPEND}"
+
+PATCHES="${FILESDIR}/${PN}-3.8.0-no-autoload-check.patch"
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-compile *.el
+ elisp-make-autoload-file
+}
+
+src_install() {
+ elisp_src_install
+ dobin emacs-helm.sh
+}