summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-12 12:55:56 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-12 13:18:43 +0200
commit1ce1ee17c592c66ef6327bedee9efcc77e30942a (patch)
tree1501b5fe3eefed892aa0010dd2e7399eaea3752c
parentdev-python/flask-sqlalchemy: Bump to 3.0.1 (diff)
downloadgentoo-1ce1ee17c592c66ef6327bedee9efcc77e30942a.tar.gz
gentoo-1ce1ee17c592c66ef6327bedee9efcc77e30942a.tar.bz2
gentoo-1ce1ee17c592c66ef6327bedee9efcc77e30942a.zip
dev-python/jupyter_client: Bump to 7.4.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/jupyter_client/Manifest1
-rw-r--r--dev-python/jupyter_client/jupyter_client-7.4.2.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/jupyter_client/Manifest b/dev-python/jupyter_client/Manifest
index 55919b9be499..76c19e50e4ef 100644
--- a/dev-python/jupyter_client/Manifest
+++ b/dev-python/jupyter_client/Manifest
@@ -1 +1,2 @@
DIST jupyter_client-7.3.5.tar.gz 326758 BLAKE2B c2ac76eb6511b29c38d7e7441e1191bae1f931da27f2eb95d6cb842a0e36f36a6f7a1421253b62abf52243f9fdad36b34828e6d5cd13a0411fa4ce09b447c3bc SHA512 5a3471fe03f44671fc2a06f8c78c11197084c8c951a1f8b55b89d651a6aea2ae1bdbb451ed463e52519954e7dba99b4e2298a6511eef2a3618f095dc864758d9
+DIST jupyter_client-7.4.2.tar.gz 327079 BLAKE2B 71e1f2d7a84a308b37105887ab7851e1f8a8e1f3019d937ec2c48493396dd757f3b7bcd75be180187f2a2855f20f5c0db924b058d316a34d503a2964c63b65c9 SHA512 4e22cb0dccdc96d16c560dba2f9b19616015143d5bd709b9dafed9fa2419ab3d8e6f9091f8a94ab78a0a1d16db2db86def23300b6a39485c0c978f145da4eb47
diff --git a/dev-python/jupyter_client/jupyter_client-7.4.2.ebuild b/dev-python/jupyter_client/jupyter_client-7.4.2.ebuild
new file mode 100644
index 000000000000..76b6f1c22129
--- /dev/null
+++ b/dev-python/jupyter_client/jupyter_client-7.4.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter protocol implementation and client libraries"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/jupyter_client/
+ https://pypi.org/project/jupyter-client/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/entrypoints[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_core-4.9.2[${PYTHON_USEDEP}]
+ >=dev-python/nest_asyncio-1.5.4[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.2[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-23.0[${PYTHON_USEDEP}]
+ >=dev-python/tornado-6.0[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/ipykernel-6.5[${PYTHON_USEDEP}]
+ dev-python/ipython[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.18[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-7.0.6-test-timeout.patch
+)
+
+distutils_enable_tests pytest