summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-01 04:56:39 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-01 05:01:24 +0200
commit1ce6e1d73c772d34729cba5ff7d1a3fceb7526ec (patch)
treee0b6a7ddfc61f4d84a7f2aad0ff754d9bc3a9539
parentdev-python/pdm: Bump to 2.8.2 (diff)
downloadgentoo-1ce6e1d73c772d34729cba5ff7d1a3fceb7526ec.tar.gz
gentoo-1ce6e1d73c772d34729cba5ff7d1a3fceb7526ec.tar.bz2
gentoo-1ce6e1d73c772d34729cba5ff7d1a3fceb7526ec.zip
dev-python/uvicorn: Bump to 0.23.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/uvicorn/Manifest1
-rw-r--r--dev-python/uvicorn/uvicorn-0.23.2.ebuild85
2 files changed, 86 insertions, 0 deletions
diff --git a/dev-python/uvicorn/Manifest b/dev-python/uvicorn/Manifest
index 3171d6eec91b..48caff7e9bcf 100644
--- a/dev-python/uvicorn/Manifest
+++ b/dev-python/uvicorn/Manifest
@@ -1,2 +1,3 @@
DIST uvicorn-0.22.0.gh.tar.gz 719615 BLAKE2B 8e0d6099e66822e77fb447c279de8f29c820e1f9e24e37629d36349ebd4b52ea8dc69f7fc02a21e9711925e3ad1ec4a95464ea315c7bc40a905810dc9a1ef077 SHA512 61af2df426a5bc060a32730ddf024ca8dd39ccea6800235bf48d7e0c694b9d363cbedd826f498063c6779061af84b6b56e8ab0a466e74291dbbaf5ae995e5587
DIST uvicorn-0.23.0.gh.tar.gz 722671 BLAKE2B f1fdc09e211c97d9e326b41b197d12ad019e660a1a2fcc0c70ee62c2016a20bbcafb9be759fc9b682185e70e10881c9a3511168eb0e75844973f7c3321d455bd SHA512 2449150abdf7914b47ff8c02732549cd71e63cc7c6440eedfd200340df4e70543232ed1ef47e2ebc6b29fc9a0d4615f542d7d1c603ce2673f121afab63d89b47
+DIST uvicorn-0.23.2.gh.tar.gz 723155 BLAKE2B 03edb0b6c7be001be868636a77b818491d71e28277e22f252d650c2d9452e5018470fa3cf60300a8f4358d548f794e95a1bf877ac02ed30574a14dc56cea9841 SHA512 a575482ed261dff3a74a5e04387b36dda55d5975a635ca5c124770b7bbfcf764ea420b0b78b9396e4eaa8b839031933aefc7867befb46d18f39f3df5115eb77a
diff --git a/dev-python/uvicorn/uvicorn-0.23.2.ebuild b/dev-python/uvicorn/uvicorn-0.23.2.ebuild
new file mode 100644
index 000000000000..3c27df7c757d
--- /dev/null
+++ b/dev-python/uvicorn/uvicorn-0.23.2.ebuild
@@ -0,0 +1,85 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Lightning-fast ASGI server implementation"
+HOMEPAGE="
+ https://www.uvicorn.org/
+ https://github.com/encode/uvicorn/
+ https://pypi.org/project/uvicorn/
+"
+# as of 0.21.0, no tests in sdist
+SRC_URI="
+ https://github.com/encode/uvicorn/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="test-rust"
+
+RDEPEND="
+ >=dev-python/asgiref-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/click-7.0[${PYTHON_USEDEP}]
+ >=dev-python/h11-0.8[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/a2wsgi[${PYTHON_USEDEP}]
+ dev-python/httpx[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/python-dotenv[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/websockets-10.4[${PYTHON_USEDEP}]
+ dev-python/wsproto[${PYTHON_USEDEP}]
+ test-rust? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ dev-python/watchfiles[${PYTHON_USEDEP}]
+ )
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # too long path for unix socket
+ tests/test_config.py::test_bind_unix_socket_works_with_reload_or_workers
+ # need unpackaged httptools
+ "tests/middleware/test_logging.py::test_trace_logging_on_http_protocol[httptools]"
+ tests/protocols/test_http.py::test_fragmentation
+ # TODO
+ tests/protocols/test_websocket.py::test_connection_lost_before_handshake_complete
+ "tests/protocols/test_websocket.py::test_asgi_return_value[H11Protocol-WebSocketProtocol]"
+ )
+ case ${EPYTHON} in
+ pypy3)
+ # TODO
+ EPYTEST_DESELECT+=(
+ tests/middleware/test_logging.py::test_running_log_using_fd
+ )
+ ;;
+ python3.12)
+ EPYTEST_DESELECT+=(
+ tests/supervisors/test_signal.py::test_sigint_abort_req
+ # hang
+ tests/protocols/test_websocket.py::test_send_close_on_server_shutdown
+ )
+ ;;
+ esac
+
+ epytest
+}
+
+pkg_postinst() {
+ optfeature "auto reload on file changes" dev-python/watchfiles
+}