summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-27 14:21:54 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-27 14:26:26 +0200
commit1ce7a4242c9d4e181ac946364e75af5964f0e981 (patch)
treefa45d8bb9d2e67b0ca8b2e5dbbe376a36fe0151c
parentmail-mta/postfix: remove old (diff)
downloadgentoo-1ce7a4242c9d4e181ac946364e75af5964f0e981.tar.gz
gentoo-1ce7a4242c9d4e181ac946364e75af5964f0e981.tar.bz2
gentoo-1ce7a4242c9d4e181ac946364e75af5964f0e981.zip
dev-python/pyhamcrest: Bump to 1.10.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pyhamcrest/Manifest1
-rw-r--r--dev-python/pyhamcrest/pyhamcrest-1.10.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pyhamcrest/Manifest b/dev-python/pyhamcrest/Manifest
index d968610eb0d6..33812a1949e5 100644
--- a/dev-python/pyhamcrest/Manifest
+++ b/dev-python/pyhamcrest/Manifest
@@ -1 +1,2 @@
+DIST PyHamcrest-1.10.1.gh.tar.gz 59019 BLAKE2B 1a090533ea8fe2dff9ad232b2e6dbf82841c38f3699e57750e2309b06a46e70ae5a9c7d087baf06de53e17323a5e36edee1a01d7a4442374d15b76a7723c2031 SHA512 f7e79f7d26c4c6add042052e451898bbf5adf21b05a234cc62bce890d68f5997693b042a9daf136f7026040a8ab7bf28b829288417b947973dcb959bf613a37b
DIST PyHamcrest-1.9.0.gh.tar.gz 57650 BLAKE2B c497688f03ec3b072d8ab076fc096a442d5cbbd94493eae57779879ccb6f281477aeeb7f7a67e539442010e60194f9f04a6deddd1d2267e9743742b45433f124 SHA512 3a878637ed5138365416c170871a63640f089047b723c7ec8db893dd716c0b1cdad16a98584700405693b954af7d4868a8543d1a3fc58ded22b493c8c61661b4
diff --git a/dev-python/pyhamcrest/pyhamcrest-1.10.1.ebuild b/dev-python/pyhamcrest/pyhamcrest-1.10.1.ebuild
new file mode 100644
index 000000000000..85ed0b0e2a84
--- /dev/null
+++ b/dev-python/pyhamcrest/pyhamcrest-1.10.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6..9} )
+
+inherit distutils-r1
+
+MY_PN="PyHamcrest"
+
+DESCRIPTION="Hamcrest framework for matcher objects"
+HOMEPAGE="https://github.com/hamcrest/PyHamcrest"
+SRC_URI="https://github.com/hamcrest/PyHamcrest/archive/V${PV}.tar.gz -> ${MY_PN}-${PV}.gh.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=dev-python/six-1.4[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_sphinx doc \
+ dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}