summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Head <chead@chead.ca>2020-02-04 07:48:48 -0800
committerAndreas Sturmlechner <asturm@gentoo.org>2020-02-04 17:12:55 +0100
commit1cec71aa79e11b4540c9bf8d0776a133e8d9b855 (patch)
treec35d333c50fe280500e5bbb65a275d0af603f559
parentdev-python/colorlog: Remove py2 (diff)
downloadgentoo-1cec71aa79e11b4540c9bf8d0776a133e8d9b855.tar.gz
gentoo-1cec71aa79e11b4540c9bf8d0776a133e8d9b855.tar.bz2
gentoo-1cec71aa79e11b4540c9bf8d0776a133e8d9b855.zip
app-office/task-coach: clean old version
Signed-off-by: Christopher Head <chead@chead.ca> Bug: https://bugs.gentoo.org/706480 Closes: https://github.com/gentoo/gentoo/pull/14554 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--app-office/taskcoach/Manifest1
-rw-r--r--app-office/taskcoach/files/taskcoach-1.4.2-fix-desktop-file.patch23
-rw-r--r--app-office/taskcoach/taskcoach-1.4.3-r1.ebuild47
3 files changed, 0 insertions, 71 deletions
diff --git a/app-office/taskcoach/Manifest b/app-office/taskcoach/Manifest
index c31fce38278b..df8ef9b5d8d8 100644
--- a/app-office/taskcoach/Manifest
+++ b/app-office/taskcoach/Manifest
@@ -1,2 +1 @@
-DIST TaskCoach-1.4.3.tar.gz 2927984 BLAKE2B 998a53fa53624bce8497423e68924962e2cec705b87cfab192a6c5869a915f0de9d5c4394a190d07a50220258e7165b6aaee18449b9b9643a37dd9d9838a6679 SHA512 ae449ae66d29ec884de680179853d5e39814a4e7b10d8e5ca2066f1c85fda328470852a10600e74ade1e4a52c5cdc8f749eceaf4f861f8852c2f47d654e9fc88
DIST TaskCoach-1.4.6.tar.gz 2927090 BLAKE2B 24f7b2f293d34d8ef0084c7065fdf5de6b01f437c971ad0d504125793ec71581ccedbd6db0701653db409ce04fb99b55f995037510daa58f10e2b15b439dc64b SHA512 f393f9e7d8422e1453a1bd711d08ba6bdcccd5634095262475538dfbd1fb7a943798b6ff197e38367cf8e6162e25fef50178458f73b76f483495d61545bec8fe
diff --git a/app-office/taskcoach/files/taskcoach-1.4.2-fix-desktop-file.patch b/app-office/taskcoach/files/taskcoach-1.4.2-fix-desktop-file.patch
deleted file mode 100644
index 9f57beb8d054..000000000000
--- a/app-office/taskcoach/files/taskcoach-1.4.2-fix-desktop-file.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From dd39524692896995daabc69c7090ecf66e64858e Mon Sep 17 00:00:00 2001
-From: Sebastian Pipping <sebastian@pipping.org>
-Date: Sun, 10 Jan 2016 01:34:13 +0100
-Subject: [PATCH] Fix .desktop file
-
-error: value "task;todo;reminder" for locale string list key "Keywords" in group "Desktop Entry" does not have a semicolon (';') as trailing character
----
- build.in/linux_common/taskcoach.desktop | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/build.in/linux_common/taskcoach.desktop b/build.in/linux_common/taskcoach.desktop
-index 9382b0b..b1a4bd1 100644
---- a/build.in/linux_common/taskcoach.desktop
-+++ b/build.in/linux_common/taskcoach.desktop
-@@ -7,4 +7,4 @@ Icon=taskcoach
- Terminal=false
- Type=Application
- Categories=Office;Calendar;
--Keywords=task;todo;reminder
-+Keywords=task;todo;reminder;
---
-2.7.0
-
diff --git a/app-office/taskcoach/taskcoach-1.4.3-r1.ebuild b/app-office/taskcoach/taskcoach-1.4.3-r1.ebuild
deleted file mode 100644
index fc81b9f5eca0..000000000000
--- a/app-office/taskcoach/taskcoach-1.4.3-r1.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1 eutils versionator
-
-MY_PN="TaskCoach"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Simple personal tasks and todo lists manager"
-HOMEPAGE="http://www.taskcoach.org https://pypi.org/project/TaskCoach/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
-LICENSE="GPL-3"
-
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="libnotify"
-
-DEPEND="
- dev-python/wxpython:3.0[${PYTHON_USEDEP}]
- || (
- >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
- >=dev-python/twisted-core-10.0
- )
-"
-RDEPEND="${DEPEND}
- x11-libs/libXScrnSaver
- libnotify? ( dev-python/notify-python[${PYTHON_USEDEP}] )
-"
-
-S="${WORKDIR}/${MY_P}"
-
-DOCS=( CHANGES.txt README.txt )
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.4.2-fix-desktop-file.patch
- epatch "${FILESDIR}"/${PN}-1.4.3-version-check.patch
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- doicon "icons.in/${PN}.png"
- make_desktop_entry ${PN}.py "Task Coach" ${PN} Office
-}