summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-04-25 22:45:02 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-04-25 22:45:33 +0300
commit1ced985fc5c89dfe573ddd52398be61f85cb8203 (patch)
tree6126cd88561da615888f633160410f0734af9a16
parentnet-misc/midentd: EAPI 6 -> 8 (diff)
downloadgentoo-1ced985fc5c89dfe573ddd52398be61f85cb8203.tar.gz
gentoo-1ced985fc5c89dfe573ddd52398be61f85cb8203.tar.bz2
gentoo-1ced985fc5c89dfe573ddd52398be61f85cb8203.zip
net-dns/idnkit: EAPI 6 -> 8
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--net-dns/idnkit/idnkit-2.3-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-dns/idnkit/idnkit-2.3-r1.ebuild b/net-dns/idnkit/idnkit-2.3-r1.ebuild
new file mode 100644
index 000000000000..d76117b8f17e
--- /dev/null
+++ b/net-dns/idnkit/idnkit-2.3-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Toolkit for Internationalized Domain Names (IDN)"
+HOMEPAGE="https://jprs.co.jp/idn/"
+SRC_URI="https://jprs.co.jp/idn/${P}.tar.bz2"
+
+LICENSE="JPRS"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="liteonly"
+RESTRICT="test"
+
+RDEPEND="virtual/libiconv"
+DEPEND="
+ ${RDEPEND}
+ dev-lang/perl
+"
+
+src_configure() {
+ econf $(use_enable liteonly)
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}