summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-08 19:22:01 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-08 19:22:01 +0100
commit1cf41a1a291f0ac3250c12710fe6dca279591346 (patch)
treea53ae429307b0e8d0d5f0032208ed9bd95e2d174
parentdev-python/google-api-core: Remove old (diff)
downloadgentoo-1cf41a1a.tar.gz
gentoo-1cf41a1a.tar.bz2
gentoo-1cf41a1a.zip
dev-python/distlib: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/distlib/Manifest1
-rw-r--r--dev-python/distlib/distlib-0.3.2.ebuild56
-rw-r--r--dev-python/distlib/files/distlib-0.3.2-py310.patch29
3 files changed, 0 insertions, 86 deletions
diff --git a/dev-python/distlib/Manifest b/dev-python/distlib/Manifest
index 83ea3006bbe5..59a80e4a647d 100644
--- a/dev-python/distlib/Manifest
+++ b/dev-python/distlib/Manifest
@@ -1,2 +1 @@
-DIST distlib-0.3.2.tar.bz2 1075843 BLAKE2B 3595dc6af53beb7ff7dc49013e6c3db3453b501b56790a953c2cfea5a73aaca71fc69de68c8121ae92ffafd32a70ffa69d768cfd42844135fd5bd6647611e090 SHA512 e033ff2ff6b760f698a20103e01d63fa87bc1839bbf44fce252284c793e10a057dac645d818a4e0a2aa8be97bb85fcf9c8706b2399c505f12a093024d11be578
DIST distlib-0.3.4.tar.bz2 1169083 BLAKE2B f1b5e5ca7d0155d204db177d9844cdff4d593be3d927bd5f9e8ad07065b52383527d3990b66c5868bb8377703d031958c5c88a9daf4f0b238903ddbea3ef6cf0 SHA512 24f8d6f5012c881ffa6bbdae7887ee5a7608ac36a83e2a96cb8a337d1ab6c896a4078028d0383165ff44be6b735aa31f7d199845d89899813be74ed00e1680e8
diff --git a/dev-python/distlib/distlib-0.3.2.ebuild b/dev-python/distlib/distlib-0.3.2.ebuild
deleted file mode 100644
index fa54b57e602c..000000000000
--- a/dev-python/distlib/distlib-0.3.2.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( python3_{7..10} pypy3 )
-
-inherit distutils-r1 vcs-snapshot
-
-DESCRIPTION="Low-level components of distutils2/packaging"
-HOMEPAGE="https://pypi.org/project/distlib/
- https://bitbucket.org/pypa/distlib/"
-# pypi has zip only :-(
-SRC_URI="
- https://bitbucket.org/pypa/distlib/get/${PV}.tar.bz2 -> ${P}.tar.bz2"
-
-LICENSE="PSF-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-IUSE="test"
-# This package's tests are extremely fragile and tend to break or hang
-# when it doesn't like metadata of packages installed on the system.
-RESTRICT="test"
-
-# pypiserver is called as external executable
-# openpyxl installs invalid metadata that breaks distlib
-BDEPEND="
- test? (
- dev-python/pypiserver
- !!<dev-python/openpyxl-3.0.3[${PYTHON_USEDEP}]
- )"
-
-src_prepare() {
- # make sure they're not used
- rm -r tests/unittest2 || die
- rm tests/pypi-server-standalone.py || die
-
- # use system pypiserver instead of broken bundled one
- eapply "${FILESDIR}"/distlib-0.3.2-system-pypiserver.py || die
- # fix tests for py310
- eapply "${FILESDIR}"/${P}-py310.patch
-
- # doesn't work with our patched pip
- sed -e '/PIP_AVAIL/s:True:False:' \
- -i tests/test_wheel.py || die
-
- distutils-r1_src_prepare
-}
-
-python_test() {
- local -x SKIP_ONLINE=1
- local -x PYTHONHASHSEED=0
- "${EPYTHON}" tests/test_all.py -v -x ||
- die "Tests failed with ${EPYTHON}"
-}
diff --git a/dev-python/distlib/files/distlib-0.3.2-py310.patch b/dev-python/distlib/files/distlib-0.3.2-py310.patch
deleted file mode 100644
index 23c3dbbe0274..000000000000
--- a/dev-python/distlib/files/distlib-0.3.2-py310.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From 5a9540cf58fc020b0c6a1d5c23b9b93d1abd2eb0 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Sat, 29 May 2021 22:08:57 +0200
-Subject: [PATCH] Fix test_is_compatible to fix Python 3.10 support
-
-On Python 3.10, PYVER is py310 which wrongly matches the original
-'py27' <= PYVER < 'py32' condition. Replace it with explicit match
-against known Python versions in this range. This is probably
-the simplest and the most future-proof solution to the problem at hand.
----
- tests/test_wheel.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/tests/test_wheel.py b/tests/test_wheel.py
-index 849e7c1..7c8f5ee 100644
---- a/tests/test_wheel.py
-+++ b/tests/test_wheel.py
-@@ -206,7 +206,7 @@ class WheelTestCase(DistlibTestCase):
-
- def test_is_compatible(self):
- fn = os.path.join(HERE, 'dummy-0.1-py27-none-any.whl')
-- if 'py27' <= PYVER < 'py32':
-+ if PYVER in ('py27', 'py30', 'py31'):
- self.assertTrue(is_compatible(fn))
- self.assertTrue(Wheel(fn).is_compatible())
- # use actual wheel names from PyPI.
---
-2.31.1
-