summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-10-27 09:07:53 +0200
committerMichał Górny <mgorny@gentoo.org>2018-10-27 09:29:51 +0200
commit1cfad8aadd257d4a15ac4b7a75a29e64bd140c23 (patch)
tree3a88dc44a13addc311c0a8ad676dd222a4e6a087
parentdev-libs/libgit2: Sec-bump to 0.26.8 (diff)
downloadgentoo-1cfad8aa.tar.gz
gentoo-1cfad8aa.tar.bz2
gentoo-1cfad8aa.zip
dev-libs/libgit2: Sec + bugfix bump to 0.27.7
Bug: https://bugs.gentoo.org/669736 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-libs/libgit2/Manifest1
-rw-r--r--dev-libs/libgit2/libgit2-0.27.7.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/dev-libs/libgit2/Manifest b/dev-libs/libgit2/Manifest
index 14155f080fae..0bbdacef74c2 100644
--- a/dev-libs/libgit2/Manifest
+++ b/dev-libs/libgit2/Manifest
@@ -1,3 +1,4 @@
DIST libgit2-0.26.7.tar.gz 4737641 BLAKE2B dd87ab3048dec361619ff0e42d19161e4b20a07d334ad42aa077b77202bf5e84b85e33a6d6668afef36a7ff23f85a68f28049e08dd7502b241e40a730a78bb44 SHA512 5ad0c514b6c1c58031029f4ada278a164cc112f25c36745973df27711f12888000c054816b65889576124e93b71ec9a1c4f4cc0b538f177d93a57bc145fea1e1
DIST libgit2-0.26.8.tar.gz 4742478 BLAKE2B 31326987961ed42740f6c0ddce6a80c278175899a62cabd65ce9eef60854553e6a91fd9947ca23945104d4e1b46f9ab0bb1a1a793d8dd87bed792528e5c32839 SHA512 efb9229b2882ac36910d75778d7431bec40f3529f2ad2dd6a950d5580ceb0d4dd798242a422ea6cbb880f515df4dfbb7055a65dd5a8106696d3d458851fca56e
DIST libgit2-0.27.5.tar.gz 4775158 BLAKE2B 118af462a4969bc802451b887386e87da0f855641a774ce7460d6fe7ad9c62ce71a4b35a7461a95c7c4a96c59143c9c1acc78c5a1b21143a651491713f4fa15b SHA512 318b981456d55f60f8aa1897f1f70274329e48f09769b661eb4bbe76399071eca0fbc7deacb3191db16bc89dba8cc69a64adaf8cbc65e34a65b6e72ca122e21f
+DIST libgit2-0.27.7.tar.gz 4782856 BLAKE2B c844eca24b5053b3391ace6ebeea047bbba4fd429786e08144151109bfbd22f5c1b2609a176816a5d7eff63f1fe91122f88d89d3613dc4c770051cf095ae5ac3 SHA512 de2e266939bd40bc580603539e1156906b97299523336ddc6a66c3bec26729495bef2daa2d240b83b7e011e93852381e95a4407132b0440a5aa1e1b7642c0011
diff --git a/dev-libs/libgit2/libgit2-0.27.7.ebuild b/dev-libs/libgit2/libgit2-0.27.7.ebuild
new file mode 100644
index 000000000000..d39c0a7a0268
--- /dev/null
+++ b/dev-libs/libgit2/libgit2-0.27.7.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6,7}} )
+inherit cmake-utils python-any-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86 ~ppc-macos"
+fi
+
+DESCRIPTION="A linkable library for Git"
+HOMEPAGE="https://libgit2.github.com/"
+
+LICENSE="GPL-2-with-linking-exception"
+SLOT="0/27"
+IUSE="+curl examples gssapi libressl +ssh test +threads trace"
+
+RDEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ sys-libs/zlib
+ net-libs/http-parser:=
+ curl? (
+ !libressl? ( net-misc/curl:=[curl_ssl_openssl(-)] )
+ libressl? ( net-misc/curl:=[curl_ssl_libressl(-)] )
+ )
+ gssapi? ( virtual/krb5 )
+ ssh? ( net-libs/libssh2 )
+"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+"
+
+DOCS=( AUTHORS CONTRIBUTING.md CONVENTIONS.md README.md )
+
+src_configure() {
+ local mycmakeargs=(
+ -DLIB_INSTALL_DIR="${EPREFIX}/usr/$(get_libdir)"
+ -DBUILD_CLAR=$(usex test)
+ -DENABLE_TRACE=$(usex trace)
+ -DUSE_GSSAPI=$(usex gssapi)
+ -DUSE_SSH=$(usex ssh)
+ -DTHREADSAFE=$(usex threads)
+ -DCURL=$(usex curl)
+ )
+ cmake-utils_src_configure
+}
+
+src_test() {
+ if [[ ${EUID} -eq 0 ]] ; then
+ # repo::iterator::fs_preserves_error fails if run as root
+ # since root can still access dirs with 0000 perms
+ ewarn "Skipping tests: non-root privileges are required for all tests to pass"
+ else
+ local TEST_VERBOSE=1
+ cmake-utils_src_test -R offline
+ fi
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ if use examples ; then
+ find examples -name '.gitignore' -delete || die
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}