summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-11-22 16:52:05 +0100
committerDavid Seifert <soap@gentoo.org>2021-11-22 16:52:05 +0100
commit1d184b86516d7c090deb45394e4e2d0b643de16c (patch)
tree87f969e84c61ca88fbd7c646ade7bbeb72fa2c6d
parentdev-util/cppcheck: drop 1.88, 2.2 (diff)
downloadgentoo-1d184b86516d7c090deb45394e4e2d0b643de16c.tar.gz
gentoo-1d184b86516d7c090deb45394e4e2d0b643de16c.tar.bz2
gentoo-1d184b86516d7c090deb45394e4e2d0b643de16c.zip
dev-util/cppcheck: [QA] EROOT -> EPREFIX
Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--dev-util/cppcheck/cppcheck-2.4.1.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/dev-util/cppcheck/cppcheck-2.4.1.ebuild b/dev-util/cppcheck/cppcheck-2.4.1.ebuild
index 9130c7d88401..74102100a3f2 100644
--- a/dev-util/cppcheck/cppcheck-2.4.1.ebuild
+++ b/dev-util/cppcheck/cppcheck-2.4.1.ebuild
@@ -2,8 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{3_7,3_8,3_9} )
-inherit distutils-r1 toolchain-funcs cmake
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1 cmake
DESCRIPTION="Static analyzer of C/C++ code"
HOMEPAGE="https://github.com/danmar/cppcheck"
@@ -30,6 +31,7 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
z3? ( sci-mathematics/z3 )
"
+
PATCHES=(
"${FILESDIR}"/${PN}-2.4.1-limits.patch
)
@@ -39,12 +41,11 @@ src_prepare() {
}
src_configure() {
-
local mycmakeargs=(
-DHAVE_RULES="$(usex pcre)"
-DBUILD_GUI="$(usex qt5)"
-DUSE_Z3="$(usex z3)"
- -DFILESDIR="${EROOT}/usr/share/${PN}/"
+ -DFILESDIR="${EPREFIX}/usr/share/${PN}/"
-DENABLE_OSS_FUZZ=OFF
)
cmake_src_configure
@@ -63,7 +64,7 @@ src_compile() {
src_install() {
# it's not autotools-based, so "${ED}" here, not "${D}", bug 531760
emake install DESTDIR="${ED}" \
- FILESDIR="${EROOT}/usr/share/${PN}/"
+ FILESDIR="${EPREFIX}/usr/share/${PN}/"
insinto "/usr/share/${PN}/cfg"
doins cfg/*.cfg
@@ -75,7 +76,7 @@ src_install() {
pushd htmlreport || die
distutils-r1_src_install
popd || die
- find "${D}" -name "*.egg-info" -delete
+ find "${D}" -name "*.egg-info" -delete || die
else
rm "${ED}/usr/bin/cppcheck-htmlreport" || die
fi