summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-11-01 11:21:33 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2020-11-01 12:56:16 +0000
commit1d3b30e96e55d0b0aa33e2293faef6ca432d2ff4 (patch)
tree7d2edc752eb0aab2686f60e8d4c58c3753958260
parentdev-haskell/uniqueid: update to EAPI=7 (diff)
downloadgentoo-1d3b30e9.tar.gz
gentoo-1d3b30e9.tar.bz2
gentoo-1d3b30e9.zip
dev-haskell/uniplate: update to EAPI=7
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
-rw-r--r--dev-haskell/uniplate/metadata.xml30
-rw-r--r--dev-haskell/uniplate/uniplate-1.6.12.ebuild10
2 files changed, 5 insertions, 35 deletions
diff --git a/dev-haskell/uniplate/metadata.xml b/dev-haskell/uniplate/metadata.xml
index fd8349c40e4b..b7878815d80d 100644
--- a/dev-haskell/uniplate/metadata.xml
+++ b/dev-haskell/uniplate/metadata.xml
@@ -5,34 +5,4 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- Uniplate is library for writing simple and concise generic operations.
- Uniplate has similar goals to the original Scrap Your Boilerplate work,
- but is substantially simpler and faster. The Uniplate manual is available at
- &lt;http://community.haskell.org/~ndm/darcs/uniplate/uniplate.htm&gt;.
-
- To get started with Uniplate you should import one of the three following
- modules:
-
- * "Data.Generics.Uniplate.Data" - to quickly start writing generic functions.
- Most users should start by importing this module.
-
- * "Data.Generics.Uniplate.Direct" - a replacement for "Data.Generics.Uniplate.Data"
- with substantially higher performance (around 5 times), but requires writing
- instance declarations.
-
- * "Data.Generics.Uniplate.Operations" - definitions of all the operations defined
- by Uniplate. Both the above two modules re-export this module.
-
- In addition, some users may want to make use of the following modules:
-
- * "Data.Generics.Uniplate.Zipper" - a zipper built on top of Uniplate instances.
-
- * "Data.Generics.SYB" - users transitioning from the Scrap Your Boilerplate library.
-
- * "Data.Generics.Compos" - users transitioning from the Compos library.
-
- * "Data.Generics.Uniplate.DataOnly" - users making use of both @Data@ and @Direct@
- to avoid getting instance conflicts.
- </longdescription>
</pkgmetadata>
diff --git a/dev-haskell/uniplate/uniplate-1.6.12.ebuild b/dev-haskell/uniplate/uniplate-1.6.12.ebuild
index 27ad0ebbe345..fd0d4337b90d 100644
--- a/dev-haskell/uniplate/uniplate-1.6.12.ebuild
+++ b/dev-haskell/uniplate/uniplate-1.6.12.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-# ebuild generated by hackport 0.3.6.9999
+# ebuild generated by hackport 0.6.6.9999
#hackport: flags: +separate_syb,+typeable_fingerprint
CABAL_FEATURES="lib profile haddock hoogle hscolour"
@@ -18,9 +18,9 @@ SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE=""
-RDEPEND=">=dev-haskell/hashable-1.1.2.3:=[profile?] <dev-haskell/hashable-1.3:=[profile?]
+RDEPEND=">=dev-haskell/hashable-1.1.2.3:=[profile?]
dev-haskell/syb:=[profile?]
- >=dev-haskell/unordered-containers-0.2.1:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
+ >=dev-haskell/unordered-containers-0.2.1:=[profile?]
>=dev-lang/ghc-7.4.1:=
"
DEPEND="${RDEPEND}