summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-08-30 14:17:00 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-08-30 14:58:20 +0200
commit1d44e1110d380df8df6b397520eecb201fea4d6a (patch)
tree7f20bf8a46356f7886c4408a65da311991a33cac
parentkde-plasma/kwin: Block >=media-libs/libglvnd (diff)
downloadgentoo-1d44e111.tar.gz
gentoo-1d44e111.tar.bz2
gentoo-1d44e111.zip
kde-apps/konsole: Only emit empty() in SessionFinished()
...when in TabbedNavigation mode. KDE-Bug: https://bugs.kde.org/show_bug.cgi?id=441206 Closes: https://bugs.gentoo.org/810598 Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-apps/konsole/files/konsole-21.04.3-emit-empty-in-SessionFinished-only-in-TabbedNavigation-mode.patch53
-rw-r--r--kde-apps/konsole/konsole-21.04.3-r3.ebuild (renamed from kde-apps/konsole/konsole-21.04.3-r2.ebuild)1
-rw-r--r--kde-apps/konsole/konsole-21.08.0-r5.ebuild (renamed from kde-apps/konsole/konsole-21.08.0-r4.ebuild)1
3 files changed, 55 insertions, 0 deletions
diff --git a/kde-apps/konsole/files/konsole-21.04.3-emit-empty-in-SessionFinished-only-in-TabbedNavigation-mode.patch b/kde-apps/konsole/files/konsole-21.04.3-emit-empty-in-SessionFinished-only-in-TabbedNavigation-mode.patch
new file mode 100644
index 000000000000..d02846ace5aa
--- /dev/null
+++ b/kde-apps/konsole/files/konsole-21.04.3-emit-empty-in-SessionFinished-only-in-TabbedNavigation-mode.patch
@@ -0,0 +1,53 @@
+From 2684bc7fa5ac0b740b3e8661c3a0ae0136fde0a7 Mon Sep 17 00:00:00 2001
+From: Ahmad Samir <a.samirh78@gmail.com>
+Date: Sun, 22 Aug 2021 20:02:52 +0200
+Subject: [PATCH] Only emit empty() in SessionFinished() when in
+ TabbedNavigation mode
+
+empty() is emitted so that MainWindow calls close() and we get rid of the
+colours-flashing bug when closing the last session/tab in a window, see
+commit bbec72250d080. However all that isn't relevant when we are in
+konsole Part mode, where there are no tabs or MainWindows.
+
+This fixes a crash in Dolphin when closing its window while the embedded
+Konsole Part is open. The crash would happen as calling
+ViewContainer::currentTabViewCount() would end up in the ViewSplitter code
+path, which is no-op in Konsole Part.
+
+To test:
+- Open dolphin, make sure the terminal panel isn't open to begin with
+- open the terminal panel
+- close the dolphin window while the terminal panel is open
+
+BUG: 441206
+FIXED-IN: 21.08.1
+---
+ src/ViewManager.cpp | 12 +++++++-----
+ 1 file changed, 7 insertions(+), 5 deletions(-)
+
+diff --git a/src/ViewManager.cpp b/src/ViewManager.cpp
+index 92d2951fc..2ba77e9f0 100644
+--- a/src/ViewManager.cpp
++++ b/src/ViewManager.cpp
+@@ -494,11 +494,13 @@ void ViewManager::sessionFinished()
+ return;
+ }
+
+- // The last session/tab, and only one view (no splits), emit empty()
+- // so that close() is called in MainWindow, fixes #432077
+- if (_viewContainer->count() == 1 && _viewContainer->currentTabViewCount() == 1) {
+- Q_EMIT empty();
+- return;
++ if (_navigationMethod == TabbedNavigation) {
++ // The last session/tab, and only one view (no splits), emit empty()
++ // so that close() is called in MainWindow, fixes #432077
++ if (_viewContainer->count() == 1 && _viewContainer->currentTabViewCount() == 1) {
++ Q_EMIT empty();
++ return;
++ }
+ }
+
+ auto *session = qobject_cast<Session *>(sender());
+--
+GitLab
+
diff --git a/kde-apps/konsole/konsole-21.04.3-r2.ebuild b/kde-apps/konsole/konsole-21.04.3-r3.ebuild
index c95192f968c4..8ebbdcdf1dd7 100644
--- a/kde-apps/konsole/konsole-21.04.3-r2.ebuild
+++ b/kde-apps/konsole/konsole-21.04.3-r3.ebuild
@@ -54,6 +54,7 @@ RDEPEND="${DEPEND}"
PATCHES=(
"${FILESDIR}/${P}-no-flash-on-session-close.patch" # bug 807933
"${FILESDIR}/${P}-dont-close-window-while-split.patch" # bug 808510
+ "${FILESDIR}/${P}-emit-empty-in-SessionFinished-only-in-TabbedNavigation-mode.patch" # bug 810598
)
src_prepare() {
diff --git a/kde-apps/konsole/konsole-21.08.0-r4.ebuild b/kde-apps/konsole/konsole-21.08.0-r5.ebuild
index d4600f096a87..22a1835a1ffc 100644
--- a/kde-apps/konsole/konsole-21.08.0-r4.ebuild
+++ b/kde-apps/konsole/konsole-21.08.0-r5.ebuild
@@ -53,6 +53,7 @@ RDEPEND="${DEPEND}"
PATCHES=(
"${FILESDIR}/${PN}-21.04.3-no-flash-on-session-close.patch" # bug 807933
"${FILESDIR}/${PN}-21.04.3-dont-close-window-while-split.patch" # bug 808510
+ "${FILESDIR}/${PN}-21.04.3-emit-empty-in-SessionFinished-only-in-TabbedNavigation-mode.patch" # bug 810598
"${FILESDIR}/${P}-fix-crash-w-blur.patch" # bug 807905, fixed in 21.08.1
"${FILESDIR}/${P}-fix-KXmlGUI-toolbars-and-MainWindow-size.patch" # KDE-bugs 430036, 439339
"${FILESDIR}/${P}-fix-MainWindow-size-w-o-saved-size.patch" # KDE-bug 437791