summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-17 07:20:38 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-17 07:58:55 +0200
commit1d4bd47ee1a57b8edf2a69fafbabe30ee0ef464e (patch)
tree70aed2617d9807f8634fe038b594cec221e20e4c
parentdev-python/virtualenv: Bump to 20.23.1 (diff)
downloadgentoo-1d4bd47ee1a57b8edf2a69fafbabe30ee0ef464e.tar.gz
gentoo-1d4bd47ee1a57b8edf2a69fafbabe30ee0ef464e.tar.bz2
gentoo-1d4bd47ee1a57b8edf2a69fafbabe30ee0ef464e.zip
dev-python/tox: Bump to 4.6.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/tox/Manifest1
-rw-r--r--dev-python/tox/tox-4.6.2.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/dev-python/tox/Manifest b/dev-python/tox/Manifest
index d227f90ac110..7a9f0239964b 100644
--- a/dev-python/tox/Manifest
+++ b/dev-python/tox/Manifest
@@ -3,3 +3,4 @@ DIST tox-4.5.1.tar.gz 170137 BLAKE2B 38ab00eb577e66211db0ecf8931087a8c5a14f8219e
DIST tox-4.5.2.tar.gz 170336 BLAKE2B 1dcd2bbd7d153dbf0ac7bb48cdd1826d5fb915b7ef6d30a943138e06bb5d82d67db551f8c6d0342a5a81d91ddfd7da6ad8272fc016eaea27bcd4d69f6be9c605 SHA512 44a6c9821975205258402eaaa2010a0acde98190c77db0361da6c67d793de90871786fe2d78c6c9ee83100d7399e1eac857e2edaf94c64c81fb535ff871a363c
DIST tox-4.6.0.tar.gz 170401 BLAKE2B ae9decd66677fc4e0422687dcd166a27df2f5617c4dbad1d99762542e0d7e1cbcb27892fce74217f85d3e93176475fa39a22a6dd99ccf141a12832862b436a02 SHA512 465db889630d1aa36329b41cf91537e7ca27fe0901b77b8b24d180ab854f2b7c062ae62bdcc931a33235b617e7c709d9290f0769b133b5cd40e398aea9a8d918
DIST tox-4.6.1.tar.gz 172090 BLAKE2B ee86b8972ee273f07ab0197ab2f0b6ce4505206eebc412f6ec68007e1cf5ac270662e4cb61aa6eb5b08df07a5b20a28c498f9e730fe08fd04339ba918a7712e5 SHA512 b6571790275ee6d7f33dfd72c587b70476fc4ea0798a5331831bea69087cacd21eed546197bfb4a32cb4fe182b63b759977f194e19b56fb346ed251a00be9d6b
+DIST tox-4.6.2.tar.gz 172333 BLAKE2B 0fa9e7782eb18b525ff7f226b0fa9b8001f69f8b620b86a19bc2c19c349b2c8c7440a1de220387bccaa7a9044796db57ae63d16851c98a73ced2c495a01b5f3e SHA512 3e4663972f8c51a634f00c57c8b9b6704a628e912ef2e1854a8dfbd7bce13e44822984af9f69cb5b8a306ede545a565044cfeb8803cff41a530de7958fc07878
diff --git a/dev-python/tox/tox-4.6.2.ebuild b/dev-python/tox/tox-4.6.2.ebuild
new file mode 100644
index 000000000000..a18298633f2c
--- /dev/null
+++ b/dev-python/tox/tox-4.6.2.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="virtualenv-based automation of test activities"
+HOMEPAGE="
+ https://tox.readthedocs.io/
+ https://github.com/tox-dev/tox/
+ https://pypi.org/project/tox/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/cachetools-5.3.1[${PYTHON_USEDEP}]
+ >=dev-python/chardet-5.1[${PYTHON_USEDEP}]
+ >=dev-python/colorama-0.4.6[${PYTHON_USEDEP}]
+ >=dev-python/filelock-3.12.2[${PYTHON_USEDEP}]
+ >=dev-python/packaging-23.1[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-3.5.3[${PYTHON_USEDEP}]
+ >=dev-python/pluggy-1[${PYTHON_USEDEP}]
+ >=dev-python/pyproject-api-1.5.2[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-2.0.1[${PYTHON_USEDEP}]
+ ' 3.{9..10})
+ >=dev-python/virtualenv-20.23.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/hatch-vcs-0.3[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/build-0.10[${PYTHON_USEDEP}]
+ >=dev-python/distlib-0.3.6[${PYTHON_USEDEP}]
+ >=dev-python/flaky-3.7[${PYTHON_USEDEP}]
+ >=dev-python/psutil-5.9.5[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-3.11.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-3.3.1[${PYTHON_USEDEP}]
+ >=dev-python/re-assert-1.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/time-machine-2.10[${PYTHON_USEDEP}]
+ ' 'python*')
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # devpi_process is not packaged, and has lots of dependencies
+ cat > "${T}"/devpi_process.py <<-EOF || die
+ def IndexServer(*args, **kwargs): raise NotImplementedError()
+ EOF
+
+ local -x PYTHONPATH=${T}:${PYTHONPATH}
+ local EPYTEST_DESELECT=(
+ # Internet
+ tests/tox_env/python/virtual_env/package/test_package_cmd_builder.py::test_build_wheel_external
+ )
+ local EPYTEST_IGNORE=(
+ # requires devpi*
+ tests/test_provision.py
+ )
+
+ [[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
+ 'tests/tox_env/python/pip/test_pip_install.py::test_constrain_package_deps[explicit-True-True]'
+ 'tests/tox_env/python/pip/test_pip_install.py::test_constrain_package_deps[requirements-True-True]'
+ 'tests/tox_env/python/pip/test_pip_install.py::test_constrain_package_deps[constraints-True-True]'
+ 'tests/tox_env/python/pip/test_pip_install.py::test_constrain_package_deps[explicit+requirements-True-True]'
+ 'tests/tox_env/python/pip/test_pip_install.py::test_constrain_package_deps[requirements_indirect-True-True]'
+ 'tests/tox_env/python/pip/test_pip_install.py::test_constrain_package_deps[requirements_constraints_indirect-True-True]'
+ )
+
+ epytest
+}