summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOskari Pirhonen <xxc3ncoredxx@gmail.com>2023-03-03 00:49:35 -0600
committerSam James <sam@gentoo.org>2023-03-04 07:18:09 +0000
commit1d4c8dd11eaf466cfd5d5bdb633573b12b48153d (patch)
tree65a9b254403ee501a0ebea701468c835f2efb9bd
parentapp-editors/gvim: configure implicit function declarations (diff)
downloadgentoo-1d4c8dd11eaf466cfd5d5bdb633573b12b48153d.tar.gz
gentoo-1d4c8dd11eaf466cfd5d5bdb633573b12b48153d.tar.bz2
gentoo-1d4c8dd11eaf466cfd5d5bdb633573b12b48153d.zip
app-editors/vim: configure implicit function declarations
Ignore implicit function declarations for platform-specific functions, `acl()` is for Solaris and `statacl()` is for AIX. Closes: https://bugs.gentoo.org/898452 Signed-off-by: Oskari Pirhonen <xxc3ncoredxx@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-editors/vim/vim-9.0.1000.ebuild8
-rw-r--r--app-editors/vim/vim-9.0.1157.ebuild8
-rw-r--r--app-editors/vim/vim-9.0.1363.ebuild8
-rw-r--r--app-editors/vim/vim-9999.ebuild8
4 files changed, 32 insertions, 0 deletions
diff --git a/app-editors/vim/vim-9.0.1000.ebuild b/app-editors/vim/vim-9.0.1000.ebuild
index c3de4d218ee4..556785a2b235 100644
--- a/app-editors/vim/vim-9.0.1000.ebuild
+++ b/app-editors/vim/vim-9.0.1000.ebuild
@@ -75,6 +75,14 @@ if [[ ${PV} != 9999* ]]; then
)
fi
+# platform-specific checks (bug #898452):
+# - acl() -- Solaris
+# - statacl() -- AIX
+QA_CONFIG_IMPL_DECL_SKIP=(
+ 'acl'
+ 'statacl'
+)
+
pkg_setup() {
# people with broken alphabets run into trouble. bug #82186.
unset LANG LC_ALL
diff --git a/app-editors/vim/vim-9.0.1157.ebuild b/app-editors/vim/vim-9.0.1157.ebuild
index ebd71300ee4c..c4bd8dd86b3b 100644
--- a/app-editors/vim/vim-9.0.1157.ebuild
+++ b/app-editors/vim/vim-9.0.1157.ebuild
@@ -75,6 +75,14 @@ if [[ ${PV} != 9999* ]]; then
)
fi
+# platform-specific checks (bug #898452):
+# - acl() -- Solaris
+# - statacl() -- AIX
+QA_CONFIG_IMPL_DECL_SKIP=(
+ 'acl'
+ 'statacl'
+)
+
pkg_setup() {
# people with broken alphabets run into trouble. bug #82186.
unset LANG LC_ALL
diff --git a/app-editors/vim/vim-9.0.1363.ebuild b/app-editors/vim/vim-9.0.1363.ebuild
index 40a78fc412a4..0e985e6afed2 100644
--- a/app-editors/vim/vim-9.0.1363.ebuild
+++ b/app-editors/vim/vim-9.0.1363.ebuild
@@ -75,6 +75,14 @@ if [[ ${PV} != 9999* ]]; then
)
fi
+# platform-specific checks (bug #898452):
+# - acl() -- Solaris
+# - statacl() -- AIX
+QA_CONFIG_IMPL_DECL_SKIP=(
+ 'acl'
+ 'statacl'
+)
+
pkg_setup() {
# people with broken alphabets run into trouble. bug #82186.
unset LANG LC_ALL
diff --git a/app-editors/vim/vim-9999.ebuild b/app-editors/vim/vim-9999.ebuild
index 40a78fc412a4..0e985e6afed2 100644
--- a/app-editors/vim/vim-9999.ebuild
+++ b/app-editors/vim/vim-9999.ebuild
@@ -75,6 +75,14 @@ if [[ ${PV} != 9999* ]]; then
)
fi
+# platform-specific checks (bug #898452):
+# - acl() -- Solaris
+# - statacl() -- AIX
+QA_CONFIG_IMPL_DECL_SKIP=(
+ 'acl'
+ 'statacl'
+)
+
pkg_setup() {
# people with broken alphabets run into trouble. bug #82186.
unset LANG LC_ALL