summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-09-25 15:52:08 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-09-25 15:55:07 -0700
commit1d59fd192f021ad6f4b2b70a6cc058524c57fbaa (patch)
tree3df9bb80ad984e205b92db7ba1ddd7d95f055465
parentdev-python/grpcio-tools: bump to 1.32.0 (diff)
downloadgentoo-1d59fd19.tar.gz
gentoo-1d59fd19.tar.bz2
gentoo-1d59fd19.zip
dev-python/grpcio-testing: bump to 1.32.0
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
-rw-r--r--dev-python/grpcio-testing/Manifest1
-rw-r--r--dev-python/grpcio-testing/grpcio-testing-1.32.0.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/grpcio-testing/Manifest b/dev-python/grpcio-testing/Manifest
index 9d4be3254adb..a094e7ae5dee 100644
--- a/dev-python/grpcio-testing/Manifest
+++ b/dev-python/grpcio-testing/Manifest
@@ -1 +1,2 @@
DIST grpcio-testing-1.28.1.tar.gz 17127 BLAKE2B 494e232d4a4cf098cefa0948868f0610732d1aeb7c788d1481ad2693394767d73a74bfda49cb8c892f6f246f47b18c016318b5eefe3509fdc87be5649c253a17 SHA512 89c3aa5528e1f243a435997266a210ba6e287bca1401931689eb51f258a51768eb25a34c095d383dfcac7d446865535c48aefa0e37b4844bbb92214c7f431068
+DIST grpcio-testing-1.32.0.tar.gz 16814 BLAKE2B 70205dd8857256c9c4de8c7a5d115620b908deb4da35fc3cb77d9a93bd42ece34d6fcd2d32d587f8c3ede9bf49e61b9d37aac36ebc1fddbbd6e3ff2ce83809f1 SHA512 3ee10912a090287d3f039f350b11b8fc2ed656939e02a3e616911fd1af838e3f3570a7b3444c0ef54a25797a61edde87d545a9b9cabaf251a862b94100a45473
diff --git a/dev-python/grpcio-testing/grpcio-testing-1.32.0.ebuild b/dev-python/grpcio-testing/grpcio-testing-1.32.0.ebuild
new file mode 100644
index 000000000000..b27dfa6488ae
--- /dev/null
+++ b/dev-python/grpcio-testing/grpcio-testing-1.32.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Testing utilities for gRPC Python"
+HOMEPAGE="https://grpc.io"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ ~dev-python/grpcio-${PV}[${PYTHON_USEDEP}]
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}"