summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2021-12-30 21:29:52 +0100
committerSam James <sam@gentoo.org>2022-01-02 07:02:57 +0000
commit1d5d1d1083c35580ba71c0fe62d5b2582a0859a3 (patch)
tree778a7e6c825a8554e03c8ee78c11d8430981d23c
parentsci-geosciences/grass: rename patch file (diff)
downloadgentoo-1d5d1d1083c35580ba71c0fe62d5b2582a0859a3.tar.gz
gentoo-1d5d1d1083c35580ba71c0fe62d5b2582a0859a3.tar.bz2
gentoo-1d5d1d1083c35580ba71c0fe62d5b2582a0859a3.zip
sci-geosciences/grass: update live ebuild
* add opengl use flag * bump EAPI Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sci-geosciences/grass/grass-9999.ebuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/sci-geosciences/grass/grass-9999.ebuild b/sci-geosciences/grass/grass-9999.ebuild
index e91faa8e4ab6..f2d4abfd423d 100644
--- a/sci-geosciences/grass/grass-9999.ebuild
+++ b/sci-geosciences/grass/grass-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
PYTHON_COMPAT=( python3_{8,9} )
PYTHON_REQ_USE="sqlite" # bug 572440
@@ -17,10 +17,11 @@ HOMEPAGE="https://grass.osgeo.org/"
EGIT_REPO_URI="https://github.com/OSGeo/grass.git"
LICENSE="GPL-2"
-SLOT="0/7.9"
-IUSE="blas cxx fftw geos lapack liblas mysql netcdf nls odbc opencl openmp png postgres readline sqlite threads tiff truetype X zstd"
+SLOT="0/8.0"
+IUSE="blas cxx fftw geos lapack liblas mysql netcdf nls odbc opencl opengl openmp png postgres readline sqlite threads tiff truetype X zstd"
REQUIRED_USE="
- ${PYTHON_REQUIRED_USE}"
+ ${PYTHON_REQUIRED_USE}
+ opengl? ( X )"
RDEPEND="
${PYTHON_DEPS}
@@ -42,13 +43,14 @@ RDEPEND="
virtual/blas[eselect-ldso(+)]
)
fftw? ( sci-libs/fftw:3.0= )
- geos? ( sci-libs/geos )
+ geos? ( sci-libs/geos:= )
lapack? ( virtual/lapack[eselect-ldso(+)] )
liblas? ( sci-geosciences/liblas )
mysql? ( dev-db/mysql-connector-c:= )
netcdf? ( sci-libs/netcdf:= )
odbc? ( dev-db/unixODBC )
opencl? ( virtual/opencl )
+ opengl? ( virtual/opengl )
png? ( media-libs/libpng:0= )
postgres? ( >=dev-db/postgresql-8.4:= )
readline? ( sys-libs/readline:0= )
@@ -57,7 +59,7 @@ RDEPEND="
truetype? ( media-libs/freetype:2 )
X? (
dev-python/wxpython:4.0
- x11-libs/cairo[X,opengl]
+ x11-libs/cairo[X,opengl?]
x11-libs/libICE
x11-libs/libSM
x11-libs/libX11
@@ -150,6 +152,7 @@ src_configure() {
$(use_with mysql)
$(use_with mysql mysql-includes "${EPREFIX}"/usr/include/mysql)
$(use_with sqlite)
+ $(use_with opengl)
$(use_with odbc)
$(use_with fftw)
$(use_with blas)