summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-08 07:15:15 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-08 07:34:56 +0200
commit1d65a112e8dd2322e109698f4acefbd3907781f0 (patch)
tree01a278f3f90bb0980cda658c8f455c47c9d4aad9
parentdev-python/jupyter_client: Bump to 7.3.3 (diff)
downloadgentoo-1d65a112.tar.gz
gentoo-1d65a112.tar.bz2
gentoo-1d65a112.zip
dev-python/sphinx-pytest: New package, v0.0.3
New dep for dev-python/myst_parser. Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/sphinx-pytest/Manifest1
-rw-r--r--dev-python/sphinx-pytest/metadata.xml13
-rw-r--r--dev-python/sphinx-pytest/sphinx-pytest-0.0.3.ebuild30
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/sphinx-pytest/Manifest b/dev-python/sphinx-pytest/Manifest
new file mode 100644
index 000000000000..5811268458d8
--- /dev/null
+++ b/dev-python/sphinx-pytest/Manifest
@@ -0,0 +1 @@
+DIST sphinx-pytest-0.0.3.gh.tar.gz 5898 BLAKE2B 08fe98b3add1d76454c30a11f4d82bd04123e44fa5c28d420401014e5aef11354541781c0ba43a5d95c0c6fd35b12742ecf630005faae68125f5c6686c19ef59 SHA512 f1ee23fd5f320b5b4ac48638d509963638322374136d98516a17075e0d5b05cfa64107541c80daad424dfcd9e769a95dd5aa8d7f86d8ded214c9a3cdf901cf1f
diff --git a/dev-python/sphinx-pytest/metadata.xml b/dev-python/sphinx-pytest/metadata.xml
new file mode 100644
index 000000000000..d0dabef2414d
--- /dev/null
+++ b/dev-python/sphinx-pytest/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">chrisjsewell/sphinx-pytest</remote-id>
+ <remote-id type="pypi">sphinx_pytest</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sphinx-pytest/sphinx-pytest-0.0.3.ebuild b/dev-python/sphinx-pytest/sphinx-pytest-0.0.3.ebuild
new file mode 100644
index 000000000000..df38b8ee1c92
--- /dev/null
+++ b/dev-python/sphinx-pytest/sphinx-pytest-0.0.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Helpful pytest fixtures for Sphinx extensions"
+HOMEPAGE="
+ https://github.com/chrisjsewell/sphinx-pytest/
+ https://pypi.org/project/sphinx_pytest/
+"
+SRC_URI="
+ https://github.com/chrisjsewell/sphinx-pytest/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest